Oil pressure gauge or sending unit? - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 05-17-2010, 11:23 PM   #1
Newb
 
Join Date: May 2010
Posts: 6
Oil pressure gauge or sending unit?

I've just gotten a 95 YJ 2.5L and the oil pressure gauge pegs out after start up. At a very slow idle, it reads less than pegged out. Do I need most likely, a new sending unit or a new gauge? Many thanks for your help.

davidaker is offline   Quote Quick Reply
Old 05-17-2010, 11:32 PM   #2
Jeeper
 
Join Date: Apr 2010
Location: Youngstown, OHIO
Posts: 86
My bet is clean the contacts on the circuit board behind the gauge and it will be fixed. I changed the sending unit on my 91 but mine would register low around 10 highway and 0 at hot idle. Try cleaning the contacts first as its free then if needed get the sending unit ( I paid $20 at autozone for mine)

fullberg is offline   Quote Quick Reply
Old 05-18-2010, 09:40 AM   #3
kik
Jeeper
 
kik's Avatar
 
Join Date: Dec 2008
Posts: 4,833
Images: 1
Most of them do that after start up and then come back to normal after the engine warms up. If yours stays toward max when warm then you need a new sending unit.
kik is offline   Quote Quick Reply
Old 05-18-2010, 10:23 PM   #4
Newb
 
Join Date: May 2010
Posts: 6
Thanks for the replys. I did take out the cluster and cleaned and tightened the contact screws but after installation, it was doing the same thing. I'll pick up a new sending unit and put it in. Many thanks.
davidaker is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Oil Pressure Gauge - Jumping around 1992wranglersahara YJ Tech Forum 9 09-15-2011 03:12 PM
Oil Pressure Sending Unit jeep95 TJ General Discussion Forum 8 05-24-2011 10:10 AM
Oil pressure sending unit? am i screwed? AtcoTrailsINC TJ Tech Forum 11 03-15-2010 05:54 AM
Which oil pressure sending unit bspeckchaser TJ Tech Forum 1 06-26-2009 09:37 PM
new head gasket and sending unit..still have oil pressure gauge issue TXST8tj TJ General Discussion Forum 10 09-18-2008 12:37 PM



Download our Mobile App

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 03:53 AM.



Jeep, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC