Oil Pressure Guage - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 05-30-2012, 05:38 AM   #1
Jeeper
 
Maladaptive's Avatar
 
Join Date: Feb 2012
Location: Winnemucca, NV
Posts: 107
Oil Pressure Guage

My oil pressure gauge on my '81 YJ w/2.5 now pegs all the way past 80 psi before I start the engine, as soon as I turn on the ignition. I'm guessing either the gage or the sending unit. I tried looking in Chilton's for information on where the sending unit is located and could not find anything about it. How would I find out if it is the gauge or the sending unit -- or could it be something else I'm not aware of?
I changed oil about 500 miles ago, the gauge was alright after that. I just added a half quart yesterday to bring it back up to full and noticed the gauge today. I can't imagine a connection to that, but then I really know either.
Any help, suggestions, solutions?

__________________
Today, we need a nation of Minutemen, citizens who are not only prepared to take arms, but citizens who regard the preservation of freedom as the basic purpose of their daily life and who are willing to consciously work and sacrifice for that freedom. — John F. Kennedy
Maladaptive is offline   Quote
Old 05-30-2012, 07:22 AM   #2
Jeeper
 
PLHamp's Avatar
 
Join Date: Jan 2012
Location: Oak Hill, VA
Posts: 89
Sending unit is to the right when looking at the distributor. When you are looking at it from the passenger side of the engine compartment, its on a stalk like thing right behind the AC mount. Try cleaning it first but if its still bad, make sure you get a guage sending unit not a oil pressure switch.

Good luck,

Pat

PLHamp is offline   Quote
Old 05-30-2012, 11:13 AM   #3
Newb
 
JDel305's Avatar
 
Join Date: May 2012
Location: Rhode Island
Posts: 12
I had the same issue and last night I changed out the sensor...very easy and pretty cheap...its right next to the oil filter on my 89 yj. The new sensor fixed my problem right away....just dont over tighten...I found the part for 17.99 at a place called AutoZone here in RI.
JDel305 is offline   Quote
Old 05-30-2012, 03:16 PM   #4
Jeeper
 
Maladaptive's Avatar
 
Join Date: Feb 2012
Location: Winnemucca, NV
Posts: 107
Oil Pressure gauge help

Hey that's what I like -- a variety of choices, but maybe your both describing the same place in different terms. I'll have a look as soon as I get off work tonight. I should be able to find it now though.
Thanks for you help!
__________________
Today, we need a nation of Minutemen, citizens who are not only prepared to take arms, but citizens who regard the preservation of freedom as the basic purpose of their daily life and who are willing to consciously work and sacrifice for that freedom. — John F. Kennedy
Maladaptive is offline   Quote
Old 05-30-2012, 07:34 PM   #5
Jeeper
 
Kernal Clink's Avatar
 
Join Date: Jan 2012
Location: Trinity, NC
Posts: 195
Well the first problem I see is that you have an 81 YJ. Look left of the oil filter.
Kernal Clink is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 01:09 PM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC