Oil Pressure issues - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 08-30-2009, 09:23 PM   #1
Jeeper
 
Slickbr's Avatar
 
Join Date: Jan 2009
Location: North ATL, Georgia
Posts: 22
Question Oil Pressure issues

OK, here's the deal.

94 I-6 4.0 Litre, running w/ Mobil 1 synthetic, it's got about 115,000 miles. New rear main seal, recent oil change. The oil pressure sensor is new about 2000 miles ago, yet it reads 60-70 psi @ start up. If I let it warm up it still runs about 60 psi, after warm up the low end is 40 and the high is 60 or so.
I've tried restarting it after warm up, and sometimes it returns to normal readings of 30 to 50 during the course of driving.

I need some leads to follow, has anyone run into this problem?

Cheers,

Brando

__________________
'94 YJ 4.0 litre I-6 Mated to a 5 spd, shifted with a Guinness Tap handle; Ford 8.8" rear end sporting LSD w/ discs & 3.73 gears, 5 1/4" of altitude riding 33 x 12.50 15 GoodYear Wrangler DuraTrac's.

Everything else is O-ridge-in-AL!!!!
Slickbr is offline   Quote
Old 08-30-2009, 09:45 PM   #2
Jeeper
 
jpdocdave's Avatar
 
Join Date: Mar 2008
Location: beach park, il
Posts: 8,162
Images: 7
this is 100% normal.

__________________
"The danger to America is not Barack Obama but a citizenry capable of entrusting a man like him with the Presidency. It will be far easier to limit and undo the follies of an Obama presidency than to restore the necessary common sense and good judgment to a depraved electorate willing to have such a man for their president."
http://mybroadband.co.za/photos/data...re_cowbell.gif
jpdocdave is offline   Quote
Old 08-30-2009, 10:30 PM   #3
Jeeper
 
NAVYCHIEF's Avatar
 
Join Date: Sep 2008
Posts: 2,207
sounds like my 94 4.0 renegade.
__________________
1994 RENEGADE

TREAT EVERY STRESSFUL SITUATION AS A DOG WOULD.
IF YOU CAN'T EAT IT OR PLAY WITH IT,
JUST PEE ON IT AND WALK AWAY.
NAVYCHIEF is offline   Quote
Old 08-31-2009, 08:06 AM   #4
kik
Jeeper
 
kik's Avatar
 
Join Date: Dec 2008
Posts: 5,669
Images: 1
Normal. Actually your oil pressure switch is working pretty well
kik is offline   Quote
Old 08-31-2009, 04:04 PM   #5
Jeeper
 
Slickbr's Avatar
 
Join Date: Jan 2009
Location: North ATL, Georgia
Posts: 22
Must be throwing me for a loop as I replaced the pressure sensor about 2000 miles ago and was used to it reading between 30 - 50 all the time. A Jeeper friend of mine recommended I replace the sending unit as pressure was hanging out @ 60psi.

Thanks for the info.
__________________
'94 YJ 4.0 litre I-6 Mated to a 5 spd, shifted with a Guinness Tap handle; Ford 8.8" rear end sporting LSD w/ discs & 3.73 gears, 5 1/4" of altitude riding 33 x 12.50 15 GoodYear Wrangler DuraTrac's.

Everything else is O-ridge-in-AL!!!!
Slickbr is offline   Quote
Reply

Tags
4 liter , inline 6 , issue , oil , pressure

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Oil Pressure drop, DD need help quick! Under the Palms TJ Tech Forum 12 10-04-2010 03:56 PM
Low oil pressure at idle 97tjcse TJ Tech Forum 9 08-24-2009 10:12 PM
fuel pressure issues ncfirefighter217 YJ Tech Forum 0 08-03-2009 06:57 PM
Fuel Pressure Problem? Rigerator YJ Tech Forum 7 05-18-2009 09:02 AM



Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 10:48 PM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC