Oil pressure sending location? 4.2L - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 07-27-2011, 06:06 PM   #1
Jeeper
 
5double0's Avatar
 
Join Date: Jan 2011
Posts: 75
Oil pressure sending location? 4.2L

I eyeballed the motor for where the wiring for the oil pressure sender is...not seeing it and now my oil pressure gauge is pegged all the time.
I do not have a repair manual, but most of my stuff I can do no problem...any info appreciated!

OWNS:
06 Commander 4x4 3.7l
90 YJ Sahara 4.2/nuttered/108 Motorcraft 2100 w 47 jets (not quite sure if that's the best configuration yet)/soon to do the Team Rush upgrade but with my Super stock yellow coil/rhino lined/new fuel tank/pump/filter/starter/battery/coil/dizzy cap/rotor/timing at 11 btdc

Jeeps do not get stuck...the mud just hates to let them go!

5double0 is offline   Quote Quick Reply
Old 07-27-2011, 06:26 PM   #2
Supporting Member

WF Supporting Member
 
scott howard's Avatar
 
Join Date: Dec 2009
Location: wichita falls texas
Posts: 1,035
if you look at the very back of the driver side of the valve cover at the fire wall
you will see the sender and the purple wire hooked to it.
if this connection is loose or dirty it will peg your gauge.

__________________
Scott Howard
940-444-1972
scott howard is offline   Quote Quick Reply
Old 07-27-2011, 06:31 PM   #3
Jeeper
 
5double0's Avatar
 
Join Date: Jan 2011
Posts: 75
Nice! Thanks! Feel free to check out my other thread regarding the Carb!
5double0 is offline   Quote Quick Reply
Old 07-27-2011, 11:30 PM   #4
444
Jeeper
 
Join Date: Oct 2010
Posts: 203
On mine that's the temp sender. My oil pressure sender is near the distributor.
444 is offline   Quote Quick Reply
Old 07-27-2011, 11:49 PM   #5
Jeeper
 
Tat2's Avatar
 
Join Date: Jul 2010
Location: SW Oregon
Posts: 138
Quote:
Originally Posted by 444 View Post
On mine that's the temp sender. My oil pressure sender is near the distributor.
Mine too!
Tat2 is offline   Quote Quick Reply
Old 07-28-2011, 05:48 AM   #6
Jeeper
 
StinkyMud's Avatar
 
Join Date: Jul 2010
Location: Roselle, IL
Posts: 485
Images: 7
Quote:
Originally Posted by 444 View Post
On mine that's the temp sender. My oil pressure sender is near the distributor.
Same here.
__________________
"Here, hold my beer. I wanna try something"

Jeff & Angel http://ddoffroad.com/
- 2004 TJ SE 2.4 5 speed, 3" lift with 31's
- 1989 YJ 4.2 5 speed, with 7" lift and 33's
StinkyMud is offline   Quote Quick Reply
Old 07-28-2011, 03:12 PM   #7
kik
Jeeper
 
kik's Avatar
 
Join Date: Dec 2008
Posts: 4,631
Images: 1
Quote:
Originally Posted by StinkyMud View Post
Same here.
Passenger side almost at the firewall.
kik is offline   Quote Quick Reply
Old 07-28-2011, 06:38 PM   #8
Jeeper
 
5double0's Avatar
 
Join Date: Jan 2011
Posts: 75
Thanks for the replies! Mine is a 90 YJ Sahara 4.2L so I did the wire at the driver's side and cleaned and re-seated but the gauge was still pegged, so I'll check the passenger side near Dizzy. Makes sense because shortly after I adjusted timing, the gauge was acting funny like a wire was loose. Can anyone post a pic?
5double0 is offline   Quote Quick Reply
Old 07-29-2011, 05:56 AM   #9
Jeeper
 
StinkyMud's Avatar
 
Join Date: Jul 2010
Location: Roselle, IL
Posts: 485
Images: 7
Here ya go.. This is taken just after we purchased it.. Little on the "dirty" side. Anyway, left side of picture, has orange(ish) looking wire going to it. You can also see the curly oil line that goes from the sender to the gauge. FYI, mine is an aftermarket gauge however the sending unit should look similar.

__________________
"Here, hold my beer. I wanna try something"

Jeff & Angel http://ddoffroad.com/
- 2004 TJ SE 2.4 5 speed, 3" lift with 31's
- 1989 YJ 4.2 5 speed, with 7" lift and 33's
StinkyMud is offline   Quote Quick Reply
Old 07-29-2011, 05:47 PM   #10
Supporting Member

WF Supporting Member
 
scott howard's Avatar
 
Join Date: Dec 2009
Location: wichita falls texas
Posts: 1,035
sorry i was thinking temp sensor for some reason..lol
__________________
Scott Howard
940-444-1972
scott howard is offline   Quote Quick Reply
Old 07-31-2011, 12:57 PM   #11
Jeeper
 
5double0's Avatar
 
Join Date: Jan 2011
Posts: 75
Ok. I unhooked an re attached that and still pegged. However, My wire looks to be centered on the terminal and yours looks offset, so perhaps I'm not actually making contact. I will redo it and advise. Thanks for the pic!

5double0 is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sending Unit on 88 Wrangler with 4.2L willylou81 YJ Tech Forum 3 05-21-2011 03:02 PM
Pics of oil pressure sending unit location? InfernoGirl TJ General Discussion Forum 9 04-18-2011 05:08 PM
Oil Pressure Issue, sending unit already replaced wiseguy52 TJ General Discussion Forum 3 04-13-2011 09:20 PM
Oil Pressure Sending Unit Location RSC17 YJ Tech Forum 6 11-23-2010 04:34 PM
Oil pressure sending unit? am i screwed? AtcoTrailsINC TJ Tech Forum 11 03-15-2010 04:54 AM



» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 02:01 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC