oil pressure sending unit - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 08-21-2010, 12:12 AM   #1
Newb
 
Join Date: Aug 2010
Posts: 1
oil pressure sending unit

Hello fellow jeep owners new here. I have a question about the oil sendiing unit connector. I had to replace my sending unit today, and when I reconnect the harness the little white rubber piece keeps popping out when I restart the jeep. I can't seem to find a replacement part. I tried the dealership, junkyards and autopart stores. I'm about to start pulling my hair out. Does anybody know how to fix this part or where I can get a new connector to replace the old piece. I just need the connector not the sending unit.

mwheeler is offline   Quote Quick Reply
Old 08-21-2010, 06:27 PM   #2
Jeeper
 
Join Date: Apr 2010
Location: Oxfordshire, UK
Posts: 43
The problem is that over the years different manufacturers and suppliers supply the dealerships, therefore you could have an oil or temp sender from lots of jeeps of the same year and they would all be different size and shape connections. hence problem with dealership. Is it a single spade connector, and is the spade connector the correct size. It sounds as if the white rubber piece is too large and is causing the connector to pull off the sender. If this is what is happenning I would tighten the spade connector with pliers so that the connection is tighter also I would trim the rubber bit to stop it pulling out. Once it is in place squidge some silicone sealant on it to make it waterproof. hope this is of help, good luck
tony01 is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Oil Pressure Sending Unit jeep95 TJ General Discussion Forum 8 05-24-2011 09:10 AM
oil pressure and temp sending unit wrangler yj YJ Tech Forum 3 08-05-2010 12:21 PM
Oil pressure gauge or sending unit? davidaker YJ Tech Forum 3 05-18-2010 09:23 PM
Oil pressure sending unit? am i screwed? AtcoTrailsINC TJ Tech Forum 11 03-15-2010 04:54 AM
new head gasket and sending unit..still have oil pressure gauge issue TXST8tj TJ General Discussion Forum 10 09-18-2008 11:37 AM


logo carid shop wrangler parts carid fender flares custom wheels store avs deflectors at carid
» Rates
Get low rates on auto insurance in Canada!

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 10:17 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC