Oil pump? - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 08-09-2010, 08:14 PM   #1
Newb
 
fisherman125's Avatar
 
Join Date: Mar 2010
Posts: 12
Oil pump?

My gauge usually reads 22-23 lbs at idol in my rio grandé and around 60-62 in fifth gear at 75 mph but today it all of a sudden became pegged past 80 but still settles down at idol. No matter what gear or what rpm it shoots straight past 80 lbs when I touch the accelerator help!

fisherman125 is offline   Quote
Old 08-09-2010, 08:18 PM   #2
Jeeper

WF Supporting Member
 
jeepjones's Avatar
 
Join Date: Jul 2010
Location: Canada, Eh?
Posts: 1,892
Either you've spun a bearing and the motors going to blow or your oil pressure sending unit is no good and needs to be replaced.

jeepjones is offline   Quote
Old 08-09-2010, 08:36 PM   #3
Newb
 
fisherman125's Avatar
 
Join Date: Mar 2010
Posts: 12
Well it's still running great would I notice if I spun a bearing? I'm assuming I would.. The other thing is, I had an oil leak out of
My sending unit. It was coming right outing the connector, so I replaced it and it was working fine til my ride home from about 3
Hours away.
fisherman125 is offline   Quote
Old 08-09-2010, 10:11 PM   #4
Jeeper
 
Join Date: Jun 2010
Posts: 34
as long as its not reading zero itll be fine.80 means you have pressure.it could be a little gunk in it.0 means you need to replace.i have a 94 and its been pinned at 80 for 3 years now with no problems.
shavedsasquach is offline   Quote
Old 08-09-2010, 10:30 PM   #5
Newb
 
fisherman125's Avatar
 
Join Date: Mar 2010
Posts: 12
Well I just replaced it 2 weeks ago and it was fine until today
fisherman125 is offline   Quote
Old 08-09-2010, 10:33 PM   #6
Jeeper

WF Supporting Member
 
jeepjones's Avatar
 
Join Date: Jul 2010
Location: Canada, Eh?
Posts: 1,892
Remove it and clean it out, reinstall and try it again, could be a faulty sender even if it's new.
jeepjones is offline   Quote
Old 08-09-2010, 10:35 PM   #7
Newb
 
fisherman125's Avatar
 
Join Date: Mar 2010
Posts: 12
Right good point ! Will do first thing in the am

fisherman125 is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
92 YJ 2.5 Won't start, no power to the fuel pump eyeChrs YJ Tech Forum 15 02-14-2012 05:46 PM
97 wrangler no start got spark no power to fuel pump 97rangler TJ General Discussion Forum 12 05-11-2011 11:41 PM
2000 jeep wrangler fuel pump replacement madmilitia TJ Tech Forum 16 07-08-2010 04:40 PM
No Injector Pulse, 89 Wrangler 2.5 4 cylinder friendx4 YJ Tech Forum 20 12-17-2009 02:53 PM
97 wrangler no start got spark no power to fuel pump 97rangler TJ Tech Forum 7 12-15-2009 04:19 PM



Download our Mobile App

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 06:52 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC