Old 93' power problems after warmup - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 03-17-2012, 07:28 AM   #1
Jeeper
 
Join Date: Mar 2012
Posts: 22
Old 93' power problems after warmup

Finally got my 93' YJ back on her feet, she'd been sittin for a little bit. I've noticed after 10-15 mins of driving I will start to see fluctuation in my oil pressure from 50-10. Losing some power in higher gears, what should I look for????? thanks

VincentC804 is offline   Quote Quick Reply
Old 03-17-2012, 09:31 AM   #2
Jeeper
 
Join Date: Aug 2011
Location: north of St.Franisville La.
Posts: 2,071
Send a message via Yahoo to Nubby55
run some sea foam in the oil, may have stuck rings. then change the oil and filter, try 20/50.

Nubby55 is offline   Quote Quick Reply
Old 03-18-2012, 08:18 PM   #3
Jeeper
 
Join Date: Mar 2012
Posts: 22
sea foam? Im dumb sorry
VincentC804 is offline   Quote Quick Reply
Old 03-18-2012, 10:16 PM   #4
Jeeper
 
Master4th's Avatar
 
Join Date: Mar 2012
Posts: 341
Seafoam is a oil/gasoline addative.
Master4th is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Manual (6-Speed) JK Owners :: Please Vote :: Problems / No-Problems Rooster76 JK General Discussion Forum 259 Today 09:09 PM
Power to the stereo problems JLaw1443 YJ Tech Forum 19 03-22-2012 08:46 AM
changed 93 fuel pump ,wont start!! 4bratsdad YJ Tech Forum 20 03-17-2012 08:41 PM
New to forum/93'Jeep Wrangler VincentC804 WF New Member Check In 10 03-17-2012 10:41 AM
Nothing but Electrical Problems Kimberly Bosley WF New Member Check In 7 03-17-2012 04:07 AM



» Featured Product

All times are GMT -5. The time now is 09:26 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC