Overheating? Turns out it was the sending unit! - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 02-16-2011, 10:21 AM   #1
First Aid technician!

WF Supporting Member
 
joshd4's Avatar
 
Join Date: Jan 2011
Location: NE GA
Posts: 107
Overheating? Turns out it was the sending unit!

I just installed new lifters, pivots and cleaned up the motor. Also new head gasket and coolant. Well, my old temp sending unit on the back of the motor for my guage was broke so i decided to replace it. the new one looked identical but when the jeep was all together as soon as it would get warm the guage would peg out! Scared the crap out of me. I reburped my system and checked the oil many times thinking something major was wrong. Well, low and behold i put my old sending unit back in and it reads the right temp. The box says it fits a 2.5 but the site said that it would work in both a 2.5 and a 4.0! WRONG!!!! So if anyone that has a 2.5 wants a new sending unit let me know. lol. I can't take it back because it was used for about 2 mins. I wanted to post this in case others have this problem. I would suggest checking your new sending unit.

I have a 1995 4.0 yj.

__________________
Failure is not an option. It is a privilege reserved only for those who try
joshd4 is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Temperature Sending Unit YJ94Runner YJ Tech Forum 3 06-20-2011 11:45 AM
Oil leak at Oil Sending Unit Daysailor YJ Tech Forum 2 08-21-2010 07:38 PM
oil pressure sending unit mwheeler YJ Tech Forum 1 08-21-2010 07:27 PM
Oil pressure sending unit? am i screwed? AtcoTrailsINC TJ Tech Forum 11 03-15-2010 05:54 AM
new head gasket and sending unit..still have oil pressure gauge issue TXST8tj TJ General Discussion Forum 10 09-18-2008 12:37 PM



Download our Mobile App

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 01:05 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC