Power issues - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 08-09-2011, 08:44 PM   #1
Jeeper
 
Join Date: Aug 2011
Posts: 20
Power issues

Over the weekend i went out on a few trails and through a little mud. On my way back home my rear driveshaft dropped out. I replaced the 2 u joints and thats all good now. When i went to start my jeep it kept stuttering. Found out that my distributor where it attaches to the motor was cracked. Got that replaced and now its hard to get it even started. When i get it started, it idles low and when u drive it, it doesnt seem to be gettin enough power. Had my mechanic lookk at it and he said it could be the fuel filter. Tried that and still didnt solve the problem. He checked my fuel pressure and it was at mid 20's while ideling and barely reached 30 on throttle. What else could it be? He mentioned that it might be the fuel pump.

94whiteyj is offline   Quote
Old 08-09-2011, 09:41 PM   #2
Jeeper
 
draarong2004's Avatar
 
Join Date: May 2011
Posts: 499
assuming you looked at your air filter and made sure it wasn't clogged....hrmm
the pump could be going out, it should be around 49 +/- 2 from what i've found online, haven't had a chance to check my repair book, 30 should be more than enough for it to run right though...did you check your air filter?...also there's a filter in the tank as well...assuming you didn't replace that one

draarong2004 is offline   Quote
Old 08-10-2011, 06:09 AM   #3
Jeeper
 
Join Date: Aug 2011
Posts: 20
I looked at the air filter and it needs to be replaced. Goin to do that. I took it out and tried running it without a filter and still had a hell of a time just trying to get it turned over and running. It still idles low and doesnt feel like its getting enough pressure. Hopefully i can get around to checking the other filter in the tank
94whiteyj is offline   Quote
Old 08-10-2011, 06:51 AM   #4
Jeeper
 
draarong2004's Avatar
 
Join Date: May 2011
Posts: 499
whats the oil look like? trans fluid/trasfer case as well
draarong2004 is offline   Quote
Old 08-10-2011, 11:10 AM   #5
Jeeper
 
Join Date: Aug 2011
Posts: 20
I checked all the fluids and they all look fine and are clean.
94whiteyj is offline   Quote
Old 08-10-2011, 11:20 AM   #6
2xs
Cali Smog Nazi.

WF Supporting Member
 
2xs's Avatar
 
Join Date: Jun 2011
Location: Santa Rosa, Ca.
Posts: 2,705
When you replaced your distributor, did you clock it correctly? you get the firing order correct?
Something is bugging me about that distributor, id look there again. you had a stuttering problem, replaced it now you have low power....

What engine?

Water in the fuel?

Air filter and fuel have been discussed, but im thinking you need more fuel pressure then you seem to have.
2xs is offline   Quote
Old 08-10-2011, 03:38 PM   #7
Jeeper
 
Join Date: Aug 2011
Posts: 20
Ive had a my mechanic look over it and distribtor is right on where its supposed to be. I have the 4.0. Checked the gas and its clean, no water in it.
94whiteyj is offline   Quote
Old 08-11-2011, 07:47 AM   #8
Jeeper
 
Thuone's Avatar
 
Join Date: Apr 2010
Location: Ocala, FL
Posts: 160
Shot in the dark, did you knock off any vacuum lines while screwing around in there? Listen close for a suck sound. I accidently popped one off while putting my lift on afterwards it kept wanting to die while idling I had to give it gas to keep her going.
__________________
Just
Empty
Every
Pocket
Thuone is offline   Quote
Old 08-12-2011, 07:35 PM   #9
Jeeper
 
Join Date: Aug 2011
Posts: 20
So i replaced the fuel pump and im still haveing trouble starting the jeep. And im still gettin low fuel pressure. Im not sure on what to do now!!
94whiteyj is offline   Quote
Old 08-12-2011, 08:59 PM   #10
Jeeper
 
draarong2004's Avatar
 
Join Date: May 2011
Posts: 499
did you try blowing out the fuel lines?
have the fuel pressure regulator checked?

when it cranks, is it a hard crank? if so maybe the flywheel?

draarong2004 is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
92 YJ 2.5 Won't start, no power to the fuel pump eyeChrs YJ Tech Forum 15 02-14-2012 04:46 PM
Power tools or Hand tools? Jeepin9910 Off-Topic 12 10-26-2010 12:16 PM
power package and taking doors off Yan JK General Discussion Forum 8 09-01-2010 10:16 AM
95 Yj Power Issues jeepboyz YJ Tech Forum 12 05-22-2009 04:48 PM



Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 01:04 AM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC