Power to the stereo problems - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 03-15-2012, 08:14 PM   #1
Jeeper
 
JLaw1443's Avatar
 
Join Date: Feb 2012
Location: Denver Metro
Posts: 101
Images: 14
Power to the stereo problems

I have a 1993 6cyl 4.0L wrangler. I just got a soft top on the Jeep, it was fully sealed and went to the car wash. It was a self wash and I made sure to mainly hit the body since that was what needed to be washed.

Afterwards, drove to my sister's work, parked and shut off the jeep, then went to McDonalds and went in to order. Both the short rides the stereo was working fine.

On the drive home, when I started it up the stereo was a bit low sounding so I changed the station. About a minute into driving home the stereo was crackly and cutting out, and then boom. No power.....

I checked behind the stereo (after market) and everything is dry, I turned off the Jeep and started her back up, still nothing.

I'm not an electrical person. Any help? Ideas?

__________________
________
l l ,[____],
l L | -[]lllll[]-
()_)()_)-o-)_)
Jeep: Not just a vehicle, but a lifestyle.
JLaw1443 is offline   Quote Quick Reply
Old 03-15-2012, 08:27 PM   #2
Jeeper
 
DILLIGAF's Avatar
 
Join Date: Sep 2011
Location: Cortland NY
Posts: 595
Did you check the fuses first? the radio may have a modular plug that came loose.

Or It just might have been the stereo's time to go!

Time to upgrade to a new one good luck

DILLIGAF is offline   Quote Quick Reply
Old 03-15-2012, 08:35 PM   #3
Jeeper
 
JLaw1443's Avatar
 
Join Date: Feb 2012
Location: Denver Metro
Posts: 101
Images: 14
I just got the stereo last summer.... O.O

and I'm not sure where the fuse for the stereo is...
__________________
________
l l ,[____],
l L | -[]lllll[]-
()_)()_)-o-)_)
Jeep: Not just a vehicle, but a lifestyle.
JLaw1443 is offline   Quote Quick Reply
Old 03-15-2012, 09:05 PM   #4
Jeeper
 
Master4th's Avatar
 
Join Date: Mar 2012
Posts: 341
The ACC fuse I believe is part of the stereo circuit. If your not sure just check them all, most stereos have a fuse in the back as well.
Master4th is offline   Quote Quick Reply
Old 03-15-2012, 09:12 PM   #5
Jeeper
 
JLaw1443's Avatar
 
Join Date: Feb 2012
Location: Denver Metro
Posts: 101
Images: 14
Okay, I'll check it and possibly have it replaced. Thank you. Keep the ideas coming in case that's not it lol
__________________
________
l l ,[____],
l L | -[]lllll[]-
()_)()_)-o-)_)
Jeep: Not just a vehicle, but a lifestyle.
JLaw1443 is offline   Quote Quick Reply
Old 03-15-2012, 09:16 PM   #6
Jeeper
 
Master4th's Avatar
 
Join Date: Mar 2012
Posts: 341
If thats not it you need to put the key in and turn it to acc, then take a multimeter and test your Constant power, and acc power. If both of these have 12v then your radio might be done.
Master4th is offline   Quote Quick Reply
Old 03-15-2012, 10:11 PM   #7
Jeeper
 
olbaid_83's Avatar
 
Join Date: Feb 2012
Location: Fort Worth, Texas
Posts: 269
when fuses blow the radio doesnt get crackly before hand it just shuts off. if everything around the radio is dry chances are its toast. im assuming you dont have an amp running everything.
olbaid_83 is offline   Quote Quick Reply
Old 03-15-2012, 11:18 PM   #8
Jeeper
 
JLaw1443's Avatar
 
Join Date: Feb 2012
Location: Denver Metro
Posts: 101
Images: 14
No amp. And all Fuses are in great shape it looks like.... so the radio is toast.... Great....
__________________
________
l l ,[____],
l L | -[]lllll[]-
()_)()_)-o-)_)
Jeep: Not just a vehicle, but a lifestyle.
JLaw1443 is offline   Quote Quick Reply
Old 03-16-2012, 12:55 AM   #9
Jeeper
 
Xpress's Avatar
 
Join Date: Jan 2011
Location: El Cajon
Posts: 2,585
Had this happen before, a small tiny resistor inside of the radio fried itself. Generally you can replace said resistor, but what's to stop the radio from frying again? I would get a new one, probably check for leaks first...
__________________


2.5L Genius of some sort.
Xpress is offline   Quote Quick Reply
Old 03-16-2012, 05:03 AM   #10
Jeeper
 
Gkrynick22's Avatar
 
Join Date: Feb 2012
Location: Marlborough, CT
Posts: 58
Did you pull the radio? Usually there is a fuse held in by the wiring harness clip.
Gkrynick22 is offline   Quote Quick Reply
Old 03-16-2012, 08:59 AM   #11
Jeeper
 
JLaw1443's Avatar
 
Join Date: Feb 2012
Location: Denver Metro
Posts: 101
Images: 14
The fuse in the back is in great shape too. Like I said, not good with electrical. Looks like I'm asking for a new radio for my birthday
__________________
________
l l ,[____],
l L | -[]lllll[]-
()_)()_)-o-)_)
Jeep: Not just a vehicle, but a lifestyle.
JLaw1443 is offline   Quote Quick Reply
Old 03-16-2012, 10:40 AM   #12
Sponsoring Vendor
 
Ibuildembig's Avatar
 
Join Date: Aug 2010
Location: Fruitland, Missouri
Posts: 8,369
Do you have power on your red and yellow wire on the radio? How is the black wire grounded?
Ibuildembig is online now   Quote Quick Reply
Old 03-17-2012, 12:03 AM   #13
Jeeper
 
JLaw1443's Avatar
 
Join Date: Feb 2012
Location: Denver Metro
Posts: 101
Images: 14
Idk
__________________
________
l l ,[____],
l L | -[]lllll[]-
()_)()_)-o-)_)
Jeep: Not just a vehicle, but a lifestyle.
JLaw1443 is offline   Quote Quick Reply
Old 03-17-2012, 08:34 AM   #14
Sponsoring Vendor
 
Ibuildembig's Avatar
 
Join Date: Aug 2010
Location: Fruitland, Missouri
Posts: 8,369
k, well it sounds like you need to take it to a stereo shop
Ibuildembig is online now   Quote Quick Reply
Old 03-17-2012, 08:38 AM   #15
Jeeper
 
Master4th's Avatar
 
Join Date: Mar 2012
Posts: 341
Im wondering if it got wet, remember 1! Drop of water can fry a stereo. I read a post about cleaning out your vent hose so water doesn't backflood into your heater box.
Also I noticed when looking at some blow up of stock parts that there is a water deflector behind the dash, which is apparently not in mine.
Master4th is offline   Quote Quick Reply
Old 03-17-2012, 09:39 AM   #16
Jeeper
 
Gkrynick22's Avatar
 
Join Date: Feb 2012
Location: Marlborough, CT
Posts: 58
If your jeep sees a lot of water you should buy a marine stereo. They are sealed to be water resistant.
Gkrynick22 is offline   Quote Quick Reply
Old 03-17-2012, 11:32 AM   #17
Sponsoring Vendor
 
Ibuildembig's Avatar
 
Join Date: Aug 2010
Location: Fruitland, Missouri
Posts: 8,369
Actually they are not, they have a coated circuit board.....but they still blow up
Ibuildembig is online now   Quote Quick Reply
Old 03-18-2012, 12:18 AM   #18
Jeeper
 
Xpress's Avatar
 
Join Date: Jan 2011
Location: El Cajon
Posts: 2,585
"Water resistant" as in they can handle a bit of moisture, but they can't handle being soaked.
__________________


2.5L Genius of some sort.
Xpress is offline   Quote Quick Reply
Old 03-18-2012, 12:33 AM   #19
Jeeper
 
MrHix's Avatar
 
Join Date: Mar 2012
Location: Floresville, Texas, just outside San Antonio
Posts: 150
Images: 2
dont forget speakers, if your contacts get wet and simulate both speaker wires touching it will cause the radio to short, but theres hope. Does your radio power up and just have zero sound? if so, disconnect the power harness for a couple seconds then reconnect, if it has sound then fizzles out then one of the speakers is your problem. If your radio doesnt power up @ all then one of 3 wires is not showing up for work. Red-constant, yellow-acc,- and black is ground. Just read your original post and it reads no power, if you do have all 3 then radio is done.
MrHix is offline   Quote Quick Reply
Old 03-22-2012, 08:46 AM   #20
Jeeper
 
JLaw1443's Avatar
 
Join Date: Feb 2012
Location: Denver Metro
Posts: 101
Images: 14
Thanks everyone. Done everything and stereo still won't power up. Time for a new one it looks like

__________________
________
l l ,[____],
l L | -[]lllll[]-
()_)()_)-o-)_)
Jeep: Not just a vehicle, but a lifestyle.
JLaw1443 is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2.5 to 4.0 Throttle body swap. Help!! Toms94YJ YJ Tech Forum 41 03-23-2013 11:28 AM
Getting ready to regear to 4.10's. Braveheart12JK JK General Discussion Forum 60 05-07-2012 12:46 PM
Farewell to my TJ bgmac1178 TJ General Discussion Forum 8 03-18-2012 07:51 AM
new adventure..... surfing the wf page! hunteryj93 Oregon Jeep Forum 9 03-16-2012 11:22 AM
Who has the best prices on axle gears ? hardcoretj TJ General Discussion Forum 4 03-15-2012 07:57 PM



» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 07:44 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC