question about obd1 code 17 - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today



Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 04-09-2013, 10:17 AM   #1
Jeeper
 
wasomma's Avatar
 
Join Date: Aug 2010
Location: Baltimore, MD
Posts: 925
wasomma is on a distinguished road
question about obd1 code 17

Searching around I've learned a 17 code means the engine is staying too cold because of a stuck or bad thermostat.

But my thermostat works fine on my dash, is it a different thermostat? Anyone have any tips or lessons learned changing this thing?
__________________
https://i.imgur.com/hboF5oU.jpg
wasomma is offline   Quote
Old 04-09-2013, 10:53 AM   #2
Founder, ThumbJeeps

WF Supporting Member
 
sevenservices's Avatar
 
Join Date: Sep 2009
Location: Mid-Michigan/Thumb
Posts: 4,019
sevenservices is on a distinguished road
The engine thermostat is under the top radiator hose, between it and the water pump. Should be a thermostat housing, its in there.


The thermo stays closed until the engine hits 185 or 195 or 210 depending on the rating of the thermostat you decide to go with. Mine is a 185. Therefore, when my I6 hits 185 degrees the thermostat opens and it circulates coolent through the radiator and heating system. If the engine stays below 185, it will not get hot enough to open the thermostat and circulate.

This video should help show what it invlolves:


__________________
-Chris
Founder, ThumbJeeps
"roads are boring"


1994 Wrangler YJ I6 4.0 H/O Auto 3 spd. 3:55 Gears
sevenservices is offline   Quote
Old 04-09-2013, 11:23 AM   #3
Jeeper
 
wasomma's Avatar
 
Join Date: Aug 2010
Location: Baltimore, MD
Posts: 925
wasomma is on a distinguished road
Nice post thanks! Can't watch the video right now, but I'll check it out after work. So just to double check, this means my thermostat valve is stuck open causing coolant to continuously run causing my engine to be colder than it is supposed to be? What problems could this cause? Poor fuel efficiency, bad water pump, etc?
__________________
https://i.imgur.com/hboF5oU.jpg
wasomma is offline   Quote
Old 04-09-2013, 05:58 PM   #4
Jeeper
 
Join Date: Jul 2006
Location: columbus
Posts: 2,179
rebelBullDawg325 is on a distinguished road
Send a message via AIM to rebelBullDawg325
the gauge on your dash is operated by a different sending unit. it is on the top of the engine towards the rear on the drivers side.

back to the t-stat, if it is not operating correctly, it could cause your engine to over or underheat. the computer tells the jeep to use more fuel so the engine burns hotter until it reaches 195 i believe. once it reaches that, it pulls back the fuel mixture so as not to burn as hot.
__________________
91' - 4.0L - 5spd
31" bfg at's
rebelBullDawg325 is offline   Quote
Old 04-09-2013, 06:35 PM   #5
Jeeper
 
bigtoysforbigboys's Avatar
 
Join Date: Mar 2013
Posts: 252
bigtoysforbigboys is on a distinguished road
Quote:
Originally Posted by rebelBullDawg325 View Post
the gauge on your dash is operated by a different sending unit. it is on the top of the engine towards the rear on the drivers side.

back to the t-stat, if it is not operating correctly, it could cause your engine to over or underheat. the computer tells the jeep to use more fuel so the engine burns hotter until it reaches 195 i believe. once it reaches that, it pulls back the fuel mixture so as not to burn as hot.
You have it backwards ...more fuel burns cooler but less fuel burns hotter...hints to much fuel fouling plugs and to little fuel burns up valves and pistons
bigtoysforbigboys is offline   Quote
Old 04-10-2013, 01:22 PM   #6
Jeeper
 
wasomma's Avatar
 
Join Date: Aug 2010
Location: Baltimore, MD
Posts: 925
wasomma is on a distinguished road
ok thanks guys!
wasomma is offline   Quote
Old 04-13-2013, 10:32 AM   #7
Jeeper
 
wasomma's Avatar
 
Join Date: Aug 2010
Location: Baltimore, MD
Posts: 925
wasomma is on a distinguished road
just watched the video, this looks super easy, thanks for all the info I'll knock this repair out this morning thanks guys!

wasomma is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 07:05 PM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC
« Back

Enter your email address:

Delivered by FeedBurner