Radio swap - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 08-07-2014, 07:23 PM   #1
Jeeper
 
Mishie's Avatar
 
Join Date: Feb 2014
Location: NC
Posts: 69
Images: 1
Hello all, I am putting in a new radio and not sure how to uninstall the old one. The picture below is how the wires are connected to head unit. My question is: do I cut all the wires to disconnect or am I missing something that will pop them out? Thanks!



Click image for larger version

Name:	image-4065507706.jpg
Views:	146
Size:	119.0 KB
ID:	1372609

Mishie is offline   Quote
Old 08-07-2014, 08:00 PM   #2
Jeeper
 
mijeeper80's Avatar
 
Join Date: Mar 2014
Posts: 846
Looks like you need to cut them and just hard wire them into the new deck, sometimes the speaker wires are same colors but sometimes not. Red is always constant power, blue turns deck on off when u turn the key on off, black is negative, rest of the wires will be speakers. Sometimes you will get a wire on the deck that will be for putting the antenna up and down, obviously you do not need that on a yj so clip it and put electrical tape on it.

The deck will usually label which speaker is which so run through the speakers on your yj that you want to hook up for left/front left/back so on so forth

mijeeper80 is offline   Quote
Old 08-07-2014, 08:06 PM   #3
Jeeper
 
AllMudd's Avatar
 
Join Date: Apr 2013
Location: SoCal
Posts: 1,608
Quote:
Originally Posted by mijeeper80 View Post
Looks like you need to cut them and just hard wire them into the new deck, sometimes the speaker wires are same colors but sometimes not. Red is always constant power, blue turns deck on off when u turn the key on off, black is negative, rest of the wires will be speakers. Sometimes you will get a wire on the deck that will be for putting the antenna up and down, obviously you do not need that on a yj so clip it and put electrical tape on it.

The deck will usually label which speaker is which so run through the speakers on your yj that you want to hook up for left/front left/back so on so forth
My radio the red is from Acc (turn of the key) yellow (constant batt power to keep radio and clock current) black (ground) blue (antenna) and the rest are speakers like stated
AllMudd is offline   Quote
Old 08-07-2014, 08:22 PM   #4
Jeeper
 
Mishie's Avatar
 
Join Date: Feb 2014
Location: NC
Posts: 69
Images: 1
Thanks guys! That's a tremendous help.
Mishie is offline   Quote
Old 08-07-2014, 09:02 PM   #5
Jeeper
 
mijeeper80's Avatar
 
Join Date: Mar 2014
Posts: 846
Quote:
Originally Posted by AllMudd View Post
My radio the red is from Acc (turn of the key) yellow (constant batt power to keep radio and clock current) black (ground) blue (antenna) and the rest are speakers like stated
well fml everyone I have worked on was that way. Guess wranglers decided to go all crazy
mijeeper80 is offline   Quote
Old 08-07-2014, 09:05 PM   #6
Jeeper
 
reno92's Avatar
 
Join Date: May 2013
Location: Cardiff By The Sea / Glamis
Posts: 1,467
You sure there isn't a plug somewhere down the wires. I've never seen a radio that was hard wired, they almost always have a plug. I kept my factory plug and wired it to the new radio.
reno92 is offline   Quote
Old 08-07-2014, 09:23 PM   #7
Jeeper
 
AllMudd's Avatar
 
Join Date: Apr 2013
Location: SoCal
Posts: 1,608
Quote:
Originally Posted by mijeeper80 View Post
well fml everyone I have worked on was that way. Guess wranglers decided to go all crazy
Lol my radio is set up like that not my YJ. I honestly dont know what wires are what in there. There is an adapter that I tapped into. I guess someone did the easy thing and just bought the adapter for the radio.
AllMudd is offline   Quote
Old 08-07-2014, 09:28 PM   #8
Jeeper
 
reno92's Avatar
 
Join Date: May 2013
Location: Cardiff By The Sea / Glamis
Posts: 1,467
If you can find the factory wires somehwere back there here is the color code.
1992 Jeep Wrangler Car Stereo Radio Wiring Diagram
reno92 is offline   Quote
Old 08-07-2014, 09:34 PM   #9
Jeeper

WF Supporting Member
 
Monster93's Avatar
 
Join Date: Mar 2014
Location: South Florida
Posts: 636
Images: 3
That looks like the old school Jensen aftermarket radio, the had the wires coming right out the radio,
__________________
Monster 93 Build Thread


1993 YJ. 6" BDS 38's
2010 Rubicon 5.5 Rock Krawler coilover 38's
2014 Dodge Ram sport 2" level 33's
Monster93 is offline   Quote
Old 08-08-2014, 10:47 AM   #10
Jeeper
 
Mishie's Avatar
 
Join Date: Feb 2014
Location: NC
Posts: 69
Images: 1
Quote:
Originally Posted by Monster93 View Post
That looks like the old school Jensen aftermarket radio, the had the wires coming right out the radio,
It is the Jensen....tape deck and all!
Mishie is offline   Quote
Old 08-08-2014, 11:30 AM   #11
Jeeper
 
Zack93's Avatar
 
Join Date: Feb 2011
Location: 937, Ohio
Posts: 515
There should be a connection back in the dash some where. I currently have mine out, when I go home for lunch I can take a picture of the connector for you if you'd like.
__________________
The above is not intended to offend, insult, or ridicule in any way, shape or form.
1995 YJ, 1992 MJ,1998 XJ,
تفخر الكافر -Proud Infidel
Zack93 is offline   Quote
Old 08-09-2014, 06:11 PM   #12
Jeeper
 
Zack93's Avatar
 
Join Date: Feb 2011
Location: 937, Ohio
Posts: 515
This is the connection you're looking for
Attached Thumbnails
Click image for larger version

Name:	image-543405343.jpg
Views:	67
Size:	108.5 KB
ID:	1377721  
__________________
The above is not intended to offend, insult, or ridicule in any way, shape or form.
1995 YJ, 1992 MJ,1998 XJ,
تفخر الكافر -Proud Infidel
Zack93 is offline   Quote
Old 08-14-2014, 08:08 AM   #13
Jeeper
 
Mishie's Avatar
 
Join Date: Feb 2014
Location: NC
Posts: 69
Images: 1
I'm currently on vacation and haven't had the time to actually play around with this stuff, but once back I'll look for that connection. Thanks!
Mishie is offline   Quote
Old 08-14-2014, 12:13 PM   #14
Jeeper
 
Zack93's Avatar
 
Join Date: Feb 2011
Location: 937, Ohio
Posts: 515
Quote:
Originally Posted by Mishie View Post
I'm currently on vacation and haven't had the time to actually play around with this stuff, but once back I'll look for that connection. Thanks!
Oh man, don't have fun! I'm currently doing my right now as well, if you need anything else just me know while it's fresh in my mind lol
__________________
The above is not intended to offend, insult, or ridicule in any way, shape or form.
1995 YJ, 1992 MJ,1998 XJ,
تفخر الكافر -Proud Infidel
Zack93 is offline   Quote
Old 08-15-2014, 08:12 AM   #15
Jeeper
 
Mishie's Avatar
 
Join Date: Feb 2014
Location: NC
Posts: 69
Images: 1
Ha! Will do! Well, at least the getting in touch if I need some help. As far as NOT having fun....too late.
Mishie is offline   Quote
Old 08-15-2014, 09:38 AM   #16
Jeeper
 
Zack93's Avatar
 
Join Date: Feb 2011
Location: 937, Ohio
Posts: 515
Quote:
Originally Posted by Mishie View Post
Ha! Will do! Well, at least the getting in touch if I need some help. As far as NOT having fun....too late.
Lol good that's how a vacation should be! I need me one of those...hahaha
__________________
The above is not intended to offend, insult, or ridicule in any way, shape or form.
1995 YJ, 1992 MJ,1998 XJ,
تفخر الكافر -Proud Infidel
Zack93 is offline   Quote
Old 08-16-2014, 09:50 PM   #17
Jeeper
 
Mishie's Avatar
 
Join Date: Feb 2014
Location: NC
Posts: 69
Images: 1
8 hours later, half the dash removed and a birds nest of unused wires...it's all in. The only issue is that no matter how I wire it I can't get the head unit to hold memory.
Mishie is offline   Quote
Old 08-17-2014, 07:31 AM   #18
Jeeper

WF Supporting Member
 
Monster93's Avatar
 
Join Date: Mar 2014
Location: South Florida
Posts: 636
Images: 3
Quote:
Originally Posted by Mishie View Post
8 hours later, half the dash removed and a birds nest of unused wires...it's all in. The only issue is that no matter how I wire it I can't get the head unit to hold memory.


Did you check to make sure you have both ignition power and battery power connected to the red and yellow wires to aftermarket radio?
__________________
Monster 93 Build Thread


1993 YJ. 6" BDS 38's
2010 Rubicon 5.5 Rock Krawler coilover 38's
2014 Dodge Ram sport 2" level 33's
Monster93 is offline   Quote
Old 08-17-2014, 08:31 AM   #19
Jeeper
 
Mishie's Avatar
 
Join Date: Feb 2014
Location: NC
Posts: 69
Images: 1
I'm pretty sure I did. I'm going to go back and double check. The PO cut a bunch of wires and there were a couple dead wires. The only live ones I had were a blue/white, purple/white and the black grounding wire.
Mishie is offline   Quote
Old 08-17-2014, 09:28 AM   #20
Jeeper
 
Zack93's Avatar
 
Join Date: Feb 2011
Location: 937, Ohio
Posts: 515
Quote:
Originally Posted by Monster93 View Post
Did you check to make sure you have both ignition power and battery power connected to the red and yellow wires to aftermarket radio?
This is probably you problem ^ these are actually the only wires I have hooked on mine. I have the rear sound bar and floor pods hardwired into the head unit.

Also do what you want but when my cowl leaks it drips right onto where the stereo goes. So I took out the gauges and right under neath that there is a bunch on space and I used aluminum foil to make like a little rain shield/tepee like thing. It's currently raining so we'll how it does in a bit lol
__________________
The above is not intended to offend, insult, or ridicule in any way, shape or form.
1995 YJ, 1992 MJ,1998 XJ,
تفخر الكافر -Proud Infidel
Zack93 is offline   Quote
Old 08-17-2014, 03:17 PM   #21
Jeeper
 
Mishie's Avatar
 
Join Date: Feb 2014
Location: NC
Posts: 69
Images: 1
I'm probably going to sound dumb but....what is the cowl? 😯
Mishie is offline   Quote
Old 08-17-2014, 04:17 PM   #22
Jeeper
 
Zack93's Avatar
 
Join Date: Feb 2011
Location: 937, Ohio
Posts: 515
Dis (see photo)

Also just checked and the wet stop isn't there on the trans tunnel and there's a new wet spot on the passenger side. So I'll probably try and fix that next week maybe
Attached Thumbnails
Click image for larger version

Name:	image-1686464181.jpg
Views:	23
Size:	122.6 KB
ID:	1401186  
__________________
The above is not intended to offend, insult, or ridicule in any way, shape or form.
1995 YJ, 1992 MJ,1998 XJ,
تفخر الكافر -Proud Infidel
Zack93 is offline   Quote
Old 08-18-2014, 07:27 AM   #23
Jeeper
 
Mishie's Avatar
 
Join Date: Feb 2014
Location: NC
Posts: 69
Images: 1
Ah ok. Well I turned on the radio this morning and it was doing awesome....except for the memory issue....then I turned on my headlights and my radio turned off. Any suggestions!
Mishie is offline   Quote
Old 08-18-2014, 09:28 AM   #24
Jeeper

WF Supporting Member
 
Monster93's Avatar
 
Join Date: Mar 2014
Location: South Florida
Posts: 636
Images: 3
Quote:
Originally Posted by Mishie View Post
Ah ok. Well I turned on the radio this morning and it was doing awesome....except for the memory issue....then I turned on my headlights and my radio turned off. Any suggestions!

Sounds like you tapped into wrong wires, could be ground issue, I would test all wires going to radio with test light or multi meter to make sure you have right wires. I think your memory wire (yellow) maybe connected to wrong source.
__________________
Monster 93 Build Thread


1993 YJ. 6" BDS 38's
2010 Rubicon 5.5 Rock Krawler coilover 38's
2014 Dodge Ram sport 2" level 33's
Monster93 is offline   Quote
Old 08-18-2014, 10:28 AM   #25
Jeeper
 
Zack93's Avatar
 
Join Date: Feb 2011
Location: 937, Ohio
Posts: 515
Quote:
Originally Posted by Monster93 View Post
Sounds like you tapped into wrong wires, could be ground issue, I would test all wires going to radio with test light or multi meter to make sure you have right wires. I think your memory wire (yellow) maybe connected to wrong source.
Yep this ^ did you use a universal connector or cut off the stock pigtail?
__________________
The above is not intended to offend, insult, or ridicule in any way, shape or form.
1995 YJ, 1992 MJ,1998 XJ,
تفخر الكافر -Proud Infidel
Zack93 is offline   Quote
Old 08-19-2014, 11:16 AM   #26
Jeeper
 
Mishie's Avatar
 
Join Date: Feb 2014
Location: NC
Posts: 69
Images: 1
Switched the wiring around and the radio works even with the lights on. Still having an issue with the memory not holding. The fuse isn't blown on the yellow wire so I'm not sure what is going on. The grounding wire from the jeep isn't in the best shape. Could that be the issue?
Mishie is offline   Quote
Old 08-19-2014, 11:22 AM   #27
Jeeper
 
Zack93's Avatar
 
Join Date: Feb 2011
Location: 937, Ohio
Posts: 515
I personally don't think so cause if it was a grounding issue then to me it would have issues just working. But it would hurt to run a new ground real quick. Does it work in the ACC key position?
__________________
The above is not intended to offend, insult, or ridicule in any way, shape or form.
1995 YJ, 1992 MJ,1998 XJ,
تفخر الكافر -Proud Infidel
Zack93 is offline   Quote
Old 08-19-2014, 12:05 PM   #28
Jeeper

WF Supporting Member
 
Monster93's Avatar
 
Join Date: Mar 2014
Location: South Florida
Posts: 636
Images: 3
Quote:
Originally Posted by Mishie View Post
Switched the wiring around and the radio works even with the lights on. Still having an issue with the memory not holding. The fuse isn't blown on the yellow wire so I'm not sure what is going on. The grounding wire from the jeep isn't in the best shape. Could that be the issue?
If the yellow wire is getting battery power with key off then it can be radio issue, there is only 3 wires that turn radio on, red - ignition, yellow - battery constant and black - ground.
__________________
Monster 93 Build Thread


1993 YJ. 6" BDS 38's
2010 Rubicon 5.5 Rock Krawler coilover 38's
2014 Dodge Ram sport 2" level 33's
Monster93 is offline   Quote
Old 08-19-2014, 07:17 PM   #29
Jeeper
 
Mishie's Avatar
 
Join Date: Feb 2014
Location: NC
Posts: 69
Images: 1
The radio doesn't work when the key is in off position but it does work in Acc. Gonna run a wire from battery trough firewall to yellow wire. That is the only way I can get it to hold memory. I'll just have to manually turn it off every-time.
Mishie is offline   Quote
Old 08-20-2014, 07:02 AM   #30
Jeeper
 
Mishie's Avatar
 
Join Date: Feb 2014
Location: NC
Posts: 69
Images: 1
Ran a wire from the battery to yellow wire and it works like a champ!

Mishie is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 01:05 AM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC