Rain kills my wrangler - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 02-16-2012, 01:49 PM   #1
Newb
 
Join Date: Feb 2012
Posts: 7
Rain kills my wrangler

95 Wrangler 4 cyl after it rains it spits and sputters ????? and you have to keep the peddle half way to the floor to keep it running ............ On a dry day I can take the garden hose and spray it from bumper to bumper and it runs ok ?????????????

Lostinthemud is offline   Quote Quick Reply
Old 02-16-2012, 03:08 PM   #2
Jeeper
 
flatline's Avatar
 
Join Date: May 2010
Location: pinole ca.
Posts: 680
Images: 3
distributor cap. then at night while jeep is running lift hoood and a light spray of water and see if the plug wires are arcing.

flatline is offline   Quote Quick Reply
Old 02-16-2012, 05:22 PM   #3
Jeeper
 
Join Date: Jan 2010
Location: Las Cruces, NM
Posts: 2,291
Time for a tune up, new wires for plugs and distributor along with a good cap etc. Make sure the plug and coil wires have a good boot that covers the connections. Also use the dielectric grease that comes with the wires on the boots etc. Won't hurt to clean and grease the coil, battery and starter connections too.
__________________
2013 WRANGLER SPORT 2 DR., V-6 ,AUTO,HARD TOP
(Sold)1994 Jeep Wrangler 2.5L, Bestop top
/w steel half door and slider windows
5 speed, 2.5" lift, 31" tires,rack lights
Garyk is offline   Quote Quick Reply
Old 02-16-2012, 09:53 PM   #4
Jeeper
 
Join Date: Aug 2011
Location: north of St.Franisville La.
Posts: 2,074
Send a message via Yahoo to Nubby55
Yea both flatline and GaryK are on the right track, bad cap bad wires, can be getting wet inside cap. Spray inside of cap with WD40.
Nubby55 is offline   Quote Quick Reply
Old 02-20-2012, 09:27 PM   #5
Jeeper
 
Gord's Avatar
 
Join Date: Feb 2012
Location: Neepawa, MB, Canada
Posts: 42
I had the same problem with mine, with occasional problems of just idling and starting. I changed the cap, rotor, plugs and wires and everything seems to be good now.
Gord is offline   Quote Quick Reply
Old 12-24-2012, 10:23 AM   #6
Newb
 
Join Date: Feb 2012
Posts: 7
lost

I replaced the wires, plugs, cap, and rotor twice and it has a new coil .......... It still will not run if it rains before I drive it or during a rain ?
Lostinthemud is offline   Quote Quick Reply
Old 12-24-2012, 12:23 PM   #7
Jeeper
 
DILLIGAF's Avatar
 
Join Date: Sep 2011
Location: Cortland NY
Posts: 595
Check all your grounds under the hood from the battery to fire wall and especially the motor, remove them clean em up, use some dialectic grease when reassembling, good luck.
__________________

Semper Fidelis!

95 2.5L, 5sp, 4" RC Lift, Lock Right front diff. 8.8 LS 4.10 gears, M/T 31" Baha Claw
DILLIGAF is offline   Quote Quick Reply
Old 12-29-2012, 11:14 AM   #8
Newb
 
Join Date: Feb 2012
Posts: 7
I cleaned all the grounds .............. There was rain and snow here Friday night and Saturday it spit and sputtered ???????
Lostinthemud is offline   Quote Quick Reply
Old 12-29-2012, 11:36 AM   #9
jokerchief462

WF Supporting Member
 
jokerchief462's Avatar
 
Join Date: Apr 2012
Location: North Las Vegas
Posts: 9,387
OK let's try looking at you vitals and see if the rain is entering the engine bay or the can getting into you wires or ignition. Is the seal at the hood and cowl still good??? Is the rain diverted over the ign module still installed?? Do you get any evidence of water inside the can after it rains?? Lots to look at. Or just move to Vegas only rains 4-5 days a year.
__________________
89 2.5 TBI, 4" RC lift, 1" Booms, SYE, Adams Driveshafts front and rear, Ford 8.8 with 4:88s, BFG 33X12.50X15, and a ton of other stuff.

AF Jeep Club Tail Number 184
jokerchief462 is offline   Quote Quick Reply
Old 12-30-2012, 06:50 PM   #10
Newb
 
Join Date: Feb 2012
Posts: 7
There is no water under the dash anywhere ?????
Lostinthemud is offline   Quote Quick Reply
Old 12-30-2012, 06:52 PM   #11
Jeeper
 
whiteyj's Avatar
 
Join Date: Jul 2005
Location: Pleasanton CA
Posts: 4,856
What kind of intake / airbox are you running?
__________________
Fallen Angel...Former MOD
whiteyj is offline   Quote Quick Reply
Old 12-30-2012, 11:04 PM   #12
Jeeper
 
RednekYJ's Avatar
 
Join Date: Feb 2007
Location: LITH IL
Posts: 1,352
There is water somewhere it shouldn't be, you just haven't found it.
RednekYJ is online now   Quote Quick Reply
Old 12-31-2012, 06:25 PM   #13
Newb
 
Join Date: Feb 2012
Posts: 7
Its the factory plastic rectangular air box drivers side .... stock filter
Lostinthemud is offline   Quote Quick Reply
Old 12-31-2012, 06:45 PM   #14
Jeeper
 
Join Date: Nov 2012
Location: Del-A-Where
Posts: 56
+ on ignition issue. moisture in the air can cause a misfire due to cap/rotor and/or plug wire and/or coil issue. get a spray bottle and while its running spray those components and see what happens.
illz88 is offline   Quote Quick Reply
Old 01-01-2013, 06:40 PM   #15
Newb
 
Join Date: Feb 2012
Posts: 7
I have taken a garden hose and sprayed all over the engine compartment. And Ive sprayed every where under the Jeep ????? It runs fine ????
Lostinthemud is offline   Quote Quick Reply
Old 01-01-2013, 07:10 PM   #16
Jeeper
 
Join Date: Nov 2012
Location: Del-A-Where
Posts: 56
thats weird, iginition is the only thing i can think of that could cause this issue. see it alot at work. sorry, i might not be of much help here.

illz88 is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Where to put my KC switch for my new lights? Daystar switch panel? ThePalmBeachYeti JK General Discussion Forum 25 03-19-2012 10:06 AM
2013 Wrangler broomhandle JK General Discussion Forum 33 02-23-2012 10:06 AM
I want another Wrangler! tluke JK General Discussion Forum 15 02-17-2012 10:24 PM
2012- My Impression mxman122 JK General Discussion Forum 8 02-17-2012 05:11 AM
02 wrangler swap to 350v8 acod916 TJ General Discussion Forum 9 02-17-2012 04:41 AM



» Featured Product

All times are GMT -5. The time now is 09:04 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC