Rear turn signal problems - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today

Thread Tools

Please support our sponsors and let them know you heard about them on
Old 08-02-2011, 05:18 PM   #1
Join Date: Aug 2011
Posts: 3
Question Rear turn signal problems

I am currently scratching my head as to why my 91's rear lights are acting so weird.

So left turn works correctly.

Right turn will make the rear right blink but verry dim. The reverse lights on both left and right will blink very dim at the same time this is happening.

Turning on the hazzard blinker makes the rear lights flash but the reverse lights are flashing very dim at the opposite time the break lights flash.

All bulbs on the jeep are ok and both flashers have been replaced. The weird flashing seems to only effect the rear lights and not the others.

staplenut is offline   Quote
Old 08-02-2011, 05:44 PM   #2
kik's Avatar
Join Date: Dec 2008
Posts: 6,660
There's usually a ground problem when that occurs. You're going to have to check all of your grounds or I would try a new ground off of the wires affected to see if that helps.

kik is online now   Quote
Old 08-02-2011, 05:52 PM   #3
Join Date: Aug 2011
Posts: 3
Thanks for the help. I hope I can find it.
staplenut is offline   Quote
Old 08-02-2011, 09:17 PM   #4
likes relays

WF Supporting Member
onroad's Avatar
Join Date: Jul 2011
Location: Long Island, NY
Posts: 348
It looks like (just checking a diagram here) all tail lights ground through the body, except for the left rear backup lamps that go to a ground wire. If that's right you possibly have a bad connection at the right rear lamp assembly to the body, voltage backfeeding through the reverse lamp circuit to its ground wire on the left side. Pull off the right rear lamp and make sure it's all clean.
onroad is offline   Quote
Old 08-03-2011, 11:19 AM   #5
Join Date: Aug 2011
Posts: 3
I think my lights must have been glitching for some time. I think sometime last year I got some wire guards for the rear lights. they have a foam pad protect the paint and came with new mounting hardware thats longer to account for the foam and the metal thickness. The problem is all the bolts had plastic washers on them. So I just took off one of the washers and Its all grounded now.
staplenut is offline   Quote

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Turn signal flashes rapidly (Different Type Socket Installed) MattD TJ Tech Forum 8 12-02-2010 07:04 PM
Turn Signal Question markharmon YJ Tech Forum 7 11-28-2010 09:36 PM
A little info on turn signal..dash light issue Bugz2008 TJ Tech Forum 7 01-08-2010 09:35 PM
Left turn signal doesn't flash pghohnst YJ Tech Forum 6 10-07-2009 03:24 PM
Picture request: Turn signal arm 95muddyYJ YJ General Discussion Forum 0 08-30-2009 01:50 PM

Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 09:55 AM.

User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC. is not in any way associated with the Chrysler Motors LLC