Rough Idle - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 09-20-2010, 01:25 PM   #1
Jeeper
 
WhiteWillSmiff's Avatar
 
Join Date: Jun 2010
Posts: 100
Rough Idle

Sup guys/girls,

Got a 2.5l 5-spd 95' YJ. Has 72,*** original miles. I've replaced the plugs/wires/distributor & rotor. I've also ran fuel cleaner through the tank (BG44k), cleaned the TB, replaced the air filter. I also ran the engine code scanner by turning the key a set amount of times, but only pulled the "NO AC" code. Are there any other sensors or issues that could be causing this? Currently I'm getting 20.1 mpg according to my fuel logs. Any tips are appreciated. Thanks!

__________________
95' YJ, 4" Suspension, 31" BFG A/T, 2.5L, 5-spd., 95% of work done by yours truly.
WhiteWillSmiff is offline   Quote
Old 09-20-2010, 02:49 PM   #2
Founder, ThumbJeeps

WF Supporting Member
 
sevenservices's Avatar
 
Join Date: Sep 2009
Location: Mid-Michigan/Thumb
Posts: 3,952
not sure myself where to look, but Im wondering if it is sucking air somewhere???

__________________
-Chris
Founder, ThumbJeeps


1994 Wrangler YJ I6 4.0 H/O Auto 3 spd. 4" RC (33x12.5) (15x8) 3:54 Gears
sevenservices is offline   Quote
Old 09-20-2010, 04:12 PM   #3
Jeeper
 
rogertc1's Avatar
 
Join Date: May 2010
Location: Maquoketa
Posts: 489
Perhaps replace the TBS? Part is about 45$...2 screws. Mine would backfire and run rough .
rogertc1 is offline   Quote
Old 09-20-2010, 04:47 PM   #4
Jeeper
 
WhiteWillSmiff's Avatar
 
Join Date: Jun 2010
Posts: 100
TBS? Never heard of that? I've checked the vacuum lines & they're looking good. Also forgot to add, replaced the lines that run from the valve cleaner to the factory air box. I did some other research & found an "Idle Speed control" motor might be in question. I assumed that if those went, there would be some kind of code related. Thanks for the input guys.
__________________
95' YJ, 4" Suspension, 31" BFG A/T, 2.5L, 5-spd., 95% of work done by yours truly.
WhiteWillSmiff is offline   Quote
Old 09-20-2010, 04:51 PM   #5
Jeeper
 
ajorosa's Avatar
 
Join Date: Aug 2010
Location: N.J.
Posts: 570
Is it getting up to temp, my 2002 2.5l runs like crap if the thermostat is stuck open and it won't get up to temp. Engine light go's on for this though.
__________________
"You got to cry without weeping
Talk without speaking
Scream without raising your voice"

Never be afraid to try something new. Remember, a lone amateur built the Ark. A team of engineers built Titanic.
ajorosa is offline   Quote
Old 09-20-2010, 05:34 PM   #6
Jeeper
 
WhiteWillSmiff's Avatar
 
Join Date: Jun 2010
Posts: 100
Temp holds just below 210deg, which ever is the 12oclock position. Oil pressure is high, going up to 75 under throttle. At idle is around 55-60. Thermostat/water pump/hoses are all new.
__________________
95' YJ, 4" Suspension, 31" BFG A/T, 2.5L, 5-spd., 95% of work done by yours truly.
WhiteWillSmiff is offline   Quote
Old 09-20-2010, 06:12 PM   #7
Jeeper
 
Join Date: Jan 2010
Location: Las Cruces, NM
Posts: 2,303
try some injector cleaner
__________________
2013 WRANGLER SPORT 2 DR., V-6 ,AUTO,HARD TOP
(Sold)1994 Jeep Wrangler 2.5L, Bestop top
/w steel half door and slider windows
5 speed, 2.5" lift, 31" tires,rack lights
Garyk is offline   Quote
Old 09-21-2010, 04:17 AM   #8
Jeeper
 
rogertc1's Avatar
 
Join Date: May 2010
Location: Maquoketa
Posts: 489
Sorry, TPS Throttle Position Sensor not TBS.
rogertc1 is offline   Quote
Old 09-21-2010, 08:01 AM   #9
Jeeper
 
WhiteWillSmiff's Avatar
 
Join Date: Jun 2010
Posts: 100
Ah cool, I'll grab up that and the ISC (?) sensor. Can't hurt to do the Crankshaft position sensor & the one under the distributor as well. I'd rather know there's new parts considering the previous owner had no mechanical history of the Jeep.

__________________
95' YJ, 4" Suspension, 31" BFG A/T, 2.5L, 5-spd., 95% of work done by yours truly.
WhiteWillSmiff is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
01 Sahara rough idle, dying and then not starting.. supernova1021 TJ Tech Forum 1 09-11-2010 07:47 PM
Recently developed rough idle and stall '87 YJ w/i6 Hardwater Kiter YJ Tech Forum 0 08-24-2010 08:53 PM
89 YJ 4.2L idle is rough, need your ideas :) jeepfan123 YJ Tech Forum 10 04-25-2010 03:48 PM
Strange Rough Idle djl7780 TJ Tech Forum 4 04-15-2010 07:08 PM
Runing rough, idle rough, cylinder #4 misfire spdrcrpete TJ General Discussion Forum 13 06-02-2008 01:32 PM



Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 02:39 AM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC