Running rich.....? - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 10-25-2007, 09:20 PM   #1
Jeeper
 
NY94YJ's Avatar
 
Join Date: May 2005
Location: Malta NY
Posts: 307
Running rich.....?

Check engine light has been coming on after about 5-10 minutes of driving. I am getting code 52 "Left Bank or Fuel System Rich" "A rich air/fuel mixture has been indicated by an abnormally lean correction factor".

This is new territory for me, as is anything that happens for the 1st time.

O2 Sensor?

Thanks in advance for any help.

__________________
'03 TJ Sport on 33's, 2"BB, 1"BL, 1"MML
NY94YJ is offline   Quote Quick Reply
Old 11-15-2007, 07:04 PM   #2
Jeeper
 
NY94YJ's Avatar
 
Join Date: May 2005
Location: Malta NY
Posts: 307
Anyone?

Since post, I have replaced muffler which was bad, and de-greased the engine to get a better view of whats going on in there. Nothing visually wrong. Before I drop it off at a shop I am hoping to get some direction instead of going in blind.

Still getting Check Engine Light and Code 52 (see above). I seem to get some hesitation at higher RPM's and fuel consumption has been excessive.....and at $3.29+ I can't go on like this.....

__________________
'03 TJ Sport on 33's, 2"BB, 1"BL, 1"MML
NY94YJ is offline   Quote Quick Reply
Old 11-15-2007, 07:08 PM   #3
Jeeper
 
nycom96's Avatar
 
Join Date: Jul 2007
Location: Wallkill, NY
Posts: 639
How about your catalytic converter? Or your O2 sensor? That is where I would start.
__________________
91YJ 6cyl
4inch Rouch Country lift
3inch Body Lift
Mickey Thompson Classic II's with M/T 33"MTZ's
40 series Flowmaster
Smitybuilt Rock Crawler Bumper
WARN M8000 Winch(Thanks to my lovely Fiance)
Lock Right Rear Locker
4:56 Gears
No Trac Bar
No Sway Bar
Pro Comp Rear Bumper
6" Pocket flares

Square Headlights Rock!

[]llllll[]

More to come soon!!
nycom96 is offline   Quote Quick Reply
Old 11-17-2007, 09:52 AM   #4
Jeeper
 
NY94YJ's Avatar
 
Join Date: May 2005
Location: Malta NY
Posts: 307
FIXED. 02 Sensor was the cause. $50...but I'm glad that's all it was! Wasted more than that in gas..should-a tried that 1st, it was my first instinct.
__________________
'03 TJ Sport on 33's, 2"BB, 1"BL, 1"MML
NY94YJ is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
running rich still achappy44 TJ Tech Forum 3 12-07-2008 01:45 PM
Engine running too rich...High Compression Jb1234 TJ Tech Forum 10 11-26-2008 08:20 PM
Ya think he's running a bit rich? 02Prove Off-Topic 7 03-14-2008 08:29 PM
4.2 Running rich MrJarratt YJ Tech Forum 5 11-25-2007 09:30 PM
Engine Running Very Rich!!! crickifur YJ Tech Forum 24 09-23-2007 11:24 AM



Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 06:36 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC