Speed sensor and speedometer question 88 wrangler - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 04-30-2011, 10:59 AM   #1
Jeeper
 
Join Date: Apr 2011
Posts: 18
Speed sensor and speedometer question 88 wrangler

Ok, I purchased a 1988 automatic wrangler from EBAY... IN the listing it stated that it speedometer/odometer was not functioning. So it arrivers its solid runs pretty well carb. needs adjusted a little nothing to much.

Here is the the I drop under and have a look you can pretty much just pull it out there is a nut and wash rigged to hold it in. In the mean time its leaking and need to get it fixed. It seem like a quick easy fix. I ran to the local salvage yard they have a 99 and 97 Cherokee 4x4. Tranfer case looks the same? But the sensor is different? Do you think the clip that secures the sensor is the same, sure looks close. They day no clue. I didn't want to drop 20 bucks on one if its not going to fit (the clip).

If not what models can be cross reff'd?

Any help would be great. I'm no master mechanic, but love doing what I can under the hood. Any thing would help even a link to the correct part or info.

Thanks....

winters816 is offline   Quote Quick Reply
Old 04-30-2011, 01:54 PM   #2
Jeeper
 
JonsBlue90's Avatar
 
Join Date: Apr 2011
Location: Moosic PA
Posts: 124
I don't think it will work. Your speedo should be cable driven, newer models (94+) I believe will be electronic.

Don't quote me, but you should be able to use pretty much anything up to a 93...

JonsBlue90 is offline   Quote Quick Reply
Old 04-30-2011, 02:55 PM   #3
Jeeper
 
Undead-89's Avatar
 
Join Date: Feb 2011
Location: Loveland, CO
Posts: 760
with my 89, manual, you would have to buy the right gear in the transfer case for the right size tires then adjust the cover to match the the gear. Mine is mechanical, cable-driven. And, I am assuming yours would be too.

Not sure what the cross reference is but it looks like 91 was the first year the electronic speedometer was used in the YJ. So you need something 90 or earlier.
Undead-89 is offline   Quote Quick Reply
Old 04-30-2011, 03:55 PM   #4
Jeeper
 
JonsBlue90's Avatar
 
Join Date: Apr 2011
Location: Moosic PA
Posts: 124
Jeep Speedometer Gears at Morris 4x4 Center will tell you what you need for tire size/gearing.
JonsBlue90 is offline   Quote Quick Reply
Old 04-30-2011, 07:55 PM   #5
Jeeper
 
Join Date: Apr 2011
Posts: 18
Thanks for all the help everyone. I found a clip off a 97 Cherokee clip work fine, it fit perfectly. The rest as stated above is electric and would not work.
For now it will work. I stopped the leak and its drivable.

I am still going to need to purchase a cable and censer.

Again thanks everyone.
winters816 is offline   Quote Quick Reply
Old 04-30-2011, 08:19 PM   #6
Jeeper
 
JonsBlue90's Avatar
 
Join Date: Apr 2011
Location: Moosic PA
Posts: 124
Speedometer Gear, Speedometer Gears, Ford, GM, Dodge 700R4

I just picked up a new gear from them. Got a used one for 25 bucks. They may have the cable too.
JonsBlue90 is offline   Quote Quick Reply
Old 05-08-2011, 11:58 AM   #7
Jeeper
 
Join Date: Apr 2011
Posts: 18
ok I have the gear.... I put it in and the speedometer still will not work. Does it have to go in in a specific direction or position. I seemed to go in an fit, I could even spin it and have see the speedometer jump when I do it by hand. Once I put it in and bult it down. I go for a drive and nothing?
winters816 is offline   Quote Quick Reply
Old 05-08-2011, 12:06 PM   #8
Jeeper
 
MellowYellow89YJ's Avatar
 
Join Date: Feb 2011
Location: NE Florida
Posts: 507
Did you index the gear when you installed it? The flange has indexing notches which align with the tabs on the fork that clamps it in place, these cam the gear into proper mesh. Your spedo gear can go in and not contact the gear in the t-case tail if not indexed to the right psition.
__________________
A few FACTS:
Rectangle headlights ARE kinda cool.
YJ does NOT stand for "Yuppie Jeep".
Jeeps should only have TWO doors.
You should ALWAYS wave at other JEEP drivers.
MellowYellow89YJ is offline   Quote Quick Reply
Old 05-08-2011, 12:56 PM   #9
Jeeper
 
JonsBlue90's Avatar
 
Join Date: Apr 2011
Location: Moosic PA
Posts: 124
Or the cable isn't attached to the speedometer.
JonsBlue90 is offline   Quote Quick Reply
Old 05-08-2011, 03:22 PM   #10
Jeeper
 
Join Date: Apr 2011
Posts: 18
I got it! There are two lines that needed to be aligned after doing this it worked great....
winters816 is offline   Quote Quick Reply
Old 05-08-2011, 03:23 PM   #11
Jeeper
 
Join Date: Apr 2011
Posts: 18
I posted this in another thread but this is what helped me....


If you have just replaced your speedo gear and now your speedo isn't working, this very well may fix your problem. For those of you who have just installed a SYE, you will want to see the pix at the bottom of this write up.

Now for you guys who have the stock Transfercase (TC) and you just change your speedo gear because you either changed your gearing or put on larger tires, you may have reinstalled your speedometer off calibration.

On your TC, there will be a little nipple or hump





Now look on your sending unit (speedo) and you will find two sets of numbers. 26-31 and 32 -36. These are your calibration number that you will use to line up on the "nipple". Your new gear will be in the set of numbers on the unit. If you installed a 34 tooth gear, then you would line up the 32-36 set of numbers.





Now install the sending unit into the TC being sure to line up the numbers that apply to the gear you installed with the nipple. You may have to tweak the unit a little for the hold down clamp to line up. What is important is that the numbers are within proxemity of the nipple.



And thats it. really pretty simple. Fasten down the hold down clapm and you are good to go. If yout speedo still doesnt work, then very possibly you may have a bad unit or the electrical contacts are dirty.


Now for you SYE guys/gals...there is NO NIPPLE or hump on the tail houseing of the SYE. What you do is you line up the correct speedo numbers with the clamp.




Real simple..Hope this helps.

winters816 is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 02:05 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC