Stalling? - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 03-30-2010, 04:03 PM   #1
Jeeper
 
Join Date: Sep 2009
Posts: 47
Angry Stalling?

so.... my 1994 sahara is acting up quite a bit. ill be driving down the road and
it will just die! sometimes i can just shift it into neutral and turn it right back
on but other times i have to go over to the side of the road and wait a bit?
there is no check engine lights or anything andyone have any ideas? anything would help thanks!

flyboy is offline   Quote
Old 03-30-2010, 05:12 PM   #2
Jeeper
 
Join Date: Feb 2010
Location: Jackman Maine
Posts: 36
my money is on ecu. mine did the same thing. read the forum about 91 won't start . a link is posted about replacing the capacitors for 5$ I couldn't open it but it's worth trying a remanned ecu is about 370$ good luck

bdl67 is offline   Quote
Old 03-30-2010, 05:20 PM   #3
Jeeper
 
little1989jeep's Avatar
 
Join Date: Sep 2009
Location: lima ohio
Posts: 1,775
i could never figure it out on mine it caused the harness to fry
__________________
There's a line between adventure and stupidity.

Quote:
Originally Posted by frankenstein_yj View Post
oh and when i find the guy who invented torx screws i have a big can of wup-ass for him
little1989jeep is offline   Quote
Old 03-30-2010, 05:34 PM   #4
Jeeper
 
Join Date: Feb 2010
Location: Jackman Maine
Posts: 36
really, so it's not a bad thing i went with the napa route, sorry your misfortune makes me feel better. did you get it all squared away?
bdl67 is offline   Quote
Old 03-30-2010, 05:46 PM   #5
Jeeper
 
Join Date: Sep 2009
Posts: 47
oh dang! yeah i read about that on the 91 but it sounded a little sketchy! so you think its the ecu? iv also been told it could be the crank postioning sensor
flyboy is offline   Quote
Old 03-31-2010, 09:00 AM   #6
Jeeper
 
Join Date: Mar 2010
Location: nh
Posts: 73
My jeep did the same thing, shutting off when driving then maybe starting, maybe not. I replaced alot of parts including the crank position sensor nothing fixed it until I changed those three little capacitors in the ECU, cost about five bucks for new capacitors then just soldered them in. Problem solved. I'm trying to save people money and time by saying try this fix first, it's cheap and easy and most likely the problem when you have these symptoms.
__________________
It doesn't matter what's right, it's only wrong if you get caught
renegadewarrior is offline   Quote
Old 03-31-2010, 11:54 AM   #7
Jeeper
 
irontom's Avatar
 
Join Date: Apr 2009
Location: Poznan, Poland
Posts: 148
Mine does this sometimes too, usually on a wet day. I take a clean cloth and clean the electrical part of the TBI. When you take of the air intake cap, you have a plug there, I just clean it, no problems for weeks after this "maintenance"

Oh, mine is a 2.5
__________________
YJ 1989 2.5l
irontom is offline   Quote
Old 03-31-2010, 05:54 PM   #8
Jeeper
 
Join Date: Sep 2009
Posts: 47
what capacitors? would i need to change? i will probably try that
flyboy is offline   Quote
Old 04-01-2010, 05:15 AM   #9
Jeeper
 
Join Date: Feb 2010
Location: Jackman Maine
Posts: 36
I would try it if I had known before I bought a new ecu. that's probably all napa did and charged me 369$ oh well. Good luck!
bdl67 is offline   Quote
Old 04-01-2010, 11:02 AM   #10
Jeeper
 
Join Date: Mar 2010
Location: nh
Posts: 73
Check this out. Let me know if the link doesn't work. You can also copy and paste it into the address bar on your browser if the link doesn't work.

http://www.jeepforum.com/forum/showth...d.php?t=492597
__________________
It doesn't matter what's right, it's only wrong if you get caught
renegadewarrior is offline   Quote
Old 04-01-2010, 11:06 AM   #11
Jeeper
 
Join Date: Mar 2010
Location: nh
Posts: 73
Quote:
Originally Posted by bdl67 View Post
I would try it if I had known before I bought a new ecu. that's probably all napa did and charged me 369$ oh well. Good luck!
I wish I knew about this before I changed my fuel pump, fuel filter, crank position sensor, idle air motor, pulled my hair out threw beer bottles at the jeep and threatened to burn it all because it wouldn't start
__________________
It doesn't matter what's right, it's only wrong if you get caught
renegadewarrior is offline   Quote
Old 04-01-2010, 03:48 PM   #12
Newb
 
Join Date: Mar 2010
Location: Portland, OR
Posts: 4
I've been having similar problems in my 91 YJ (4.0 6L). My mechanic who's a Jeep guy replaced my Crank Position sensor which was failing - that worked for a while, then started acting up again. My fuel pump is working fine (tested over and over again.) He found that my O2 sensor was bad. Said he's seen that cause this problem, so I'm trying that - so far so good. If this doesn't solve it I think we're on to the ECU.
CCowboy4G is offline   Quote
Old 04-01-2010, 08:15 PM   #13
Jeeper
 
Join Date: Jan 2010
Location: Las Cruces, NM
Posts: 2,303
Did you check it for codes?
__________________
2013 WRANGLER SPORT 2 DR., V-6 ,AUTO,HARD TOP
(Sold)1994 Jeep Wrangler 2.5L, Bestop top
/w steel half door and slider windows
5 speed, 2.5" lift, 31" tires,rack lights
Garyk is offline   Quote
Old 04-01-2010, 08:30 PM   #14
Newb
 
dbt381's Avatar
 
Join Date: Nov 2008
Location: Mass
Posts: 12
my 91was doing this last spring. It was driving me nuts Itried cramk position sensor but that didn't help. Finally when I was going to give up Ifound the a wire that came out from under the distributor was shorted out to the clip that holds it to the block. I removed the wire from the clip and repaired the insulation and no problem since. The wire was a flat 4 wire set.
__________________
91 wrangler 4.0 3in lift 32in coopers
84 Scrambler work in progress
dbt381 is offline   Quote
Old 09-02-2010, 03:24 PM   #15
Newb
 
Join Date: Aug 2010
Posts: 2
Talking 91 jeep wrangler stalling solve

I have a 91 jeep wrangler and used to stall some times I replaced the ECU, rotor cap, rotor, all censors, gas pump and the problem was still there I was about to give up... But I love my jeep very much so I had to try for the last time..but this time I noticed that the catalytic converter was red hot, changed the ignition coil... Problem solve, now runs really good and I'm really happy so hope someone there that,s having same problem help my post before expending a lot of cash in parts not needed... Good luck every one

Navegador is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Stalling problems with 97 six cylinder CSmith1128 TJ General Discussion Forum 8 08-24-2011 01:35 PM
stalling jarhead77811 YJ Tech Forum 3 01-23-2010 02:36 PM
Stalling on deceleration mike_b_ar YJ Tech Forum 7 01-02-2010 02:10 PM
stalling problems GGUSDWrangler TJ Tech Forum 8 07-09-2007 07:38 PM
1998 TJ SE Stalling at highway speeds. SmirkyWaters TJ Tech Forum 5 06-22-2007 11:47 AM



Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 08:44 PM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC