Starter issue - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 03-17-2014, 05:50 PM   #1
Newb
 
Sexybij's Avatar
 
Join Date: Mar 2014
Location: Vancouver, Canada
Posts: 13
Starter issue

So my starter went. I have replaced with a brand new one. I get one click when turning the ignition, but that is it. I have checked all the cables, tested the battery, cleaned terminals, connections and grounds. A friend "jumped" the starter while it was in Jeep and it worked. What am I missing? Any other troubleshooting would be great please This is day 3 beating my head against a wall.

Sexybij is offline   Quote
Old 03-17-2014, 09:22 PM   #2
Jeeper
 
Join Date: Aug 2011
Location: north of St.Franisville La.
Posts: 2,642
Send a message via Yahoo to Nubby55
Sound like a bad selinord .

__________________
The Government can not give anything to anybody that it does not first take from someone else !
Nubby55 is offline   Quote
Old 03-17-2014, 09:26 PM   #3
Supporting Member

5-Year WF Supporting Member
 
jokerchief462's Avatar
 
Join Date: Apr 2012
Location: North Las Vegas
Posts: 9,966
Or you battery is a little low and your cables may have internal corrosion further down under the insulation. They are not expensive measure the length got AZ or Oreillys they have em on the shelf make a huge difference especially 50 miles off- road.
__________________
89 2.5 TBI, 4" RC lift, 1" Booms, SYE, Adams Driveshafts front and rear, Ford 8.8 with 4:88s, BFG 33X12.50X15, and a ton of other stuff.

AF Jeep Club Tail Number 184
jokerchief462 is online now   Quote
Old 03-18-2014, 06:42 PM   #4
Newb
 
Sexybij's Avatar
 
Join Date: Mar 2014
Location: Vancouver, Canada
Posts: 13
It ended up being the positive battery terminal. Go figure. Quick fix though.
Sexybij is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 08:15 PM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC