Starter wont engage & kills all power. - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 03-20-2011, 09:51 PM   #1
Jeeper
 
Join Date: Feb 2011
Posts: 25
Starter wont engage & kills all power.

I just got my 89 YJ all put back together after I put in a new clutch, turned the key heard a click, and then nothing. The starter didn't try to crank the engine, it engaged I heard the click but it doesn't crank the engine. The batterys charged so thats not it. After the starter trys to kick in the inital time it won't do it again, I will turn the key and nothing will happen. The only way to get it to click again is by taking off both terminals on the battery putting them back on and trying to start it again. Then it will try to engage once and thats it, take the battery terminals off put them on and it will click one time. Also I tried to start it with the headlights on and once it engages the lights go out and won't turn back on until I take the terminals off and put them back on the battery. The cd player and the dash gauges are the only things that stay powered. The voltmeter in the dash only reads like 8V when the key is turned, then when I engage the starter it goes even further to left (less voltage). My ideas are either a messed up safety switch (If one of this nature exists), I bumped a wire somewhere, or a bad ground. I'm not sure is there is any kind of safety circuit on the tranny to prevent it form starting, but I installed the two connectors and the vent to it. And I put all the wires back on like they were on the starter. Anyone experience anything similar to this, or have any ideas on what could be wrong? I'm at a loss for ideas. I also tried it with the starter out of the bell housing the same thing happened.

rambo3489 is offline   Quote Quick Reply
Old 03-20-2011, 10:02 PM   #2
Jeeper
 
Chris Anderson's Avatar
 
Join Date: Dec 2010
Location: Ogden, Ut
Posts: 74
This happened to me after I rebuilt my motor. Clean up the wires and the terminals on the starter and tighten them back up.

Chris Anderson is offline   Quote Quick Reply
Old 03-20-2011, 10:22 PM   #3
Jeeper
 
Join Date: Feb 2011
Posts: 25
Quote:
Originally Posted by Chris Anderson View Post
This happened to me after I rebuilt my motor. Clean up the wires and the terminals on the starter and tighten them back up.
Yup thanks just did that and it cranked over. Now I just gotta get it running smooth again.
rambo3489 is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
No power to coil? Bugz2008 TJ General Discussion Forum 6 06-25-2012 05:19 AM
92 YJ 2.5 Won't start, no power to the fuel pump eyeChrs YJ Tech Forum 15 02-14-2012 04:46 PM
power package and taking doors off Yan JK General Discussion Forum 8 09-01-2010 10:16 AM
Losing power when hot cyclebender TJ Tech Forum 3 04-01-2009 04:58 PM


logo carid shop wrangler parts carid fender flares custom wheels store avs deflectors at carid
» Rates
Get low rates on auto insurance in Canada!

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 04:09 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC