Tapping sound from lifters - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 04-28-2008, 08:20 PM   #1
Newb
 
texwrangler's Avatar
 
Join Date: Apr 2008
Posts: 8
Tapping sound from lifters

The tapping is intermittent throughout any temperature of the engine. Any ideas on how to resolve this noise without tearing the valvetrain apart? Also the distibutir cap and rotor make a "dragging" sound sometimes, not sure why. Any help is appreciated.
The vehicle is a 1992 wrangler with the 4.0L HO and about 125,00 miles original.

texwrangler is offline   Quote Quick Reply
Old 04-28-2008, 08:42 PM   #2
Jeeper
 
jpdocdave's Avatar
 
Join Date: Mar 2008
Location: beach park, il
Posts: 8,162
Images: 7
dragging in distributor cap is weird, might not be on straight. as far as noise, your first step before making any repairs should be an engine flush. just buy the chemical from the parts store, put it in, and run for 5 mins. usually, then change oil, i like to let drain for a long time. then change filter, and fill er up. i have seen lucas work well first hand also. good luck and welcome

__________________
"The danger to America is not Barack Obama but a citizenry capable of entrusting a man like him with the Presidency. It will be far easier to limit and undo the follies of an Obama presidency than to restore the necessary common sense and good judgment to a depraved electorate willing to have such a man for their president."
http://mybroadband.co.za/photos/data...re_cowbell.gif
jpdocdave is offline   Quote Quick Reply
Old 04-29-2008, 05:49 PM   #3
Newb
 
texwrangler's Avatar
 
Join Date: Apr 2008
Posts: 8
Thanks for the info, I will try that and see what the results are. I received a tune up kit from Accel today, so I will see if the dragging noise goes away when I install the new ignition stuff.

Thanks again!
texwrangler is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Acceleration Sound – Normal? MacApple JK Tech Forum 10 01-17-2009 11:56 AM
4.0 tapping racer-xerols YJ Tech Forum 3 11-21-2008 09:00 AM
sound bar or sound pods distortedtj Classifieds Archive 2 12-11-2007 08:00 AM
Valve tapping Chris YJ Tech Forum 5 12-31-2006 12:53 PM
popping sound at moving off. upinar TJ Tech Forum 6 10-13-2006 09:45 AM



Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 11:13 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC