three clutch slaves in four months!??!?! - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 04-20-2010, 11:30 AM   #1
Jeeper
 
Join Date: Dec 2009
Posts: 46
three clutch slaves in four months!??!?!

this is the third time in four months that i have returned a busted clutch to oreilly's because it is broken. all three times they have broken on the inside, where the slave sits on the spindle of the transmission. i have had two different transmissions in, and have all the parts where they need to be, according to my chiltons.
any ideas? someone said it could be traveling too far?

jubilee is offline   Quote Quick Reply
Old 04-20-2010, 11:36 AM   #2
Jeeper
 
Schmo's Avatar
 
Join Date: Jul 2007
Location: SoCal
Posts: 1,586
Are you using OEM parts? I've heard lots of issues with the non OEM replacement parts from Kragen, etc being crap . . . not specifically slaves, but water pumps, etc.

__________________
Bite the hand that feeds you . . . you've had more than enough to eat already.
Schmo is offline   Quote Quick Reply
Old 04-20-2010, 12:48 PM   #3
Jeeper
 
Join Date: Jan 2010
Location: Las Cruces, NM
Posts: 2,291
Sounds like you need to get your $$ back and try OEM
__________________
2013 WRANGLER SPORT 2 DR., V-6 ,AUTO,HARD TOP
(Sold)1994 Jeep Wrangler 2.5L, Bestop top
/w steel half door and slider windows
5 speed, 2.5" lift, 31" tires,rack lights
Garyk is offline   Quote Quick Reply
Old 04-20-2010, 01:49 PM   #4
Hacks off Parts while Lit
 
whitebuffalo's Avatar
 
Join Date: May 2005
Location: The Sandhills of South Texas
Posts: 2,290
did you flush your clutch master? if there's debris in there somehow, it could be taking out the slave maybe? just a thought
__________________
'90 YJ, ford 8.8, SOA, lincoln front, aussie rear, 4.88s, swampers.
whitebuffalo is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Another Clutch Master cylinder bleeding tip. USAFChief YJ Tech Forum 1 01-25-2010 10:19 AM
Help! Clutch question! ScottyWantsWrangler TJ Tech Forum 1 06-23-2009 06:59 PM
ba 10 ax 15 clutch slaves Difference jjohnnythrock YJ Tech Forum 2 06-18-2009 04:33 AM
Clutch Wierdness in an o1 grnorris99 TJ Tech Forum 6 07-02-2007 04:00 PM
Clutch Wierdness in an o1 grnorris99 TJ Tech Forum 0 06-23-2007 07:39 PM



» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 08:31 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC