Trouble getting reer leaf springs on - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 08-15-2014, 06:50 PM   #1
Jeeper
 
Join Date: Jul 2014
Posts: 61
Trouble getting reer leaf springs on

I'm toward the end of putting a 2-1/2 " lift on a YJ and I'm having a terrible time getting the read leaf spring center pins to line up...anyone have any tips to share...thanks.

Dryrot is offline   Quote
Old 08-15-2014, 10:42 PM   #2
Jeeper
 
AllMudd's Avatar
 
Join Date: Apr 2013
Location: SoCal
Posts: 1,608
How are they not lining up? Are they bolted into the mounts but the center pins wont align to the axle?

AllMudd is offline   Quote
Old 08-15-2014, 10:54 PM   #3
Jeeper
 
reno92's Avatar
 
Join Date: May 2013
Location: Cardiff By The Sea / Glamis
Posts: 1,432
I guess I need to know where the problem is. I've changed my center pin location on my spring perch which has three holes to use. I loosen the U bolts enough to lift the axle and place the center pin in the hołe I want to use, I then tighten it all down, never been a problem. What exactly are you having trouble with?
reno92 is offline   Quote
Old 08-16-2014, 07:22 AM   #4
Jeeper
 
Join Date: Jul 2014
Posts: 61
I've been trying to raise the leaf springs up to the axle and align the pin and hole, I'll try loosening the eye bolts until they are sloppy loose and see if I can lower the axle to the springs. The axle is setting on stands and I've been trying to jack the springs up to the axle, I can get the U bolts in but can not align the pin and hole because the spring plate is against the shock mount on both sides so there's no way to move it left to right so the pin lines up. I believe the front spring pins had a bevel to help them line up, the back springs do not.
Dryrot is offline   Quote
Old 08-16-2014, 09:30 AM   #5
Jeeper
 
AllMudd's Avatar
 
Join Date: Apr 2013
Location: SoCal
Posts: 1,608
Yea dont do that! Compressing the springs while nothong is connect could end bad if it were to fall on you. Lower the axle off the jack stands. Then line up the aligning pins. And remember torque the shackle bolts to 55ftlbs so you wont over tightwn then and limit the travel of the new springs.
AllMudd is offline   Quote
Old 08-17-2014, 09:29 PM   #6
Newb
 
Join Date: Aug 2013
Posts: 3
had the opposite problem could not get my fronts to line up. the last one I put on was a bitch think the spring had a twist to it

grizzlyadams73 is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 10:13 PM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC