Troubleshooting high oil pressure and hanging idle??? - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 09-07-2010, 03:44 PM   #1
Jeeper
 
Adam4fiddy's Avatar
 
Join Date: Aug 2010
Posts: 30
Troubleshooting high oil pressure and hanging idle???

Ive done some research and want to make sure im starting in the right places.

I have a 91 YJ 2.5L

Oil pressure at freeway speeds is just below 80 psi and at idle around 60psi....

Im going to start with the oil pressure sending unit and see if that is the reason, does this sound right?

I just changed the oil so i know their is the correct amount.

Does someone know the part number for the sending unit?? Just want to get the right one the first time.


Next is the hanging idle. With the clutch in coming to a stop the idle raises to 1300 to 1500 stays their for a minute then drops down to 1000 and idles steadily.

Plan on taking off the TB and cleaning it thoroughly and the IAC.


Do my methods sound like a good place to start im pretty new to the jeep and the 2.5L but from what i have read these are the cheapest fixes to the listed problems.


THANKS IN ADVANCE!!!

__________________
91 YJ just beginning.....
Adam4fiddy is offline   Quote Quick Reply
Old 09-08-2010, 12:49 PM   #2
Jeeper
 
Adam4fiddy's Avatar
 
Join Date: Aug 2010
Posts: 30
anybody?

__________________
91 YJ just beginning.....
Adam4fiddy is offline   Quote Quick Reply
Old 09-08-2010, 02:21 PM   #3
Deaky

WF Supporting Member
 
Fweaky's Avatar
 
Join Date: Aug 2009
Location: Central Virginia
Posts: 2,202
Images: 18
Assuming you used the right weight oil.... Bad oil pressure sending units seem to be the cause a lot of times on the 2.5L engines. I would change that out first as a starting point. Clean the throttle body and the IAC as you stated for the idle problem and hollar back with the results.
__________________
Nothing is foolproof to a sufficiently talented fool.
Fweaky is offline   Quote Quick Reply
Old 09-08-2010, 03:46 PM   #4
Jeeper
 
Adam4fiddy's Avatar
 
Join Date: Aug 2010
Posts: 30
thanks... yeah it had the problem with the oil pressure before i changed it. I changed it for peace of mind since i didnt know what the PO had used. Ill do these couple things and see if it helps.
__________________
91 YJ just beginning.....
Adam4fiddy is offline   Quote Quick Reply
Old 09-08-2010, 08:59 PM   #5
Jeeper
 
FNjeep's Avatar
 
Join Date: Jul 2010
Location: Everett, WA
Posts: 266
I've got a brand spanking new 'Oil Pressure Sending Unit,' and I Still get random readings every time I start the engine.

Welcome to the 91 YJ world. If ever figure this out, I'll call a Press-Conference!.
FNjeep is offline   Quote Quick Reply
Old 09-09-2010, 09:16 PM   #6
Jeeper
 
Adam4fiddy's Avatar
 
Join Date: Aug 2010
Posts: 30
well cleaned the throttle body today and it seems to have helped a little bit with the hanging idle. i havnt had a chance to far but it was really dirty inside and i could see how that could have been the cause.

havnt changed the sending unit since after looking under the hood it looks different than the one i was going to buy.

it is the part between the distributor and alternator correct? silver, few inches long with a wire coming out the top...
__________________
91 YJ just beginning.....
Adam4fiddy is offline   Quote Quick Reply
Old 09-09-2010, 09:33 PM   #7
Jeeper
 
Bignuke's Avatar
 
Join Date: Mar 2009
Location: Fort Mill, SC
Posts: 1,057
Quote:
Originally Posted by Adam4fiddy View Post
well cleaned the throttle body today and it seems to have helped a little bit with the hanging idle. i havnt had a chance to far but it was really dirty inside and i could see how that could have been the cause.

havnt changed the sending unit since after looking under the hood it looks different than the one i was going to buy.

it is the part between the distributor and alternator correct? silver, few inches long with a wire coming out the top...
Yes it is. If this doesn't fix it, your relief valve might be stuck closed if it is reading high.
__________________
'98 Jeep Wrangler Sahara - SOLD
'87 Jeep Comanche Chief - 2.5L IN THE WORKS
Bignuke is offline   Quote Quick Reply
Old 09-09-2010, 10:21 PM   #8
Jeeper
 
Adam4fiddy's Avatar
 
Join Date: Aug 2010
Posts: 30
thanks nuke. probably change it this weekend.
__________________
91 YJ just beginning.....
Adam4fiddy is offline   Quote Quick Reply
Old 09-09-2010, 10:37 PM   #9
Jeeper
 
WhiteWillSmiff's Avatar
 
Join Date: Jun 2010
Posts: 100
What's the relief valve? I have the same issue with mine. Mine is reading about 75 at highway speeds. Idle is a little choppy, but I plan on pulling the TB this weekend & giving it a thorough cleaning.
__________________
95' YJ, 4" Suspension, 31" BFG A/T, 2.5L, 5-spd., 95% of work done by yours truly.
WhiteWillSmiff is offline   Quote Quick Reply
Old 09-10-2010, 03:43 PM   #10
Jeeper
 
Adam4fiddy's Avatar
 
Join Date: Aug 2010
Posts: 30
hey will smiff do you have more pictures of you YJ with the 4" lift and 31"s. I would like to get the 4" RC and keep the new 31"s i have but dont want it to look stupid without 33"s.

thanks, and i dont know where the relief valve is....hopefully someone will chime in.
__________________
91 YJ just beginning.....
Adam4fiddy is offline   Quote Quick Reply
Old 09-10-2010, 04:14 PM   #11
Jeeper
 
WhiteWillSmiff's Avatar
 
Join Date: Jun 2010
Posts: 100
I'll snap a few in better light today, only ones I have are in shade.
__________________
95' YJ, 4" Suspension, 31" BFG A/T, 2.5L, 5-spd., 95% of work done by yours truly.
WhiteWillSmiff is offline   Quote Quick Reply
Old 09-10-2010, 04:20 PM   #12
Jeeper
 
Adam4fiddy's Avatar
 
Join Date: Aug 2010
Posts: 30
thanks man i appreciate it

__________________
91 YJ just beginning.....
Adam4fiddy is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 01:13 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC