Turn key and nothing - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 05-28-2011, 10:10 PM   #1
Newb
 
Join Date: Aug 2010
Location: Concord NC
Posts: 13
Angry Turn key and nothing

I have an 89 YJ. I turn the key and no dashlights come on. No spark, nothing. I have replaced Battery, starter and ignition switch and also the fuse. Does anyone have any idea what it might be?

__________________
Michael Beverage
mbeverage is offline   Quote Quick Reply
Old 05-28-2011, 10:22 PM   #2
J10
Jeeper
 
J10's Avatar
 
Join Date: Oct 2010
Posts: 210
Was the problem there before you did all the work or after?

J10 is offline   Quote Quick Reply
Old 05-28-2011, 10:36 PM   #3
Newb
 
Join Date: Aug 2010
Location: Concord NC
Posts: 13
Before I changed everything. I changed things because it is stuck at my house and can not get it to the shop and these things were recommended by the mechanic
__________________
Michael Beverage
mbeverage is offline   Quote Quick Reply
Old 05-29-2011, 12:58 AM   #4
J10
Jeeper
 
J10's Avatar
 
Join Date: Oct 2010
Posts: 210
You got to have a bad connection somewhere. If you cant get the dash lights on even. What about an accessory thats not controlled by the ignition switch. A dome light or something.

If you have a volt meter or test light try testing the terminals from the battery, not the posts but the actual ends you bolt on just to make sure that you are getting a good connection there.

If that is good and or you have non ignition accessries working I would guess your ignition switch is toast
J10 is offline   Quote Quick Reply
Old 05-29-2011, 12:58 AM   #5
Jeeper
 
Undead-89's Avatar
 
Join Date: Feb 2011
Location: Loveland, CO
Posts: 760
Did you check all the cables from the battery. The ground cable goes straight to the engine block and sometimes gets loose/corroded. Did you clean the battery terminals and cable connections before installing the battery? When you say "no dashlights" do you mean absolutely no lights? Does anything else electrical work?

Another place to check. Against the firewall is bunch of wires connected to a single point on a bunch of spade lugs. I had one of these from the battery harness break once and had to reconnect it by putting a new round lug on and securing the lug under the nut.
Undead-89 is offline   Quote Quick Reply
Old 05-29-2011, 08:44 AM   #6
Jeeper
 
Join Date: May 2011
Posts: 317
Happened to me. Turned out to be my ground cable from the battery was bad inside. The ends looked perfect but was cracked or something I guess. I didn't take it apart to find out. But a new ground cured my problems. Till the next one.
Hemi YJ is offline   Quote Quick Reply
Old 05-29-2011, 09:38 AM   #7
Newb
 
Join Date: Aug 2010
Location: Concord NC
Posts: 13
Thanks everyone. I am trying your suggestions and will let you know.
__________________
Michael Beverage
mbeverage is offline   Quote Quick Reply
Old 05-29-2011, 09:40 AM   #8
Newb
 
Join Date: Aug 2010
Location: Concord NC
Posts: 13
I have the headlights that work and the clock is working.
__________________
Michael Beverage
mbeverage is offline   Quote Quick Reply
Old 05-29-2011, 10:42 AM   #9
Newb
 
Join Date: Aug 2010
Location: Concord NC
Posts: 13
I have an accessory and it works
__________________
Michael Beverage
mbeverage is offline   Quote Quick Reply
Old 05-29-2011, 06:25 PM   #10
J10
Jeeper
 
J10's Avatar
 
Join Date: Oct 2010
Posts: 210
Well time to check the ignition switch. Not sure of any easy ways of doing that.
I'd be half tempted to do the screw driver trick to by pass the solenoid on the starter.
J10 is offline   Quote Quick Reply
Old 06-01-2011, 04:08 PM   #11
Newb
 
Join Date: Aug 2010
Location: Concord NC
Posts: 13
I did the celanoid also. I am stumped. I will keep replacing things
__________________
Michael Beverage
mbeverage is offline   Quote Quick Reply
Old 06-01-2011, 04:26 PM   #12
Jeeper
 
RLaFitte's Avatar
 
Join Date: Mar 2010
Location: Newport, Tennessee
Posts: 169
Isn't there a fuse for the ignition in the fuse panel?
__________________
IMAGE is EVERYTHING!

Hee Hee, you ass in a heap o trouble, Boy! ...Great big Georgia state cop
RLaFitte is offline   Quote Quick Reply
Old 06-02-2011, 06:41 PM   #13
Newb
 
Join Date: Aug 2010
Location: Concord NC
Posts: 13
yes changed the fuse also
__________________
Michael Beverage
mbeverage is offline   Quote Quick Reply
Old 06-02-2011, 09:50 PM   #14
J10
Jeeper
 
J10's Avatar
 
Join Date: Oct 2010
Posts: 210
Quote:
Originally Posted by mbeverage View Post
I did the celanoid also. I am stumped. I will keep replacing things
You replaced it or did you try and by pass it to verify it has power to it?
Its a quick easy test to see if its an ignition switch issue or another problem such as a loose or bad ground as mentioned before
J10 is offline   Quote Quick Reply
Old 06-19-2011, 05:45 PM   #15
Newb
 
Join Date: Aug 2010
Location: Concord NC
Posts: 13
ok Thanks for all your comments. I broke down and towed it to the shop and they found out the previous owner had done some bad wiring. They rewired and now starts

__________________
Michael Beverage
mbeverage is offline   Quote Quick Reply
Reply

Tags
no spark , start

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 12:06 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC