Turn Signal/Brake Light Issue, I'm stumped - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today



Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 08-12-2012, 01:27 PM
Thread Starter
  #1
Jeeper
 
Join Date: Jun 2012
Location: Campbellsville
Posts: 27
bane1975 is on a distinguished road
Turn Signal/Brake Light Issue, I'm stumped

I have recently purchased and 91 YJ (my second one), and had steering column issues. Have had those fixed, but the turn signal/brake/hazzard lights do not function. I have checked the bulbs(good), flasher(getting current when the turn signal is used), and the flasher seems to be closed when current is applied. The parking lights word fine. The only out of the ordinary thing, is the flasher was not in the fuse box, it has two wires attached to it that come from behind the fuse box. I tested the prongs in the fuse box, no current to either, and no difference in them when the signal is used.

Any insight would be greatly appreciated.
bane1975 is offline   Quote
Old 08-14-2012, 01:19 AM   #2
Jeeper
 
0III0forlife's Avatar
 
Join Date: Mar 2012
Location: Ridgway, Pa.
Posts: 4,757
0III0forlife is on a distinguished road
The brake lights and the hazard lights all run thru the turn signals so the problem could possibly be your turn signal switch. Maybe check the fuse for the signals?

If you are getting power into your flasher but not out of it, then i would say the flasher is bad.

0III0forlife is offline   Quote
Old 08-17-2012, 12:37 PM   #3
Jeeper
 
Reaper83's Avatar
 
Join Date: Aug 2012
Location: Hertford NC
Posts: 104
Reaper83 is on a distinguished road
i had a similar problem and it turned out to be a few contacts on the turn signal lever that where broken off inside or not making contact isn't there a relay for that also i would check that as well have had a bad relay on a few cars that caused that problem
__________________
Mike AKA Reaper
93 Jeep Safari
Reaper83 is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off





All times are GMT -5. The time now is 02:02 AM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC
« Back

Enter your email address:

Delivered by FeedBurner