Urgent help needed - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 06-29-2013, 05:07 AM   #1
Jeeper
 
Megamonster's Avatar
 
Join Date: Apr 2013
Location: Southern Europe
Posts: 135
Urgent help needed

My YJ 91 2.5L died after it started to lose power and a loud pop that seemed to come from under the jeep. Now it does not start. Any idea what could be the reason? Thanks

__________________
91 YJ 2.5 Manual
Megamonster is offline   Quote Quick Reply
Old 06-29-2013, 06:32 AM   #2
Jeeper
 
DirtyRob's Avatar
 
Join Date: Sep 2011
Location: Sampson County N.C.
Posts: 1,130
Images: 3
Is there any oil on the ground under the engine?

__________________
wherever you go there you are..........
DirtyRob is offline   Quote Quick Reply
Old 06-29-2013, 07:47 AM   #3
Jeeper
 
Megamonster's Avatar
 
Join Date: Apr 2013
Location: Southern Europe
Posts: 135
No. Every thing looks normal. After the tow ( of course) it started back up. But now it makes a prop prop sound when it revs down. So I'm thinking the cat might have gone bad. Any other areas that I can check? It left me stranded away from home.
__________________
91 YJ 2.5 Manual
Megamonster is offline   Quote Quick Reply
Old 06-29-2013, 01:00 PM   #4
Jeeper
 
Megamonster's Avatar
 
Join Date: Apr 2013
Location: Southern Europe
Posts: 135
Any other ideas?
__________________
91 YJ 2.5 Manual
Megamonster is offline   Quote Quick Reply
Old 06-29-2013, 01:28 PM   #5
Jeeper
 
AllMudd's Avatar
 
Join Date: Apr 2013
Location: SoCal
Posts: 1,281
The prop prop noise is it happen while downshifting? And how is the power while driving? If your cat is bad you will notice almost no power while you try to accelerate.
AllMudd is offline   Quote Quick Reply
Old 06-29-2013, 01:51 PM   #6
Jeeper
 
Megamonster's Avatar
 
Join Date: Apr 2013
Location: Southern Europe
Posts: 135
Quote:
Originally Posted by AllMudd View Post
The prop prop noise is it happen while downshifting? And how is the power while driving? If your cat is bad you will notice almost no power while you try to accelerate.
After the pop noise, which sounded like a .22, I could only accelerate for about ten seconds then it lost power and shut down. I did notice that the rpm stayed the same, for a few seconds, while the engine lost power.

My guess is that the cat is plugged and after continuous use in the highway, the pressure increases? Is this possible?

Thanks.
Megamonster is offline   Quote Quick Reply
Old 06-29-2013, 03:18 PM   #7
Jeeper
 
Sahara1995's Avatar
 
Join Date: Jun 2013
Posts: 73
I had a similar problem with a dodge ram truck, it ended up being an O2 sensor. My cats actually glowed red so I thought it was the cats but it was an O2.
Sahara1995 is offline   Quote Quick Reply
Old 06-29-2013, 04:15 PM   #8
Jeeper
 
Megamonster's Avatar
 
Join Date: Apr 2013
Location: Southern Europe
Posts: 135
Quote:
Originally Posted by Sahara1995 View Post
I had a similar problem with a dodge ram truck, it ended up being an O2 sensor. My cats actually glowed red so I thought it was the cats but it was an O2.
I replaced the o2 sensor recently and it ran fine until now. It was a spectra Premium brand.
Megamonster is offline   Quote Quick Reply
Old 06-29-2013, 04:18 PM   #9
Jeeper
 
maverick1979's Avatar
 
Join Date: Jun 2013
Posts: 105
Sounds like a cat to me too
maverick1979 is offline   Quote Quick Reply
Old 06-29-2013, 05:51 PM   #10
Jeeper
 
AllMudd's Avatar
 
Join Date: Apr 2013
Location: SoCal
Posts: 1,281
Quote:
Originally Posted by maverick1979 View Post
sounds like a cat to me too
x2
AllMudd is offline   Quote Quick Reply
Old 07-01-2013, 11:19 AM   #11
Jeeper
 
Megamonster's Avatar
 
Join Date: Apr 2013
Location: Southern Europe
Posts: 135
Update:

I went to get the Jeep today at the city that it left me stranded in. I did not wanted to take any chances with it so I took the cat out and drove back home loud and slow. Made it home without incident. A new kitty is on the way should be here by Friday.

Is there any other things that I should check while is apart? Thanks for the help.
__________________
91 YJ 2.5 Manual
Megamonster is offline   Quote Quick Reply
Old 07-01-2013, 07:42 PM   #12
Jeeper
 
Sahara1995's Avatar
 
Join Date: Jun 2013
Posts: 73
If the O2 you replaced was bad that could be what caused the cat to go. Can cause the cat to run hot n melt down causing the clog that left you high n dry
Sahara1995 is offline   Quote Quick Reply
Old 07-07-2013, 01:10 PM   #13
Jeeper
 
Megamonster's Avatar
 
Join Date: Apr 2013
Location: Southern Europe
Posts: 135
I am in the process of taking the cat completely out since the new one should be here tomorrow. I remove the clamps that connect the cat to the muffler but the cat does not want to let go of the muffler. It is welded inside? Do i need to remove the TC skid plate to get the cat completely out?

Thanks.
Megamonster is offline   Quote Quick Reply
Old 07-07-2013, 01:51 PM   #14
Supporting Member

WF Supporting Member
 
wasomma's Avatar
 
Join Date: Aug 2010
Location: Baltimore, MD
Posts: 924
check your muffler, when my cat went the pieces fouled the muffler as well.

It depends if the cat is stock, but either way you should not have to remove the TC skid place to get it out
wasomma is offline   Quote Quick Reply
Old 07-07-2013, 02:23 PM   #15
Jeeper
 
Megamonster's Avatar
 
Join Date: Apr 2013
Location: Southern Europe
Posts: 135
Quote:
Originally Posted by wasomma View Post
check your muffler, when my cat went the pieces fouled the muffler as well.

It depends if the cat is stock, but either way you should not have to remove the TC skid place to get it out
I got it to wiggle but the muffler still not letting go of the cat even with a pry bar and a hammer

I am going to soak the cat in liquid wrench and I will give it another try tomorrow.
Megamonster is offline   Quote Quick Reply
Old 07-07-2013, 05:28 PM   #16
Jeeper
 
Sahara1995's Avatar
 
Join Date: Jun 2013
Posts: 73
Heat the hell out of it. Preferably with and oxygen and acetylene torch. If you don't have that which I, guessing you don't you can try a map gas torch it burns hotter than a propane torch. You can get me Home Depot. If you can get real hot you can hammer it right out.
Sahara1995 is offline   Quote Quick Reply
Old 07-07-2013, 05:43 PM   #17
Jeeper
 
Megamonster's Avatar
 
Join Date: Apr 2013
Location: Southern Europe
Posts: 135
Quote:
Originally Posted by Sahara1995 View Post
Heat the hell out of it. Preferably with and oxygen and acetylene torch. If you don't have that which I, guessing you don't you can try a map gas torch it burns hotter than a propane torch. You can get me Home Depot. If you can get real hot you can hammer it right out.
That is a great idea. Fortunately my wife just suggested that I change the rest of the exhaust since it is only a matter of time that I will have to buy a new muffler. It is stock.

I'll keep trying to take it apart without resorting to cutting it out until the new parts arrive
Megamonster is offline   Quote Quick Reply
Old 07-07-2013, 06:05 PM   #18
Supporting Member

WF Supporting Member
 
wasomma's Avatar
 
Join Date: Aug 2010
Location: Baltimore, MD
Posts: 924
i would just get a cat back system as well, I went Borla and I loved it
wasomma is offline   Quote Quick Reply
Old 07-07-2013, 06:13 PM   #19
Jeeper
 
Megamonster's Avatar
 
Join Date: Apr 2013
Location: Southern Europe
Posts: 135
Bought a cat back since the wife approved it. Not a Borla but looks good enough for me.
Megamonster is offline   Quote Quick Reply
Old 07-20-2013, 09:43 AM   #20
Jeeper
 
Megamonster's Avatar
 
Join Date: Apr 2013
Location: Southern Europe
Posts: 135
Good News everyone:

Finally received all the parts and finished installing them. Test drive went ok. I will be mall crawling all next week to make sure issue was resolved. Now i'm just enjoying that brand new exhaust smell.

Thank you all.
Attached Images
 
Megamonster is offline   Quote Quick Reply
Old 07-20-2013, 11:42 AM   #21
Supporting Member

WF Supporting Member
 
wasomma's Avatar
 
Join Date: Aug 2010
Location: Baltimore, MD
Posts: 924
sweet dude glad it worked out for you
wasomma is offline   Quote Quick Reply
Old 07-20-2013, 08:15 PM   #22
Jeeper
 
Sahara1995's Avatar
 
Join Date: Jun 2013
Posts: 73
Excellent!

Sahara1995 is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



logo carid shop wrangler parts carid fender flares custom wheels store avs deflectors at carid
» Rates
Get low rates on auto insurance in Canada!

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 02:23 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC