Washer fluid wont spray - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 04-03-2013, 03:08 PM   #1
Jeeper
 
Huntsman180's Avatar
 
Join Date: Jul 2012
Location: Papillion, Nebraska
Posts: 218
Washer fluid wont spray

New Washer pump.

Blew out the washer lines, they're clear.

Windshield wipers turn both on normal settings and on the 'wash off' setting that involves the washer fluid.

1993.

Kinda curious what's wrong, and why the fluid won't spray. I'm thinking its electrical, and the motor isn't turning on, since everything else is clear. Where/how should I go about fixing this?

__________________


Watch my custom dash project unfold:
http://www.wranglerforum.com/f218/cu...me-491025.html
Huntsman180 is offline   Quote Quick Reply
Old 04-03-2013, 07:14 PM   #2
jokerchief462

WF Supporting Member
 
jokerchief462's Avatar
 
Join Date: Apr 2012
Location: North Las Vegas
Posts: 9,275
From a 1990 FSM hope this helps. Troubleshooting guide.
Attached Thumbnails
Click image for larger version

Name:	Wiper Motor.png
Views:	54
Size:	120.8 KB
ID:	231235   Click image for larger version

Name:	Wiper Motor 2.png
Views:	36
Size:	85.2 KB
ID:	231236  


__________________
89 2.5 TBI, 4" RC lift, 1" Booms, SYE, Adams Driveshafts front and rear, Ford 8.8 with 4:88s, BFG 33X12.50X15, and a ton of other stuff.

AF Jeep Club Tail Number 184
jokerchief462 is offline   Quote Quick Reply
Old 04-03-2013, 07:34 PM   #3
Jeeper
 
cclax44's Avatar
 
Join Date: Jul 2012
Posts: 98
i know that when its cold, mine wont spray until the engine is warm.
cclax44 is offline   Quote Quick Reply
Old 04-04-2013, 10:23 AM   #4
President, ThumbJeeps

WF Supporting Member
 
sevenservices's Avatar
 
Join Date: Sep 2009
Location: Mid-Michigan/Thumb
Posts: 3,938
double check all hoses for air leaks. Put a small hose on the pump, will it shoot out it? Take it 1 step at a time until you find either a bad pump, air leak or water leak.
__________________
-Chris
President, ThumbJeeps
CB Callsign "AirForce One"


1994 Wrangler YJ I6 4.0 H/O Auto 3 spd. 4" RC (33x12.5) (15x8) 3:54 Gears
sevenservices is offline   Quote Quick Reply
Old 04-04-2013, 03:21 PM   #5
Jeeper
 
Join Date: Jan 2010
Location: Las Cruces, NM
Posts: 2,291
Its either a bad wire connection or broken wire or the switch in the stem is messed up if you don't have power at the pump....
__________________
2013 WRANGLER SPORT 2 DR., V-6 ,AUTO,HARD TOP
(Sold)1994 Jeep Wrangler 2.5L, Bestop top
/w steel half door and slider windows
5 speed, 2.5" lift, 31" tires,rack lights
Garyk is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



logo carid shop wrangler parts carid fender flares custom wheels store avs deflectors at carid
» Rates
Get low rates on auto insurance in Canada!

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 04:57 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC