Water leaking on feet when drive - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 12-22-2013, 05:42 PM   #1
Jeeper
 
rossYJbujol's Avatar
 
Join Date: Sep 2013
Posts: 100
Water leaking on feet when drive

When I'm driving there is water leaking on my feet every once and a while and it gets pretty annoying, I turned on my heaters today and water started spraying on me, I haven't looked at it yet. Any ideas of what's going on?

rossYJbujol is offline   Quote
Old 12-22-2013, 05:51 PM   #2
jokerchief462

WF Supporting Member
 
jokerchief462's Avatar
 
Join Date: Apr 2012
Location: North Las Vegas
Posts: 9,830
Cowl vent drain rubber hose passenger side of firewall. Open the hose at the bottom and clean it out.

Or your cowl seal is leaking below the windshield.

__________________
89 2.5 TBI, 4" RC lift, 1" Booms, SYE, Adams Driveshafts front and rear, Ford 8.8 with 4:88s, BFG 33X12.50X15, and a ton of other stuff.

AF Jeep Club Tail Number 184
jokerchief462 is offline   Quote
Old 12-23-2013, 04:35 AM   #3
Jeeper
 
Jkilbert's Avatar
 
Join Date: Aug 2013
Location: McKeesport,Pa
Posts: 204
Send a message via Yahoo to Jkilbert
X2
Jkilbert is offline   Quote
Old 12-23-2013, 09:37 AM   #4
Jeeper
 
peety's Avatar
 
Join Date: Feb 2013
Location: Almost a PINEY...
Posts: 225
X3
__________________
Patience and perseverance have a magical affect before which difficulties disappear and obstacles vanish.

John Quincy Adams
peety is offline   Quote
Old 12-24-2013, 08:02 AM   #5
BAP
Jeeper
 
BAP's Avatar
 
Join Date: Jan 2012
Posts: 1,909
x4,,,,my gas pedal foot ,,,clean ur hose out..
__________________
4inch suspension lift,3inch body lift,4.0 5 speed,8.8 with disc,s,16inch moto metal rims ,and some 35s..
with trail rash..and getting 25mpg,s
BAP is offline   Quote
Old 01-08-2014, 09:41 AM   #6
Jeeper
 
rossYJbujol's Avatar
 
Join Date: Sep 2013
Posts: 100
It was cowl vent hose thanks guys! I had mud clogged up to the top! I guess that's what happens when you mudride a lot! Hahahah
rossYJbujol is offline   Quote
Old 01-10-2014, 02:13 PM   #7
Jeeper
 
Join Date: Aug 2012
Location: Newport News, VA
Posts: 50
I've had it snow on my feet lol!!! I deff have to do this

zr.despain14 is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 11:22 AM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC