Weird electrical problem in my YJ - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 08-14-2012, 07:30 PM   #1
Newb
 
Join Date: Apr 2009
Posts: 12
Unhappy Weird electrical problem in my YJ

This happened for the first time last week. Now when I turn on my turn signals, my radio goes off. Then it comes right back on - even though the turn signals continue to operate. I have not done any electrical work on it in many months, so I don't think I caused this. The voltmeter has always twitched a bit when the turn signal was on, and it is still doing that.
I thought I might start by replacing the voltage regulator and maybe the flasher unit (although it is only a year old).
I wonder if the turn signal mechanism might be wearing out.
Does anyone have any thoughts on a solution to this? Thank you.

meptmoore is offline   Quote
Old 08-14-2012, 07:45 PM   #2
Jeeper
 
Jeep716's Avatar
 
Join Date: Aug 2010
Posts: 397
Check your battery terminals. Sounds like a bad ground there or somewhere. I had to clean every one I could find in mine to get the bugs out.

Jeep716 is offline   Quote
Old 08-15-2012, 12:11 PM   #3
Newb
 
Join Date: Apr 2009
Posts: 12
Sorry, I should have mentioned that I already cleaned my terminals and reinstalled the cables. I also removed the ground cable where it attaches to the alternator bracket on the engine and cleaned that up as well. Thanks for the suggestion though. I'm still scratching my head.
meptmoore is offline   Quote
Old 08-19-2012, 12:07 AM   #4
Jeeper
 
Jeep716's Avatar
 
Join Date: Aug 2010
Posts: 397
The turn signal switch is a common fail item. Mine is sticky. Not sure if it would effect power to radio though. Test with a separate new fused hot wire from bat + to radio + and maybe add a second frame ground from radio to body and see if that helps.
Jeep716 is offline   Quote
Old 08-19-2012, 12:53 AM   #5
Jeeper
 
0III0forlife's Avatar
 
Join Date: Mar 2012
Location: Ridgway, Pa.
Posts: 3,832
Images: 6
There are more grounds than just the negative wire to the alternator bracket.

Like it was said above, its a grounding issue. Atleast thats what it sounds like.

You can look for a strap that looks like braided copper, going from the motor to the firewall, And on some models there is a grounding strap that is located on 1 of the body mounts, usually either under the drivers or passengers floor.
0III0forlife is offline   Quote
Reply

Tags
flasher unit , turn signal , voltage , voltage regulator

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 04:16 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC