what is going on with my 4 wheel drive???? - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 12-16-2012, 09:30 PM   #1
Newb
 
Join Date: Dec 2012
Posts: 3
Question what is going on with my 4 wheel drive????

ok, i have an 89 wrangler 4.2 all stock except it has 33" super swampers on it. lift has not yet been installed, will be installed in spring. But i have been having issues with my 4wd. at first when i almost got stuck off roading i thaught that it wasnt working at all, so i figured it was a vac line, but it wasnt. i put it up on jack stands and both front wheels were spinning when i put it in 4wd? so then i went off roading again and went to flex on a rock and my front wheels wouldnt spin so i couldnt get on it then i got stuck on an un even bump (rear differential is not locked so only one wheel spins) then almost got stuck again. so i got home put it up on jack stands to check it out and 4wd... worked fine? when i was in the trail and when ever i put it in 4wd weather it works or not the gears always get really low like they should when it is in 4wd low. so it seems like it is working and the 4wd light always comes on but when eveer i actually try to use the 4wd in the trail the front wheels dont move. but when i put it on jack stands and their is no pressure or any resistance it works fine. What is going on with my 4wd? when ever i need it it doesnt work? WTF?????

acciceman is offline   Quote Quick Reply
Old 12-16-2012, 09:49 PM   #2
Sponsoring Vendor
 
JPi4.0's Avatar
 
Join Date: Feb 2012
Posts: 850
Do you have locking hubs?

__________________
Jeeperformance, Inc
Yucaipa CA.
877-795-JEEP
https://www.facebook.com/Jeeperformanceinc http://www.jeeperformanceinc.com/
JPi4.0 is offline   Quote Quick Reply
Old 12-16-2012, 09:57 PM   #3
Jeeper
 
brs256's Avatar
 
Join Date: Jul 2012
Location: ft riley ks
Posts: 441
i'd still bet that it is the vac. disconnec t if u have one

its extremely simple to fix if its the vac disco

on my cousins yj we slid the collar so the shafts were connected and put a large zip tie on the shaft that the shift fork mounts to ... effectively semi-permantly connecting the disco

or you can waste money on a cable disco setup

or do the smart thing and swap in a non disco shaft
__________________
97 #1 TJ 4.0 5spd - built,beat,rolled,totaled,stripped, and SOLD

97 #2 TJ 4.0 5spd and some stuff from - savvy, rokmen, corbeau, a-z fab, rock hard 4x4,metal cloak, and others ....slowly building it up

06 Civic - tint + 36mpg
brs256 is offline   Quote Quick Reply
Old 12-16-2012, 10:17 PM   #4
Newb
 
Join Date: Dec 2012
Posts: 3
no it does not not have locking hubs. but if it was a vac line why does the 4wd work fine when it is up on stand? caus if it is vac line it wouldnt engage at all right?
acciceman is offline   Quote Quick Reply
Old 12-17-2012, 10:30 AM   #5
Jeeper
 
Xpress's Avatar
 
Join Date: Jan 2011
Location: El Cajon
Posts: 2,585
The 4x4 light is activated by the vacuum lines on that year Wrangler, so even if the light comes on, it doesn't mean the shift motor is locking the shafts.
__________________


2.5L Genius of some sort.
Xpress is offline   Quote Quick Reply
Old 12-17-2012, 10:35 AM   #6
Newb
 
Join Date: Dec 2012
Posts: 3
So if it I my vac lines what is te best way to fix this? I have heard of posilock or products like that? Would that solve the problem or is their a better solution
acciceman is offline   Quote Quick Reply
Old 12-17-2012, 08:18 PM   #7
Jeeper
 
pocketpistolpete's Avatar
 
Join Date: May 2012
Location: NE INDIANA
Posts: 87
I run a posi-lock on mine (installed be PO) and it works fine. if i personally had to do it, i'd swap for a non-vacuum front axle or just lock it
__________________
4:10 = 2.5
pocketpistolpete is offline   Quote Quick Reply
Old 12-17-2012, 09:16 PM   #8
jokerchief462

WF Supporting Member
 
jokerchief462's Avatar
 
Join Date: Apr 2012
Location: North Las Vegas
Posts: 9,387
Posi lock or permanently lock it out. It is in the sticky s at the top of the page. Gut the vacuum system and get something reliable.

__________________
89 2.5 TBI, 4" RC lift, 1" Booms, SYE, Adams Driveshafts front and rear, Ford 8.8 with 4:88s, BFG 33X12.50X15, and a ton of other stuff.

AF Jeep Club Tail Number 184
jokerchief462 is offline   Quote Quick Reply
Reply

Tags
4wd doesnt work , 4wd doesnt work right , help advise , only sometimes works

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




» Featured Product

All times are GMT -5. The time now is 09:12 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC