Won't Idle - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today



Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 08-27-2013, 07:32 AM
Thread Starter
  #1
Jeeper
 
Join Date: Oct 2011
Location: East of Gratiot, West of Zanesville, Ohio
Posts: 223
thresher_593 is on a distinguished road
Won't Idle

I've been prepping my '94 YJ for paint so I have all the fenders, doors, tailgate, etc. removed. The interior is stripped, no seats in and the dash is loosened but not removed. I hadn't run it since about the 4th of July (been putting a roof on the house & garage) so I tried to start it up last night. It will start but won't idle. Runs just fine as long as you hold the gas pedal down. I'm thinking maybe fuel pump? Anyone else care to hazard a guess? it's a '94 with the 4.0 and TBI. Since I have had it it seems like it cranks a little longer than it should to start. Anyway, any suggestions as to where to start are welcome.
__________________
Illegitimi non carborundum
thresher_593 is offline   Quote
Old 08-27-2013, 07:55 AM   #2
Jeeper
 
AllMudd's Avatar
 
Join Date: Apr 2013
Location: SoCal
Posts: 1,610
AllMudd is on a distinguished road
Pull the codes with the "key trick" and go from there. Maybe you disconnected something that was needed? Could be as simple as a vacuum hose/line.

AllMudd is offline   Quote
Old 08-27-2013, 11:27 AM   #3
Jeeper
 
c5wagner's Avatar
 
Join Date: Apr 2013
Location: Highland, California
Posts: 2,068
c5wagner is on a distinguished road
Old gas maybe? You could also take off the idle air control valve and clean it(google for help)
__________________
Build Thread 1989 YJ, np231 sye/wide chain/6 pinion planetary, D30/8.8 ARBs/4.56, 31" rollers for now, bds 3.5" springs, 1" Boom Shackles, crossover heim steering (Soon to come: TBI 350, 4l60)
c5wagner is offline   Quote
 
Old 08-28-2013, 08:32 PM
Thread Starter
  #4
Jeeper
 
Join Date: Oct 2011
Location: East of Gratiot, West of Zanesville, Ohio
Posts: 223
thresher_593 is on a distinguished road
It was the air control valve. Took it apart and cleaned it and it started an ran. I'll replace it before I button this thing back up.

Thanks for the tip.
__________________
Illegitimi non carborundum
thresher_593 is offline   Quote
Old 08-29-2013, 11:50 AM   #5
Jeeper
 
c5wagner's Avatar
 
Join Date: Apr 2013
Location: Highland, California
Posts: 2,068
c5wagner is on a distinguished road
Quote:
Originally Posted by thresher_593 View Post
It was the air control valve. Took it apart and cleaned it and it started an ran. I'll replace it before I button this thing back up.

Thanks for the tip.
No problem, happened with my old 93 cherokee
__________________
Build Thread 1989 YJ, np231 sye/wide chain/6 pinion planetary, D30/8.8 ARBs/4.56, 31" rollers for now, bds 3.5" springs, 1" Boom Shackles, crossover heim steering (Soon to come: TBI 350, 4l60)
c5wagner is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off






All times are GMT -5. The time now is 03:10 AM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC
« Back

Enter your email address:

Delivered by FeedBurner