Wont start - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 04-17-2009, 10:17 PM   #1
Jeeper
 
Joey's Avatar
 
Join Date: Mar 2007
Posts: 96
Wont start

I have a 95 Yj with 2.5. All she does when I turn key is click. I checked the voltage at battery, it was good. I moved to the starter, voltage was good. I took the starter off and hooked to jumper cables and it turned over on the floor. Put starter back on and same thing happens. Now I click my lights on and there real dim and my radio clicks off and on. Put new battery terminals on and checked the ground to the block. Every things tight, its about to blow my mind. I think theres a loose ground somewhere. Any ideas. Thanks for the help in advanced.

Joey is offline   Quote Quick Reply
Old 04-17-2009, 10:45 PM   #2
Jeeper
 
RednekYJ's Avatar
 
Join Date: Feb 2007
Location: LITH IL
Posts: 1,352
dead spot in the starter. have someone tap it with a hammer while cranking.

RednekYJ is offline   Quote Quick Reply
Old 04-18-2009, 12:23 PM   #3
Jeeper
 
Joey's Avatar
 
Join Date: Mar 2007
Posts: 96
Would that make my lights dim and everything too.
Joey is offline   Quote Quick Reply
Old 04-18-2009, 01:20 PM   #4
kik
Jeeper
 
kik's Avatar
 
Join Date: Dec 2008
Posts: 4,709
Images: 1
It does sound like a bad ground.
kik is offline   Quote Quick Reply
Old 04-18-2009, 01:34 PM   #5
Jeeper
 
Joey's Avatar
 
Join Date: Mar 2007
Posts: 96
Are there any other main grounds besides the one to the block and the fire wall?
Joey is offline   Quote Quick Reply
Old 04-18-2009, 01:53 PM   #6
Jeeper
 
Join Date: Feb 2009
Location: Honeybrook Pa
Posts: 44
X2 bad spot in the starter My XJ did the same thing and the starter was shot
__________________
93 YJ 3.5 lift 31x10.50 Dunlops on soft 8s 8K winch Tj Ft bumper RRC rear bumper w/tire mt RRC rock rails TJ flares'dual Optima red topsw/homemade relay/jumpstart mode Congo cage and Garman Wilderness rack. CB and Fireband 2-ways undercover LED red lites and siren. Full EMS gear including 02 and AED A work in progress never finished!!!!
EMS 34 20 is offline   Quote Quick Reply
Old 04-18-2009, 02:10 PM   #7
Newb
 
Join Date: Mar 2009
Location: NC
Posts: 14
remember, it should have a body to chassis ground too.
jmurray79 is offline   Quote Quick Reply
Old 04-19-2009, 01:10 AM   #8
Jeeper
 
87YJWrangler's Avatar
 
Join Date: Sep 2008
Location: Owatonna, Minnesota
Posts: 640
Yeah check for your grounds and than maybe your alternator too
__________________
Mine: 1987 YJ 4.2 5spd soft top
98% of people when they are about to go into the ditch say "oh shit!" The other 2% are Minnesotans and when we are about to go into a ditch we say "Hold my beer and watch this shit!"
87YJWrangler is offline   Quote Quick Reply
Old 04-19-2009, 08:35 AM   #9
Jeeper
 
Joey's Avatar
 
Join Date: Mar 2007
Posts: 96
I took the starter back off today. I am going to take it to advanced auto and let them test it and I will let you guys know what I find. Thanks for the advice.
Joey is offline   Quote Quick Reply
Old 04-20-2009, 02:00 PM   #10
Jeeper
 
Join Date: Mar 2009
Location: Seattle
Posts: 259
How many volts are you getting at the battery? 14?
I thought maybe it wasn`t charging properly when I first read your post but I would
not only make sure everything is tight but clean. If you have debris under your grounds you may not be getting a good ground even though everything`s tight.

Rainycity is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Good Crank w/o start, dead gages joepowles TJ Tech Forum 21 03-16-2013 04:12 PM
Takes forever to start.. Mike2000 General Jeep Discussion 7 04-10-2011 10:42 AM
Where to start... mspencer54 YJ General Discussion Forum 2 03-04-2009 08:59 PM
wont start cold?! Mikeyz89YJ YJ Tech Forum 2 02-14-2009 09:14 AM
wont start? snowmanzz13 YJ Tech Forum 10 04-14-2008 12:14 PM



» Featured Product

All times are GMT -5. The time now is 04:18 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC