Yj engine codes/rough idle - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 07-16-2013, 11:28 PM   #1
Jeeper
 
Join Date: Jun 2011
Location: Tallahassee
Posts: 73
Yj engine codes/rough idle

My yj has been giving me some issues. She starts up fine and idles but as soon as I drive and stop like at my apartment gate or a light she idles speratically like 1000rpm to 500, back to 1000 then down to 500, and back and forth again. Kind of like loping or acting like its going to die then gets a jolt of energy . During acceleration she seems fine a little sluggish but that I think is due to me crappy welding my exhaust on "there's some holes in the pipe and makes the jeep sound like a rice burner since the muffler sits half way under the jeep. I have also been getting an lean code and an o2 sensor code. I was told by the shop that I had a crack in my exhaust manifold, and I know there's holes in the pipe as I can feel the hot exhaust air "popping" out of the exhaust hole. Does anyone know what might be causing it to idle like that? And for some reason my oil pressure sensor starts off regular and as the jeep heats up it drops to the second to last line on the gauge, is this normal? She seems to have enough oil. Any help is appreciated!

cautiocones is offline   Quote Quick Reply
Old 07-17-2013, 12:34 AM   #2
Supporting Member

WF Supporting Member
 
wasomma's Avatar
 
Join Date: Aug 2010
Location: Baltimore, MD
Posts: 924
what are all the codes it's throwing

wasomma is offline   Quote Quick Reply
Old 07-17-2013, 10:11 AM   #3
Jeeper
 
Join Date: Jun 2011
Location: Tallahassee
Posts: 73
Code 12,21,33,51,55
cautiocones is offline   Quote Quick Reply
Old 07-17-2013, 12:56 PM   #4
Supporting Member

WF Supporting Member
 
wasomma's Avatar
 
Join Date: Aug 2010
Location: Baltimore, MD
Posts: 924
Sounds like you might have multiple issues going on, the codes that matter out of those are 21 and 51. Is it time for a new O2 sensor? If so that might be a start for your issues, in regards to the cracked manifold and holes in your exhaust, that can give your O2 sensor the wrong readings and cause it send more fuel than it needs. So replace your exhaust manifold and button up any holes in the exhaust system. Check your cat if you have one.

Not sure about the oil.

source:
Jeep Parts, Jeep Accessories & Jeep Soft Tops From The Jeep Parts Experts - Quadratec
wasomma is offline   Quote Quick Reply
Old 07-17-2013, 02:35 PM   #5
Jeeper
 
Michigan jeeper's Avatar
 
Join Date: Feb 2013
Posts: 412
Mine was doing this too this morning not as bad though I changed the o2 sensor and it seemed to do the trick!
Michigan jeeper is offline   Quote Quick Reply
Old 07-17-2013, 04:06 PM   #6
Jeeper
 
Join Date: Jun 2011
Location: Tallahassee
Posts: 73
Well thw jeep has 100k miles and no cat, does that sound about the correct mileage to replace my 02 sensor?
cautiocones is offline   Quote Quick Reply
Old 07-17-2013, 04:13 PM   #7
Jeeper
 
Michigan jeeper's Avatar
 
Join Date: Feb 2013
Posts: 412
Yeah defiantly mine has 92000 and I can't say if I have a cat or not on here but I'm sure you could guess
Michigan jeeper is offline   Quote Quick Reply
Old 07-17-2013, 04:44 PM   #8
Jeeper
 
Join Date: Jun 2011
Location: Tallahassee
Posts: 73
Okay does anyone know about code 51
cautiocones is offline   Quote Quick Reply
Old 07-17-2013, 04:58 PM   #9
Jeeper
 
Michigan jeeper's Avatar
 
Join Date: Feb 2013
Posts: 412
It's a lean air fuel mixture
Michigan jeeper is offline   Quote Quick Reply
Old 07-17-2013, 10:47 PM   #10
Jeeper
 
Join Date: Jun 2011
Location: Tallahassee
Posts: 73
is this caused by too much air? does anyone know what is a possible common fix for this or if my exhaust leak down stream or my exhaust manifold leak is a culprit?
cautiocones is offline   Quote Quick Reply
Old 07-17-2013, 11:27 PM   #11
Supporting Member

WF Supporting Member
 
wasomma's Avatar
 
Join Date: Aug 2010
Location: Baltimore, MD
Posts: 924
51 = A lean air/fuel mixture has been indicated by an abnormally rich correction factor.

Meaning your computer is thinking it needs to put more fuel into the engine that it actually needs to. This is caused by some problem in your exhaust fouling the O2 sensor. Could be the cracked exhaust manifold, holes in your exhaust line, bad O2 sensor, etc.

wasomma is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



logo carid shop wrangler parts carid fender flares custom wheels store avs deflectors at carid

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 01:05 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC