Couple questions? - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > CJ Jeep Forum > CJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 09-06-2013, 07:02 PM   #1
Jeeper
 
sean112280's Avatar
 
Join Date: Jan 2011
Location: JBLM, WA
Posts: 1,471
Couple questions?

I have a T-18 mated to a SBC. I just started getting a shimmy that feels like it's in either the trans or the front diff. Curious as to see if anyone else has had this happen before. Also what fluid is recommended for the trans and the diffs? My other question has to do with the clutch...what clutch could I use to replace mine in case that's my issue? I don't know if there has to be a specific model or what. Thanks for any information.

sean112280 is offline   Quote
Old 09-06-2013, 08:13 PM   #2
Moderator

::WF Moderator::
 
harleydragon's Avatar
 
Join Date: Jul 2012
Location: south georgia
Posts: 3,929
90 weight gear oil will work in everything..I would pull the clutch out to make sure and take it to the parts house if necessary but I would bet it is a chevy clutch and pressure plate in order for it to match the chevy flywheel..worn pilot bushing is one possibility of the little shimmy if I am interpreting shimmy correct or loose bell housing bolts

harleydragon is offline   Quote
Old 09-06-2013, 09:22 PM   #3
Jeeper
 
sean112280's Avatar
 
Join Date: Jan 2011
Location: JBLM, WA
Posts: 1,471
Quote:
Originally Posted by harleydragon View Post
90 weight gear oil will work in everything..I would pull the clutch out to make sure and take it to the parts house if necessary but I would bet it is a chevy clutch and pressure plate in order for it to match the chevy flywheel..worn pilot bushing is one possibility of the little shimmy if I am interpreting shimmy correct or loose bell housing bolts
Ok awesome. Thanks. I will check the bolts and see about the bushing.
sean112280 is offline   Quote
Old 09-07-2013, 06:19 AM   #4
Moderator

::WF Moderator::
 
harleydragon's Avatar
 
Join Date: Jul 2012
Location: south georgia
Posts: 3,929
Quote:
Originally Posted by sean112280 View Post
Ok awesome. Thanks. I will check the bolts and see about the bushing.
most people,when they change the clutch,replace the pilot bushing at that time
harleydragon is offline   Quote
Old 09-08-2013, 08:09 PM   #5
Jeeper
 
sean112280's Avatar
 
Join Date: Jan 2011
Location: JBLM, WA
Posts: 1,471
Oh ok. Thanks
sean112280 is offline   Quote
Old 09-13-2013, 05:43 PM   #6
Jeeper
 
sean112280's Avatar
 
Join Date: Jan 2011
Location: JBLM, WA
Posts: 1,471
So now there is a "clunk" noise when I let off the clutch and shift. It's like there is a delay in the shift too
sean112280 is offline   Quote
Old 09-14-2013, 04:35 PM   #7
Jeeper
 
sean112280's Avatar
 
Join Date: Jan 2011
Location: JBLM, WA
Posts: 1,471
Anyone have any ideas?
sean112280 is offline   Quote
Old 09-14-2013, 04:38 PM   #8
Moderator

::WF Moderator::
 
harleydragon's Avatar
 
Join Date: Jul 2012
Location: south georgia
Posts: 3,929
Quote:
Originally Posted by sean112280 View Post
Anyone have any ideas?
describe what it is doing a little better if you can and anything that you did just before it started this if anything
harleydragon is offline   Quote
Old 09-14-2013, 07:09 PM   #9
Jeeper
 
sean112280's Avatar
 
Join Date: Jan 2011
Location: JBLM, WA
Posts: 1,471
Quote:
Originally Posted by harleydragon View Post
describe what it is doing a little better if you can and anything that you did just before it started this if anything
Haven't done anything. Changed my coil to cap wire. Kind of hard to explain any further. Could it be anything with the clutch?
sean112280 is offline   Quote
Old 09-14-2013, 07:12 PM   #10
Moderator

::WF Moderator::
 
harleydragon's Avatar
 
Join Date: Jul 2012
Location: south georgia
Posts: 3,929
could be
harleydragon is offline   Quote
Old 09-24-2013, 10:29 AM   #11
Jeeper
 
sean112280's Avatar
 
Join Date: Jan 2011
Location: JBLM, WA
Posts: 1,471
Was a u joint in the rear driveshaft
sean112280 is offline   Quote
Old 09-24-2013, 11:09 AM   #12
Moderator

::WF Moderator::
 
harleydragon's Avatar
 
Join Date: Jul 2012
Location: south georgia
Posts: 3,929
cool,glad you got it fixed
harleydragon is offline   Quote
Old 09-24-2013, 04:00 PM   #13
Jeeper
 
sean112280's Avatar
 
Join Date: Jan 2011
Location: JBLM, WA
Posts: 1,471
Me too...lol. That u joint was just about to give out.

sean112280 is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 10:37 PM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC