Electronic point module failure....again - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > CJ Jeep Forum > CJ Tech Forum

Join Wrangler Forum Today



Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 01-14-2017, 12:47 AM
Thread Starter
  #1
Supporting Member

WF Supporting Member
 
Filthy's Avatar
 
Join Date: Jul 2016
Location: Surprise, Az
Posts: 48
Filthy is on a distinguished road
Electronic point module failure....again

I've got an Accel electronic point eliminator kit that I've replaced 4 times in the last year within only 100miles. Any of you guys have any general ideas on what could be causing the module to fail? I am using the coil and wire set Accel recommends with this module. I probably should lie but I cant, this is not for my jeep but for my 69 Bronco. I'm hoping you don't hold that against me
Filthy is offline   Quote
Old 01-14-2017, 08:58 AM   #2
Jeeper
 
Join Date: Feb 2012
Posts: 46
MILOJ is on a distinguished road
I have herd that if you leave the key on without the engine running for a while it will blow the unit I guess they are not fail safe

MILOJ is offline   Quote
Old 01-14-2017, 11:54 AM
Thread Starter
  #3
Supporting Member

WF Supporting Member
 
Filthy's Avatar
 
Join Date: Jul 2016
Location: Surprise, Az
Posts: 48
Filthy is on a distinguished road
Quote:
Originally Posted by MILOJ View Post
I have herd that if you leave the key on without the engine running for a while it will blow the unit I guess they are not fail safe
I think if I just look at it wrong it will blow.
I think this problem started around the time I bought my Jeep. I wonder if vehicles get jealous?
Filthy is offline   Quote
 
Old 01-14-2017, 01:04 PM
Thread Starter
  #4
Supporting Member

WF Supporting Member
 
Filthy's Avatar
 
Join Date: Jul 2016
Location: Surprise, Az
Posts: 48
Filthy is on a distinguished road
Quote:
Originally Posted by MILOJ View Post
I have herd that if you leave the key on without the engine running for a while it will blow the unit I guess they are not fail safe

Thanks MILOJ! That makes the most sense of anything I can think of. I use a remote starter switch/button. I turn the key to the on position and start it with the switch. I guess I end up leaving the ignition on for longer than usual while starting and sometimes I forget the ignition is even on. I wonder if I'm blowing the module.
Filthy is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off






All times are GMT -5. The time now is 01:43 AM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC
« Back

Enter your email address:

Delivered by FeedBurner