Heat - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > CJ Jeep Forum > CJ Tech Forum

Join Wrangler Forum Today



Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 04-14-2014, 12:42 PM   #1
Newb
 
DustinH's Avatar
 
Join Date: Feb 2014
Posts: 7
Heat

My 83 CJ7 has no heat at all. I can hear the blower running when on, but no air coming out of defrost. Where should I start?
DustinH is offline   Quote
Old 04-17-2014, 02:02 PM   #2
Jeeper
 
Quinnzeeskimo's Avatar
 
Join Date: Sep 2013
Location: Oshkosh WI
Posts: 213
I'd start by taking the dash off or sticking your head up behind it to see if everything is hooked up and the vent tubes are connected and don't have any holes in them. My CJ7 still has the problem.

Quinnzeeskimo is offline   Quote
Old 04-27-2014, 03:13 PM   #3
Newb
 
Join Date: Apr 2014
Posts: 4
has fan detached from motor. check piping from fan assembly to outlets.
keefy is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 05:51 PM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC