Help with 82 CJ 258 missfiring - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > CJ Jeep Forum > CJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 07-14-2007, 07:12 PM   #1
Newb
 
Join Date: Jul 2007
Posts: 3
Angry Help with 82 CJ 258 missfiring

I need help trouble shooting. I have an 82 CJ7, 4.2 (258).
Replaced the worn cam and put new lifters in about 8000 miles ago, and while I was at it replaced the timing chain. It has ran fine until yesterday, and it has started spitting and back firing thru the intake, badly!
I have checked the spark advance mechanism, working, checked for vacum leaks, none, put a rebuilt carb on it when I replaced the cam, never had a lick of trouble from it. It is alsost acting like it threw a tooth on the timing chain (or the cam went bad). I was told that a coil can go bad and cause these symptons also. Before I tear into it , I would like some suggestions. Thank You!

Big Gus is offline   Quote Quick Reply
Old 07-14-2007, 08:13 PM   #2
Jeeper
 
debruins's Avatar
 
Join Date: Feb 2007
Location: Needham Ma, Rangeley ME in the summer
Posts: 5,578
Send a message via AIM to debruins
a coil is easy to fix, buy a new one for like $40

i woould ask here though
www.earlycj5.com/forum/
they know their stuff

debruins is offline   Quote Quick Reply
Old 07-15-2007, 08:16 AM   #3
Newb
 
Join Date: Jul 2007
Posts: 3
Distributer cap, rotor??

Could a bad distributer cap or rotor cause a backfire thru the intake??
Just want to explore the cheaper options first.
Big Gus is offline   Quote Quick Reply
Old 07-15-2007, 09:52 AM   #4
Jeeper
 
debruins's Avatar
 
Join Date: Feb 2007
Location: Needham Ma, Rangeley ME in the summer
Posts: 5,578
Send a message via AIM to debruins
well a backfire through the intake is kinda of a common thing, you probably have a rich mix, i believe, but again i would ask over at ecj5.
Do this, pull your plugs, clean them real good, then replace them, run the engine for two minutes, through all RPM's. let the engine cool down, take out the plugs and look at them, if they have lots of ash your runnning rich, actually they really shouldnt have any ash on them

that will tell you if your running rich, then i owuld put a ai cleaner on it, b/c you shouldnt run an engine wihthout one, and i assume you dont have one b/c then you wouldnt even notice the backfire.

once again not an expert at these carb adjustment and timing adjustment things so i would ask at ecj5 forum
debruins is offline   Quote Quick Reply
Old 07-15-2007, 10:22 AM   #5
Newb
 
Join Date: Jul 2007
Posts: 3
No way it's a carburation issue. It is popping and spitting too much for that, almost like the cam has gone bad, or timing chain. I can't see this though, since it's only been 8000 miles since both were replaced.
It does idle smoothly, a little backfire, then when accelerating it reaaly starts to spit and pop back thru the intake and carb
Big Gus is offline   Quote Quick Reply
Old 07-15-2007, 10:54 AM   #6
Jeeper
 
debruins's Avatar
 
Join Date: Feb 2007
Location: Needham Ma, Rangeley ME in the summer
Posts: 5,578
Send a message via AIM to debruins
hmm cam problmes sounds plausible, if the vqalves arent shutting all the way, umm i have no idea wha to do about that

if u havent gotten the drift, ask here www.earlycj5.com/forums/
debruins is offline   Quote Quick Reply
Old 07-16-2007, 11:42 AM   #7
Jeeper
 
penguin_in_a_cj's Avatar
 
Join Date: Apr 2007
Location: eastern virginia
Posts: 366
something to think about is an hei upgrade for your jeep. you can put a diffrent distributor in with a cam gear out of something else I got to find the link somewhere in my pile of websites. I will put if up for you later. makes a big diffrence.
__________________
If at first you don't succeed...

Bomb defusal is probally not for you


tiny for president
penguin_in_a_cj is offline   Quote Quick Reply
Old 07-16-2007, 11:44 AM   #8
Jeeper
 
penguin_in_a_cj's Avatar
 
Join Date: Apr 2007
Location: eastern virginia
Posts: 366
sorry I forgot to put the main thought into that make sure your distributor is not worn out. sounds like the problem I had with mine. if it is youll have play alot of it

__________________
If at first you don't succeed...

Bomb defusal is probally not for you


tiny for president
penguin_in_a_cj is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



logo carid shop wrangler parts carid fender flares custom wheels store avs deflectors at carid
» Rates
Get low rates on auto insurance in Canada!

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 02:39 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC