09 jk acceleration issues.. PLEASE HELP! - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 12-11-2012, 07:18 PM   #1
Newb
 
Join Date: Dec 2012
Posts: 7
09 jk acceleration issues.. PLEASE HELP!

Ok, so I have an 09 jk, 47k miles, brought it mudding for the first time a couple weeks ago. Not 100% sure the issue started at the same time but pretty close.

The problem only happens when I'm accelerating from a stop. When I give it gas it vibrates and very slowly accelerates, but if I let off the gas and then press it again, it's fine...

I've only had my jeep a couple months, kinda new to this...

Thanks in advance for any help

Bostonsbetter is offline   Quote Quick Reply
Old 12-11-2012, 08:32 PM   #2
Moderator

WF Supporting Member
::WF Moderator::
 
jkjeeper06's Avatar
 
Join Date: Jul 2010
Posts: 3,428
Auto or manual? Could be water or dirt in the transmission. You could always park over a sprinkler. I do that and it works pretty well at cleaning off the underside

jkjeeper06 is offline   Quote Quick Reply
Old 12-12-2012, 05:00 AM   #3
Newb
 
Join Date: Dec 2012
Posts: 7
Quote:
Originally Posted by jkjeeper06 View Post
Auto or manual? Could be water or dirt in the transmission. You could always park over a sprinkler. I do that and it works pretty well at cleaning off the underside
It's auto.. I went through a touch less car wash that sort of briefly sprays your under carriage with very high pressure water..
Bostonsbetter is offline   Quote Quick Reply
Old 12-12-2012, 05:07 AM   #4
Member
 
Join Date: Sep 2010
Location: Kearneysville, WV
Posts: 3,574
Quote:
Originally Posted by Bostonsbetter View Post
It's auto.. I went through a touch less car wash that sort of briefly sprays your under carriage with very high pressure water..
Sounds like the pressure washer either caused the issue. Maybe the PCM got wet or an O2 Sensor got wet. How long ago did you go through the pressure washer?
Con Artist is offline   Quote Quick Reply
Old 12-12-2012, 07:51 AM   #5
Newb
 
Join Date: Dec 2012
Posts: 7
Quote:
Originally Posted by Con Artist

Sounds like the pressure washer either caused the issue. Maybe the PCM got wet or an O2 Sensor got wet. How long ago did you go through the pressure washer?
Probably about 2 weeks ago around the time it started.. Any idea if it should dry itself out?
Bostonsbetter is offline   Quote Quick Reply
Old 12-12-2012, 09:05 AM   #6
MARGARET, 10-14-51\6-1-12

WF Supporting Member
 
GREEN-MACHINE's Avatar
 
Join Date: Aug 2010
Location: PEOPLES REPUBLIC OF MASSACHUSETTS
Posts: 10,250
if you went mudding, i would first check the air cleaner assembly and filter for clogs.
__________________

life is too short to be taken seriously all the time,,,, go buy a MR.potato head and have some fun.
GREEN-MACHINE is offline   Quote Quick Reply
Old 12-12-2012, 10:09 AM   #7
Member
 
Join Date: Sep 2010
Location: Kearneysville, WV
Posts: 3,574
Quote:
Originally Posted by Bostonsbetter View Post
Probably about 2 weeks ago around the time it started.. Any idea if it should dry itself out?
If it happened two weeks ago, whatever it is should have already dried out unless you actually got water up in the bungs where the O2 sensors are located, if that would be the problem.

Quote:
Originally Posted by GREEN-MACHINE View Post
if you went mudding, i would first check the air cleaner assembly and filter for clogs.
As good a suggestion as any. I'd definitely do this, too.
Con Artist is offline   Quote Quick Reply
Old 12-12-2012, 01:03 PM   #8
Jeeper
 
Baby Huey's Avatar
 
Join Date: Feb 2012
Location: Western Washington County Oregon
Posts: 1,062
If it's an 09..... It could be a bad or sticking or gummy PCV valve.... Check your oil, are you loosing any ? a lot of 3.8L use lots of oil....could be a cause.

Also try Cleaning and Lubricating your Mass Air Flow Butterfly...There is special spray lubes for this at auto parts stores...

Just a couple ideas.... "BH"

__________________
07-JKU-X /Poison spider Evap.Skid/Master craft grab handles/Or-Fab spare tire-can carrier/ Gibson SS Duals/ Q-tec Floor Liners/Hidden Hitch Receiver/ AntennaX 7inch/ 48" Hi-Lift./ 8"X16"X4"bs Steel smoothie wheels/ 265X75R-16 Kelly Safari TSR tarz.

Viet Nam Veteran 69-70, Troop "D" (AIR) 3/4 Cav. ,25th Inf. Div. CUCHI RVN. UH-1H Crew Chief of the "Pinball Wizard" 68-16224. Call Sign "CENTAUR".
Baby Huey is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 09:37 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC