13' 3600 miles auto still shifting weird - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 08-21-2013, 08:36 PM   #1
Jeeper
 
Join Date: Apr 2013
Location: Central Ca
Posts: 514
13' 3600 miles auto still shifting weird

I even reprogrammed with the AEV for the aftermarket rubi wheels but it still holds second and what seems like hits a wall at 2300 rpm for a few seconds. I have to hit the gas for it to jump but then it thinks i want to haul a$$. Just no smoothness about it. Even first gear climbs to 3k from a soft take off.

I noticed it has a program for 3.73 gears but it says if your jeep came from the factory that way it is not needed. My question is should i go ahead and try reprogramming for 3.73 gears? Could it be possible the factory forgot since it was an add on?

lando76 is offline   Quote Quick Reply
Old 08-22-2013, 10:42 AM   #2
Jeeper
 
Join Date: Apr 2013
Location: Central Ca
Posts: 514
So let me ask this another way. Is my jeep still in learning mode?

lando76 is offline   Quote Quick Reply
Old 08-22-2013, 12:39 PM   #3
Jeeper
 
mental1's Avatar
 
Join Date: Aug 2013
Location: Iowa
Posts: 18
Quote:
Originally Posted by lando76 View Post
So let me ask this another way. Is my jeep still in learning mode?
My jeep jk has 11k miles on it is a 2013, and when going at slow speeds won't engage second gear, rpm's upto 5-6000. And hesitates from a soft start. Dealer has had it for a week. Can't figure it out. So your not alone. But sorry I have no answers.
mental1 is offline   Quote Quick Reply
Old 08-22-2013, 12:45 PM   #4
Jeeper
 
Join Date: Feb 2013
Posts: 1,921
There have been reports on here of '13 autos having issues with second gear. I believe some transmissions have been replaced, and some valve bodies. I personally have the second gear 'wall' with my '13, at 5k miles. It revs up and up before second gear 'catches'. I still drive it since the dealer won't do anything until its ready to blow up.

EDIT: I also have 3.73, but I don't think its a programming issue. It shifted crisply when I first bought it.

Do you have bigger tires by chance? I do.
__________________
2013 Commando Green Freedom Edition JKU
2013 Billet Freedom Edition JK
legitposter is offline   Quote Quick Reply
Old 08-23-2013, 10:27 AM   #5
Jeeper
 
mental1's Avatar
 
Join Date: Aug 2013
Location: Iowa
Posts: 18
The dealership just told me The main module that controls all the other modules in my JK is bad and they're replacing it w/a new one and they think that's what's going to fix my problem
mental1 is offline   Quote Quick Reply
Old 08-23-2013, 11:13 AM   #6
Jeeper
 
Tweak's Avatar
 
Join Date: Jan 2013
Location: Keller, TX
Posts: 2,382
Quote:
Originally Posted by lando76 View Post
I even reprogrammed with the AEV for the aftermarket rubi wheels but it still holds second and what seems like hits a wall at 2300 rpm for a few seconds. I have to hit the gas for it to jump but then it thinks i want to haul a$$. Just no smoothness about it. Even first gear climbs to 3k from a soft take off.

I noticed it has a program for 3.73 gears but it says if your jeep came from the factory that way it is not needed. My question is should i go ahead and try reprogramming for 3.73 gears? Could it be possible the factory forgot since it was an add on?
if you have 3.73 gears reprogram it for 3.73 gears. mine came from the factory with 3.73 gears programed for 3.21's.
Tweak is online now   Quote Quick Reply
Old 08-24-2013, 01:51 PM   #7
Jeeper
 
Join Date: Apr 2013
Location: Central Ca
Posts: 514
I did buy the 13 stock rubi wheels but I calibrated accordingly for those. Thanks Tweak I will go ahead and try that tonight. Can't hurt anything. Mental1 this is concerning and how do I go about getting this looked at. What was the tale tale sign. Is it what I described or was yours just not shifting to second at all until 4 or 5k rpm.
lando76 is offline   Quote Quick Reply
Old 08-25-2013, 10:19 PM   #8
Jeeper
 
Join Date: Apr 2013
Location: Central Ca
Posts: 514
Heres an update. After trying what Tweak recommended it seems as if the jeep shifts alot smoother and faster now. Theres no hunting or mixing of gears and lull in rpms. I am at a loss as to how this happened. I suspect there will be more like myself.
lando76 is offline   Quote Quick Reply
Old 08-26-2013, 09:56 AM   #9
Jeeper
 
mental1's Avatar
 
Join Date: Aug 2013
Location: Iowa
Posts: 18
Quote:
Originally Posted by lando76 View Post
I did buy the 13 stock rubi wheels but I calibrated accordingly for those. Thanks Tweak I will go ahead and try that tonight. Can't hurt anything. Mental1 this is concerning and how do I go about getting this looked at. What was the tale tale sign. Is it what I described or was yours just not shifting to second at all until 4 or 5k rpm.
Mine was just engaging second gear at all. It happened one day about 4x, rpm's went as high 5-6k. But check engine light came on, with codes registering. Dealer had to put in a call to the jeep line to figure it out. I had other minor issues, rear drivers side window would work intermittently also, hesitation like it was gonna stall on occasion. But perhaps after reading your last post we had different issues.
mental1 is offline   Quote Quick Reply
Old 08-26-2013, 10:39 PM   #10
Jeeper
 
Join Date: Apr 2013
Location: Central Ca
Posts: 514
Yea definately two different issues. Glad its fixed. I just turned 4k miles so maybe the learning mode shut off or maybe it was the procal for 3.73. Either way its alot better.
lando76 is offline   Quote Quick Reply
Old 08-26-2013, 10:54 PM   #11
Jeeper
 
domr's Avatar
 
Join Date: Oct 2011
Location: San Diego, CA
Posts: 76
Quote:
Originally Posted by Tweak View Post

if you have 3.73 gears reprogram it for 3.73 gears. mine came from the factory with 3.73 gears programed for 3.21's.
Could you elaborate on this? How did you determine it was programmed for 3.21 gears? Thanks.
domr is offline   Quote Quick Reply
Old 08-27-2013, 01:22 PM   #12
Jeeper
 
Join Date: Aug 2013
Posts: 18
I've had some weird instances with the rpms and shifting while in cruise control and going uphill. Almost to the point where it would redline instead of shift on the automatic. Could this be related to what you guys are talking about? Thanks
szekler is offline   Quote Quick Reply
Old 08-27-2013, 10:28 PM   #13
Jeeper
 
Join Date: Feb 2013
Posts: 1,921
Tweak, how did you know your 3.73 factory was programmed for 3.21? Does the tuner tell you this or something?
__________________
2013 Commando Green Freedom Edition JKU
2013 Billet Freedom Edition JK
legitposter is offline   Quote Quick Reply
Old 08-29-2013, 08:47 AM   #14
Jeeper
 
mental1's Avatar
 
Join Date: Aug 2013
Location: Iowa
Posts: 18
Quote:
Originally Posted by szekler View Post
I've had some weird instances with the rpms and shifting while in cruise control and going uphill. Almost to the point where it would redline instead of shift on the automatic. Could this be related to what you guys are talking about? Thanks
Yes that's exactly what was happening with mine but I was only going 15 miles an hour on flat ground. Plus a few other weird electrical issues.
mental1 is offline   Quote Quick Reply
Old 08-30-2013, 12:15 AM   #15
Jeeper
 
Join Date: Apr 2013
Location: Central Ca
Posts: 514
To me you can just feel it. The rpms climb but hardly any torque. I found in basic hlls my auto had no clue what to do or what gear it wanted. I had to coherce it into a lower gear by mashing the pedal. Second gear off a soft take off would stall out at 2400 rpm for about two seconds before it decided to shift into third.

I figured it couldnt hurt anything knowing the gears were on the build sheet.
lando76 is offline   Quote Quick Reply
Old 08-30-2013, 12:31 PM   #16
Jeeper
 
Tweak's Avatar
 
Join Date: Jan 2013
Location: Keller, TX
Posts: 2,382
Quote:
Originally Posted by domr View Post

Could you elaborate on this? How did you determine it was programmed for 3.21 gears? Thanks.
My programmer read "stock" for gears, which I would assume is 3.21. Changing that to 3.73 was night and day difference. Helped with shifting and made my mpg gauge accurate.

Tweak is online now   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




» Featured Product

All times are GMT -5. The time now is 11:06 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC