2010 Whistle Starting at 2000rpm going away at 1000rpm? - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 08-23-2011, 02:02 PM   #1
Newb
 
Join Date: Mar 2011
Posts: 7
2010 Whistle Starting at 2000rpm going away at 1000rpm?

I have a 2010 unlimited with 9800 miles that just started whistling under load at 2000rmp and over. The whistle goes away at 1000rpm's. Under load meaning going up a steep hill. Took it to the dealership and they cant duplicate the problem. I took a video of it so they went to work to try to find the problem. They did find a loose intake hose but that did not fix it. Sounds like a vacuum leak. It doesn't do it all of the time. Seems to do it after driving it for a while and then go up a steep hill. Here is the video i took of it. Let me know if you guys have any ideas? Thanks for your input!
IMG_0859.mp4 video by carrunphoto - Photobucket

2010jkun is offline   Quote Quick Reply
Old 08-25-2011, 02:34 PM   #2
Newb
 
Join Date: Mar 2011
Posts: 7
Any ideas??

2010jkun is offline   Quote Quick Reply
Old 08-25-2011, 02:41 PM   #3
Jeeper
 
Clutch127's Avatar
 
Join Date: Sep 2010
Location: Raleigh, NC
Posts: 427
I have the same problem except mine is more of a fast clicking sound and it does it in the exact situation that yours does. Also took it to the dealer and they couldn't hear it, but i can hear it with the radio on. I have no idea.
__________________
Keep on rockin in the Jeep world!
Clutch127 is offline   Quote Quick Reply
Old 08-27-2011, 08:22 PM   #4
Newb
 
Join Date: Aug 2011
Posts: 1
Quote:
Originally Posted by 2010jkun View Post
I have a 2010 unlimited with 9800 miles that just started whistling under load at 2000rmp and over. The whistle goes away at 1000rpm's. Under load meaning going up a steep hill. Took it to the dealership and they cant duplicate the problem. I took a video of it so they went to work to try to find the problem. They did find a loose intake hose but that did not fix it. Sounds like a vacuum leak. It doesn't do it all of the time. Seems to do it after driving it for a while and then go up a steep hill. Here is the video i took of it. Let me know if you guys have any ideas? Thanks for your input!
IMG_0859.mp4 video by carrunphoto - Photobucket

My 2010 jk also did that,untill i noticed to stock air box cover ,had 1 latch open.locked it no more whistling
DAAM421 is offline   Quote Quick Reply
Old 09-05-2011, 07:34 PM   #5
Jeeper
 
Crainbox's Avatar
 
Join Date: Aug 2011
Posts: 40
__________________
Jeep Wrangler 2012
Crainbox is offline   Quote Quick Reply
Old 05-08-2013, 08:29 AM   #6
Newb
 
Join Date: Sep 2011
Posts: 9
Quote:
Originally Posted by 2010jkun View Post
I have a 2010 unlimited with 9800 miles that just started whistling under load at 2000rmp and over. The whistle goes away at 1000rpm's. Under load meaning going up a steep hill.
Did you ever solve this problem? My 2007 JK has 50K miles on it and just started doing this.

Captbrando is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2010 Wrangler Unlimited starting problems dandepatie JK General Discussion Forum 2 03-21-2011 11:07 PM
Trouble with stalling/difficult starting... CSmith1128 TJ Tech Forum 1 04-22-2010 10:57 PM
Chryseler Announces Prices for 2010 Geoff@Bestop Off-Topic 13 08-20-2009 11:10 PM



» Featured Product

All times are GMT -5. The time now is 08:07 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC