2012 Hot Oil Light Limp Mode - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 05-13-2012, 09:26 PM   #1
Newb
 
Join Date: May 2012
Posts: 5
2012 Hot Oil Light Limp Mode

Hey guys,

Drove my 2012 1/4 mile saturday from a cold start in 80 degree weather. Hot oil light comes on and jeep goes into limp mode...Called dealer they had me drive it in. Right around the corner...Jeep has 2000 miles on it. Never had it off roading yet...totally stock...wondering if anyone else has had this problem yet? hopefully dealer finds something tomorrow..it has been sitting since sat evening so i hope the light may come on again...if not i am assuming they are just going to send me on my way...thanks for any info on this problem...
Attached Thumbnails
Click image for larger version

Name:	Screen Shot 2012-05-13 at 10.02.28 PM.jpg
Views:	154
Size:	133.5 KB
ID:	122478  

mbutler82 is offline   Quote
Old 05-13-2012, 09:34 PM   #2
Jeeper
 
joe002's Avatar
 
Join Date: Nov 2010
Location: Phoenix, AZ
Posts: 1,185
Doesn't look right at all - especially for a 2012 with the added cooler. If the transmission is really getting that hot in your situation then it sure sounds like a defect in the transmission/torque converter.

You do have the pic to show the service guys if they don't see anything in the computer.

__________________
2008 Rubicon, 2 Door, Flame Red, Auto, MyGIG, Power Group, Deep Tint
AEV Pintlers, BFG KM2s 35x12.50x17, Bulldog Fab Rear Stubby Bump, Currie F/R Adj Trac Bars, Daystar Upper Dash, FireStik FireFly Antenna, Kilby Rear Shock Skids, LoD Sig Stubby Front Bump, Midland 75-822 CB, Mopar Filler Door & Locking Gas Cap, Rancho LCA Skid, Rancho Oil Pan Armor, Riddler Diff Covers, TeraFlex 2.5" Spring Lift, Warn PowerPlant HD, Woods Evap Can Relo, Woods SS Relo, Yukon 5.38s
joe002 is offline   Quote
Old 05-13-2012, 09:41 PM   #3
Newb
 
Join Date: May 2012
Posts: 5
Cant image the transmission getting that hot in that short amount of time though. Thats whats got me wondering...
mbutler82 is offline   Quote
Old 05-13-2012, 09:48 PM   #4
Jeeper
 
joe002's Avatar
 
Join Date: Nov 2010
Location: Phoenix, AZ
Posts: 1,185
Quote:
Originally Posted by mbutler82 View Post
Cant image the transmission getting that hot in that short amount of time though. Thats whats got me wondering...
If you only drove it 1/4 mile on the road and it got that hot there has to be a defect in the transmission/torque converter, lack of oil, or maybe it really isn't that hot and it's just a bad sensor/computer thing. I donít think you could even get a pre-2012 to get Hot Oil in only a 1/4 mile from a 80 degree starting temp.
__________________
2008 Rubicon, 2 Door, Flame Red, Auto, MyGIG, Power Group, Deep Tint
AEV Pintlers, BFG KM2s 35x12.50x17, Bulldog Fab Rear Stubby Bump, Currie F/R Adj Trac Bars, Daystar Upper Dash, FireStik FireFly Antenna, Kilby Rear Shock Skids, LoD Sig Stubby Front Bump, Midland 75-822 CB, Mopar Filler Door & Locking Gas Cap, Rancho LCA Skid, Rancho Oil Pan Armor, Riddler Diff Covers, TeraFlex 2.5" Spring Lift, Warn PowerPlant HD, Woods Evap Can Relo, Woods SS Relo, Yukon 5.38s
joe002 is offline   Quote
Old 05-14-2012, 05:30 AM   #5
Newb
 
Join Date: May 2012
Posts: 5
Scanned the jeep this morning. Receive code u0101 could not establish link with TCM. Still had the hot oil light. After it sat all weekend. Sounds like it might be a an electrical problem. Let's see what the dealership says today.
mbutler82 is offline   Quote
Old 05-14-2012, 09:15 AM   #6
Supporting Member

WF Supporting Member
 
Daniel_M's Avatar
 
Join Date: Nov 2011
Location: Arizoner
Posts: 2,420
Could be. Do the 2012 have a transmission cooler stock? I though they did...

-Dan
Daniel_M is offline   Quote
Old 05-14-2012, 09:18 AM   #7
Jeeper
 
joe002's Avatar
 
Join Date: Nov 2010
Location: Phoenix, AZ
Posts: 1,185
Quote:
Originally Posted by mbutler82 View Post
Scanned the jeep this morning. Receive code u0101 could not establish link with TCM. Still had the hot oil light. After it sat all weekend. Sounds like it might be a an electrical problem. Let's see what the dealership says today.
Yeah, it sure isn't hot from just sitting there. At least you don't have to worry about your transmission all burnt up inside.
__________________
2008 Rubicon, 2 Door, Flame Red, Auto, MyGIG, Power Group, Deep Tint
AEV Pintlers, BFG KM2s 35x12.50x17, Bulldog Fab Rear Stubby Bump, Currie F/R Adj Trac Bars, Daystar Upper Dash, FireStik FireFly Antenna, Kilby Rear Shock Skids, LoD Sig Stubby Front Bump, Midland 75-822 CB, Mopar Filler Door & Locking Gas Cap, Rancho LCA Skid, Rancho Oil Pan Armor, Riddler Diff Covers, TeraFlex 2.5" Spring Lift, Warn PowerPlant HD, Woods Evap Can Relo, Woods SS Relo, Yukon 5.38s
joe002 is offline   Quote
Old 05-14-2012, 09:22 AM   #8
Jeeper
 
MarineHawk's Avatar
 
Join Date: Dec 2011
Location: Virginia
Posts: 700
Quote:
Originally Posted by Daniel_M View Post
Could be. Do the 2012 have a transmission cooler stock? I though they did...

-Dan
They do.
MarineHawk is offline   Quote
Old 05-14-2012, 04:11 PM   #9
Newb
 
Join Date: May 2012
Posts: 5
Went to dealer today and they told me it was a bad TCM. Part will be in tomorrow. Let's see what happens. 2000 miles an stuff is breaking already. Testing my confidence in the jk.
mbutler82 is offline   Quote
Old 05-19-2012, 11:39 AM   #10
Newb
 
Join Date: May 2012
Posts: 5
It ended up being the tcm that was bad. No damage to trans, just false indicator. Best case scenario I guess. Thanks for the help.
mbutler82 is offline   Quote
Old 05-19-2012, 12:22 PM   #11
Jeeper
 
joe002's Avatar
 
Join Date: Nov 2010
Location: Phoenix, AZ
Posts: 1,185
Quote:
Originally Posted by mbutler82 View Post
It ended up being the tcm that was bad. No damage to trans, just false indicator. Best case scenario I guess. Thanks for the help.
Cool, glad it was just an electrical gremlin!

__________________
2008 Rubicon, 2 Door, Flame Red, Auto, MyGIG, Power Group, Deep Tint
AEV Pintlers, BFG KM2s 35x12.50x17, Bulldog Fab Rear Stubby Bump, Currie F/R Adj Trac Bars, Daystar Upper Dash, FireStik FireFly Antenna, Kilby Rear Shock Skids, LoD Sig Stubby Front Bump, Midland 75-822 CB, Mopar Filler Door & Locking Gas Cap, Rancho LCA Skid, Rancho Oil Pan Armor, Riddler Diff Covers, TeraFlex 2.5" Spring Lift, Warn PowerPlant HD, Woods Evap Can Relo, Woods SS Relo, Yukon 5.38s
joe002 is offline   Quote
Reply

Tags
2012 , hot oil , limp mode

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 03:38 AM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeepģ, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC