2012 JKU Belt Squeal - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 05-31-2013, 07:03 PM   #1
Jeeper
 
chrisfp88's Avatar
 
Join Date: Jun 2012
Posts: 1,309
2012 JKU Belt Squeal

My 2012 JKU has what I think is belt related squeal from a tensioner being loose or bad. I'm having a hard time finding a picture so I can identify the location of the tensioners. I dropped it off at service ten days ago. The service manager even heard the noise over the telephone, but Murphy's Law hates me and of course it didn't make the noise once it got there. They changed the coolant per Chrysler, which I am pretty sure is unrelated. It's not making the noise consistently now, but I thought I heard it start earlier. I just recieved it back today. I'm thinking they just put conditioner on the belt and sent me on my way. I guess time will tell. Anyone else have this issue?

chrisfp88 is offline   Quote
Old 05-31-2013, 08:04 PM   #2
THW
Jeeper
 
THW's Avatar
 
Join Date: Jun 2012
Location: Litchfield Hills area, Connecticut
Posts: 780
I had what sounded like a belt squeal turn out to be the water pump. Maybe that's why they flushed your coolant...

__________________
2013 Sport S Unlimited, Black
THW is offline   Quote
Old 06-01-2013, 02:44 PM   #3
Jeeper
 
chrisfp88's Avatar
 
Join Date: Jun 2012
Posts: 1,309
Bump
chrisfp88 is offline   Quote
Old 06-25-2013, 12:21 AM   #4
Newb
 
JKUenvy's Avatar
 
Join Date: Jun 2012
Posts: 10
Quote:
Originally Posted by chrisfp88 View Post
Bump
http://www.wranglerforum.com/f33/chi...gs-192439.html
JKUenvy is offline   Quote
Old 06-25-2013, 07:40 AM   #5
Jeeper
 
Gort's Avatar
 
Join Date: Aug 2012
Location: Central PA
Posts: 318
The front driver's side belt on my 2012 sometimes squeals/grinds/chatters (sort of a combo sound) when I extend it. Typically only happens when it's been sitting in the sun for while. I figured it was poor lubrication on the tensioner.

And no, it's not the water pump -- unless the water pump pumps coolant without the key in the ignition or the engine running.

I was planning on complaining about it when I take it to the dealer the next time to have some other warranty work done.
Gort is offline   Quote
Old 06-25-2013, 09:35 AM   #6
Jeeper
 
chrisfp88's Avatar
 
Join Date: Jun 2012
Posts: 1,309
According them mine is water pump. Its scheduled to be replaced thursday
chrisfp88 is offline   Quote
Old 06-25-2013, 09:47 AM   #7
Jeeper
 
Tom009's Avatar
 
Join Date: Feb 2012
Posts: 52
The water pump is on back order all over the place. That means they use alot of water pumps.

Tom009 is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 10:08 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC