2012 Radio- To much bass - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 03-03-2013, 10:29 PM   #1
Jeeper
 
Join Date: Aug 2012
Posts: 18
2012 Radio- To much bass

I have searched and cannot find someone that has identified this problem. My radio in the 2012 JK is the cheapest model, no sub, just bare bones. I have replaced everything but the head unit, I have the stock head with 4 Polk audio. Speakers and one alpine X sub.

I know that it is a strong sub but something is not Right. This sound is booming, it will even boom on voices like Howard stern or HLN news. I have never had a radio act like this, gain is down to zero, head unit bass is down to zero. I am convinced it is the head unit, maybe it is because we used line in's since there are no RCA,s. This happens on both Sirius and radio. The radio audio also has turned off before for days and then will come back on.

I wonder what the dealer would do with a bad head unit but all my after market stuff.

Crushed2012 is offline   Quote Quick Reply
Old 03-04-2013, 08:39 AM   #2
Jeeper
 
Trenty's Avatar
 
Join Date: Nov 2012
Location: New York City
Posts: 86
I kept my stock head unit as well and I'm paying for it now. The unit cannot properly regulate aftermarket subs apparently because it causes my subs protection to shoot on and cut off power to the sub whenever I raise the bass to a decent level. Now I have twin 12s sitting in the trunk barely on because of it. Took it to multiple sound shops, replaced the sub thinking it was the cause, and still it happens. The last shop I took it to said he read this head unit will send abnormally high voltages and mess up the bass. Idk if that was BS or not but sounded plausible. .

Trenty is offline   Quote Quick Reply
Old 03-04-2013, 09:26 PM   #3
Jeeper
 
Join Date: Aug 2012
Posts: 18
Thats what I was afraid to be the case. When my 12 inch sub is rattling the windows with talk radio I knew something was wrong. God- all I wanted from this piece of crap is the signal and it can't do that. I will need to find a radio that is Sirius and that is about it. I have everything locked down so I don't want a aftermarket radio in the dash. Maybe a removable face plate. This radio has also cut off about 5 minutes into a 3 hour drive so it is time to go aftermarket.
Crushed2012 is offline   Quote Quick Reply
Old 03-04-2013, 11:42 PM   #4
Jeeper
 
st1264's Avatar
 
Join Date: Mar 2013
Location: Windsor, ON (near Detroit)
Posts: 1,252
What amplifier are you guys using?
st1264 is offline   Quote Quick Reply
Old 03-06-2013, 08:02 AM   #5
Jeeper
 
Join Date: Aug 2012
Posts: 18
2 brand new amps by Alpine, no rca's on stock head unit so we are doing line in's. Gain is zero.
Crushed2012 is offline   Quote Quick Reply
Old 03-06-2013, 12:23 PM   #6
Jeeper
 
Join Date: Sep 2012
Posts: 23
Stock HU is most likely the culprit. The frequencies are altered to perform with the crappy stock speakers. If you are dead seat against a new HU, you can go with a signal processor to fix the frequencies, but it will cost as much as a new HU. BTW, I went with the JVC Kw-AV64bt. Double din with detachable face plate--since security is definitely a concern when riding doorless/topless. Hope this helps.
micahnormal is offline   Quote Quick Reply
Old 03-06-2013, 12:28 PM   #7
Jeeper
 
Join Date: Dec 2012
Location: Bakersfield, CA
Posts: 96
Get a 1/8" mini (headphone jack) to RCA converter and go directly from your phone/mp3 player into the amp and see if that makes a difference. Just a troubleshooting step, I'm not suggesting permanently running that way. Just make sure to start with your volume all the way down on the device and then work your way up.
ccoston is offline   Quote Quick Reply
Old 04-11-2013, 08:20 PM   #8
Jeeper
 
Join Date: Aug 2012
Posts: 18
Found it! It was a bad fuse holder on the battery. go figure, I replaced about everything to find it but at least my system looks good and the head and EQ are cheap but great.
Crushed2012 is offline   Quote Quick Reply
Old 04-11-2013, 08:21 PM   #9
Jeeper
 
Join Date: Aug 2012
Posts: 18

Crushed2012 is offline   Quote Quick Reply
Reply

Tags
130 stereo , bass , booming , radio

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 11:21 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC