2012 speaker fuses! - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 03-15-2012, 09:52 AM   #1
Jeeper
 
fishmd's Avatar
 
Join Date: Dec 2011
Location: South Florida
Posts: 334
Help me out here guys. I am in a bind. I think I blew a fuse for one of the speakers and don't know where the fuses are for the speakers.

fishmd is offline   Quote Quick Reply
Old 03-15-2012, 09:58 AM   #2
Jeeper
 
pasteris71's Avatar
 
Join Date: Feb 2011
Location: Hampden, MA.
Posts: 497
I didn't think the speakers had a fuse. I know the radio has a fuse. Are the speakers just not working?

pasteris71 is offline   Quote Quick Reply
Old 03-15-2012, 10:01 AM   #3
Jeeper
 
Join Date: Oct 2011
Location: Camden, AR
Posts: 445
Sounds more like you blew a voice coil. I have never heard of factory systems having fused speakers. And,a ctually, only heard of one aftermarket system having fused speakers and it was for a SQ competition vehicle. Not exactly sure what good it would do.

Either way, sounds like a good time to upgrade to aftermarket speakers.
rivershark2005 is offline   Quote Quick Reply
Old 03-15-2012, 10:09 AM   #4
Jeeper
 
fishmd's Avatar
 
Join Date: Dec 2011
Location: South Florida
Posts: 334
No, definitely didn't blow a coil. Checked ten out. I am getting no sound output to it though. I didn't know if there was another location for fuses that I was missing is all. Front speakers are fine, just not getting the rear to work...
fishmd is offline   Quote Quick Reply
Old 03-15-2012, 10:25 AM   #5
Jeeper
 
4fit's Avatar
 
Join Date: Dec 2010
Location: Graham, NC
Posts: 2,304
Like said, the speakers shouldn't be fused. Wonder if the fader control went out on the radio?
__________________
-Jeff-
'11 JKU Sport - TF Leveling Kit - 16" Strike 5s on 33s
4fit is offline   Quote Quick Reply
Old 03-15-2012, 11:11 AM   #6
Jeeper
 
fishmd's Avatar
 
Join Date: Dec 2011
Location: South Florida
Posts: 334
Ah...I am stupid, but not totally. Realized one of the wire colors for the sub is the same is one of the wire colors for the right rear speaker. Once I got that straightened out it is all good.

I think you all are right though, there are no fuses for the speakers. I just couldn't figure out any other reason for it at first.

fishmd is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2012 JKU 3.6 Block Heater question redrockman JK General Discussion Forum 21 11-06-2012 01:37 PM
•••HELP••• Problems with my 12 day old 2012 JKU Rubicon Mastersonics JK General Discussion Forum 72 06-28-2012 08:37 PM
First TJ topless pics of 2012!!! JeepinDave TJ General Discussion Forum 204 04-09-2012 11:28 AM
2012 Rubi meghanca WF New Member Check In 16 04-04-2012 02:39 PM
5 mile, Sun. March 18 2012 Justanothermoparman Utah Jeep Forum 0 03-15-2012 12:53 AM



» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 12:07 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC