2012 wipers turn on automatically - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 02-05-2012, 07:27 PM   #1
Jeeper
 
cozmo2312's Avatar
 
Join Date: Dec 2011
Location: Utah
Posts: 78
2012 wipers turn on automatically

so my gf's 2012's windshield wipers have been going off when you use the turn signals, which is weird because the stalks are on either side of the wheel.

turn on the signal, wipers make one pass.

i didn't believe her until today when i was driving and it did it to me everytime i used the signals.

if that isn't bad enough, they now started going off without having touched anything, just driving down the road and they make a few passes.

anyone else have this issue?

__________________
2011 Jeep Rubicon His
2012 jeep sport Hers
cozmo2312 is offline   Quote Quick Reply
Old 02-05-2012, 07:32 PM   #2
Jeeper
 
PA . JAY's Avatar
 
Join Date: Jan 2012
Location: GREENSBURG PA.
Posts: 146
nope thats a new one to me . I dont think their even on the same fuse are they ?

PA . JAY is offline   Quote Quick Reply
Old 02-05-2012, 07:35 PM   #3
Jeeper
 
j.luis's Avatar
 
Join Date: May 2011
Location: Mercedes
Posts: 651
get the battery checked...
don't asked, but what I have read here many weird electrical problems are due to a bad battery.
__________________
2012 Jeep Rubicon Unlimited 3.6L V6 24V VVT Engine, 5sp Auto Trans.
Connectivity Group, Max Tow, Hard Top(Black), 4:10 gears... Bright White Clear Coat.
j.luis is offline   Quote Quick Reply
Old 02-05-2012, 07:45 PM   #4
Jeeper
 
Join Date: Dec 2011
Location: Ozarks
Posts: 29
Either its haunted or you need to take it to the dealer. Odd cross connections can be dangerous. Then so can being haunted
Elslys is offline   Quote Quick Reply
Old 02-07-2012, 04:26 AM   #5
Newb
 
Join Date: Feb 2012
Posts: 2
I've had the same problem with my Jeep. Found any solution??
adisi is offline   Quote Quick Reply
Old 02-07-2012, 06:07 AM   #6
Jeeper
 
Sgt.slaughter's Avatar
 
Join Date: Sep 2011
Location: New York State
Posts: 278
I know this sounds like I'm being a smart ass but was it raining or sprinkling? The reason I ask is my last car had automatic sensors on the windshield so when it felt water the wipers went on. Does Jeep have this option?
Sgt.slaughter is offline   Quote Quick Reply
Old 02-07-2012, 06:56 AM   #7
kik
Jeeper
 
kik's Avatar
 
Join Date: Dec 2008
Posts: 4,078
Images: 1
Quote:
Originally Posted by Sgt.slaughter View Post
I know this sounds like I'm being a smart ass but was it raining or sprinkling? The reason I ask is my last car had automatic sensors on the windshield so when it felt water the wipers went on. Does Jeep have this option?
Not on a JK.
kik is offline   Quote Quick Reply
Old 02-07-2012, 06:57 AM   #8
kik
Jeeper
 
kik's Avatar
 
Join Date: Dec 2008
Posts: 4,078
Images: 1
Make sure it's not set on intermittent. If not, take it in.
kik is offline   Quote Quick Reply
Old 02-07-2012, 07:01 AM   #9
Jeeper
 
Sgt.slaughter's Avatar
 
Join Date: Sep 2011
Location: New York State
Posts: 278
Quote:
Originally Posted by kik

Not on a JK.
Cool thanks!

Ugh if it's not on intermittent I'd take it in that would annoy me.
Sgt.slaughter is offline   Quote Quick Reply
Old 02-08-2012, 12:35 AM   #10
Newb
 
Join Date: Feb 2012
Posts: 2
Actually I'm in a desert and it hasn't rained in the last 10 months! It's a peculair thing and the wipers generally go on when I turn the indicators on.
adisi is offline   Quote Quick Reply
Old 02-08-2012, 03:36 AM   #11
First Jeep: M38A1

WF Supporting Member
 
AZduck's Avatar
 
Join Date: Dec 2011
Location: Arizona
Posts: 366
Sounds like some sort of intermittent short. It should be throwing codes that your dealer can check out, and then replace something(s). If no codes, and the problem won't replicate in Park, then insist on a test drive by the Service Manager.
__________________

2012 JK Rubicon - 2011 FJC
AZduck is offline   Quote Quick Reply
Old 02-08-2012, 06:45 AM   #12
Jeeper
 
cozmo2312's Avatar
 
Join Date: Dec 2011
Location: Utah
Posts: 78
haven't gotten a solution yet because we haven't taken it in. we'll get around to it sooner or later, but as of now it's not a major failure or issue... it's almost humorous.

was just curious if anyone else was getting the same thing.
__________________
2011 Jeep Rubicon His
2012 jeep sport Hers
cozmo2312 is offline   Quote Quick Reply
Old 02-08-2012, 07:59 AM   #13
Jeeper
 
Join Date: Nov 2010
Posts: 773
Read all over, a lot of steering wheel/column issues are solved by hitting the horn. Depress the horn hard for a few seconds. Worth a noisy shot IMO.
positrak is offline   Quote Quick Reply
Old 06-04-2012, 09:35 AM   #14
Newb
 
Join Date: Mar 2012
Location: Perryville Missouri
Posts: 5
I'm sitting at the dealer right now hopeing they get it fixed bc we just got back from a trip and it was so annoying! I'll let you know what they come up with.
Terradb82 is offline   Quote Quick Reply
Old 06-11-2012, 11:00 PM   #15
Newb
 
Join Date: Mar 2012
Location: Perryville Missouri
Posts: 5
After waiting for two and a half hours. They told me they wouldn't know what it was unless it did it in the shop :-(. Please let me know if any of you get yours fixed bc it's driving me crazy
Terradb82 is offline   Quote Quick Reply
Old 06-11-2012, 11:20 PM   #16
Jeeper
 
RRTRI's Avatar
 
Join Date: Apr 2012
Location: Virginia
Posts: 578
Quote:
Originally Posted by Terradb82
After waiting for two and a half hours. They told me they wouldn't know what it was unless it did it in the shop :-(. Please let me know if any of you get yours fixed bc it's driving me crazy
Just had the wife's JKU in for this exact issue last week. They said they were able to reproduce it while there and replaced the integrated control module (I think that is what they called it). Appears to have fixed it as it hasn't happened since she got it back on Friday.
__________________
2012 JKU Sport Gecko 6sp/4.88/3" Teraflex/35's/Wet Okole/Teraflex Hinged TC/ACE RS FB RB/VIAIR OBA/Warn 9.5 CTI-s/Volant CAI/Various other cosmetic mods (Mine)
2012 JKU Sport Flame Red 6sp/4.88/3" Teraflex/35's/Wet Okole/Teraflex Hinged TC/ACE RS FB RB/VIAIR OBA/Warn 9.5 CTI-s/Various other cosmetic mods (Hers)
2014 Grand Cherokee SRT Redline 2-Coat Pearl Tow Group/HK Audio Group/Panoramic Sunroof/Satin Carbon W (Date Night Ride)
RRTRI is offline   Quote Quick Reply
Old 06-11-2012, 11:35 PM   #17
Jeeper
 
NY_Joe's Avatar
 
Join Date: Mar 2012
Posts: 116
Images: 2
I had a wiper mishap as well. A little different than what was stated.

I was cleaning the Jeep and my wife's Maxima and had the radio playing from the Jeep. After a good 30 mins I went back into the driver seat to start the Jeep and move it. Turned the key, engine turned over and my wipers started going. Check the stalk and they were off. They kept going no matter what I did.

I turned the Jeep on and off about 3 times. I finally realized that I had no dashboard lights or instrument cluster displays. After a few choice words I went to the engine bay and wiped down some dripped water on the fuse box cover and went and depressed every fuse. Make sure nothing was loose.

Went back to driver seat, turned the key and got more of the same. I was furious at this point b/c it was Sunday and this would piss me off all day now. Out of frustration I just started trying things. I turned the lights on from theleft stalk and all of a sudden my dashboard cluster came on and my wipers stopped.

Hasn't happened since and hoping it doesn't anytime soon.
NY_Joe is offline   Quote Quick Reply
Old 08-30-2012, 10:23 AM   #18
Newb
 
JeffreyScottModola's Avatar
 
Join Date: Aug 2012
Posts: 5
I have the same problem and will be bringing my 2012 Rubicon in next week. This morning I started the jeep and didn't touch any switches and the wipers turn on and made three passes, turn off and back on again for two more passes. I had a problem with my 2007 Jeep Liberty but wasn't the wipers. When I turned the blinker on, left or right, when I completed the turn and the blinker turned off, the headlights would flash off and on. This really bothered people coming the opposite direction, they thought I was flashing them for some reason.
JeffreyScottModola is offline   Quote Quick Reply
Old 08-30-2012, 12:29 PM   #19
Jeeper
 
klkb's Avatar
 
Join Date: Feb 2012
Location: Gainesville, Virginia
Posts: 2,976
Must be the season for this crap. I turned on my 2010 the other day and the wipers and headlights wouldn't turn off, and the turn signal wouldn't work. Someone suggested disconnecting the battery for a bit, and that worked. Good thing because I'm waiting right now to have it inspected...I didn't have a few hundred dollars for it to be fixed and have my tags die in the process!
klkb is offline   Quote Quick Reply
Old 08-30-2012, 02:38 PM   #20
Supporting Member

WF Supporting Member
 
Peter T's Avatar
 
Join Date: Jun 2012
Location: Hamilton Ontario Canada
Posts: 513
My 2012 has been doing the same thing. Every once in awhile they make one pass. Had it in to the dealer last week. Said they never heard of that. They flashed the computer. Drove off the lot and they made one swipe. So much for flashing the computer
Peter T is offline   Quote Quick Reply
Old 09-05-2012, 07:40 PM   #21
Newb
 
Join Date: Dec 2011
Location: Omaha, NE
Posts: 11
I have the same issue on my 2012 Sahara. I thought maybe I was bumping the stalk because it only happened very occasionally on left turns, but it happened several times on the interstate last weekend and I know I wasn't bumping anything. One time they went for 4 swipes and every other time 1. It has not done it since last weekend, though.

Glad to see I'm not the only one that has this issue. I will probably let it go unless it gets to the point it could be reproduced at the dealership.
markoware is offline   Quote Quick Reply
Old 09-06-2012, 12:25 AM   #22
Jeeper
 
scuba_steve's Avatar
 
Join Date: Aug 2011
Location: Northern VA
Posts: 674
Had the sane issue with Fog Lights in a TJ. Actually, that is a pretty common problem on a TJ. After awhile, the multifunction switch module in the steering column wears out...and you have to replace this to fix it:

http://www.oconeeoffroad.com/servlet/the-44978/Multi-Function-Switch-%28With/Detail

I grabbed mine off of eBay for 45 beans...ad the fix took about half an hour.

The wiper switch connects to the same module...on the other side...at least in a TJ. I haven't taken apart my JK's steering column yet, but it might be a bad wiper switch. Again, I'm not sure what it would take to replace on a JK, but I could swap it in a TJ in about 15 minutes.
scuba_steve is offline   Quote Quick Reply
Old 09-06-2012, 01:39 AM   #23
Jeeper
 
BlackOpsJeep's Avatar
 
Join Date: Dec 2011
Location: Near Fort Stewart, GA
Posts: 595
Mine too and they replaced some module. My wipers just came on all by themselves without touching anything. Crazy!
__________________
“If freedom of speech is taken away, then dumb and silent we may be led, like sheep to the slaughter.”
― George Washington
BlackOpsJeep is offline   Quote Quick Reply
Old 09-07-2012, 07:26 AM   #24
Newb
 
JeffreyScottModola's Avatar
 
Join Date: Aug 2012
Posts: 5
Thanks for the posts. Yeah it's strange. I turned the left signal on last week to make a turn and the wipers stayed on for almost 5 minutes. I called the dealer and they said they never heard of the problem. Only afraid that it's going to burn out and when I need them they aren't going to work. I'm taking it in for an oil change soon and will ask about it again.
JeffreyScottModola is offline   Quote Quick Reply
Old 09-07-2012, 02:53 PM   #25
Supporting Member

WF Supporting Member
 
Peter T's Avatar
 
Join Date: Jun 2012
Location: Hamilton Ontario Canada
Posts: 513
Wife took ours in today because of the random wiper turning on by it self. Dealer said if they can't reproduce it. It didn't happen. Last time they flashed something and we drove it off lot and they turned on. Back to the drawing board.
Peter T is offline   Quote Quick Reply
Old 09-07-2012, 03:42 PM   #26
Jeeper
 
bumpus's Avatar
 
Join Date: Aug 2012
Location: CR, IA
Posts: 34
My 07 JKU has done that to me a couple times. Always on a right turn signal.
bumpus is offline   Quote Quick Reply
Old 09-07-2012, 04:04 PM   #27
Jeeper
 
Join Date: Sep 2012
Location: Central Texas
Posts: 54
On the personal settings for the computer (left side data display/menu), you can have the lights turn on when the wipers are on. That would say there is a tie in for the left side head lights and right side wipers and they go to the computer.

On the flip side a 2012 Dodge Charger I drive is set up a lot like the Jeep (steering wheel, engine, etc) and when the battery has issues the wipers tend to tell the story when they self activate.

Best of luck.
CavCop is offline   Quote Quick Reply
Old 09-28-2012, 06:36 PM   #28
Jeeper
 
bumpus's Avatar
 
Join Date: Aug 2012
Location: CR, IA
Posts: 34
This was getting annoying for me so I tried replacing the turn signal lever. On my 2007 JKU w/ Fogs it's p/n 68041485AB. Knock on wood, that appears to have fixed the problem. I turned on the right signal about 20 times without the wipers coming on at all. Before, it probably would have happened 3-4 times.

I was able to find the part online and get it shipped to me for about $35 total, so I'm in it for about 1/2 an hour of shop labor even if this doesn't fix the problem. Not a bad gamble.

Changing it was very easy. There's three T20 screws that hold the steering column trim on. All of the bottom. Remove those and then work the two halves apart carefully and wiggle them out of the dash. They do clip together lightly in a few spots and you need to work the bottom half a little on the right side to get around the key hole.

The multi-function switch comes off the steering column with 1 phillips hear screw. Then slide it out toward where the door would be if you didn't have a Jeep and unplug the two wiring harnesses.

Putting the new one on is just the same steps in reverse. Took probably 15 minutes total including getting my toolbox out and checking all the functions on the levers at the end.
bumpus is offline   Quote Quick Reply
Old 09-29-2012, 11:09 PM   #29
Newb
 
Join Date: Sep 2012
Posts: 3
I had the same issue with the wipers turning on. Dealership reflashed computer, just to have it happen the next day.


I found the ground post nut loose right in front of the battery on the engine compartment wall. The power was back feeding through the ground wires causing all kinds of issues.

Everyone needs to check their ground posts under the hood!
Blackshirts is offline   Quote Quick Reply
Old 10-08-2012, 06:17 PM   #30
Newb
 
Join Date: Oct 2012
Posts: 2
2012 Sahara and same problem (intermittent wipers going off by themselves). Took it into the dealer ... same results: Can't reproduce, no error codes, no fix.

I understand if you can't reproduce the problem, it's hard to fix, but having had other issues and poor service, I'm definitely skeptical/concerned about the future of my new Jeep, i.e., how much time will I have to spend in and out of the dealer?

Anyone have a sure way to reproduce the problem? My wipers come on about once per day, usually when I use the turn signal, but sometimes by itself. I've looked under the hood for loose ground wires, but all seems tightened down pretty well.

bohunlee is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Marker light Turn signal modification gluestick JK General Discussion Forum 140 01-12-2014 02:48 PM
2012 Jeep® Wrangler Rubicon Captures Four Wheeler of the Year Award WbnjTJ JK General Discussion Forum 18 02-03-2013 05:23 PM
2012 Jeep Wrangler test drive issue philipfreire JK General Discussion Forum 27 06-28-2012 09:55 PM
Turn Signal Issues notlaelyk TJ General Discussion Forum 9 07-25-2011 07:51 PM



» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 03:06 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC