2012 Wrangler usb ipod connectivity issue with 130 RES media center - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 11-24-2011, 05:57 PM   #1
Jeeper
 
radioscooter's Avatar
 
Join Date: Sep 2011
Location: Pittsburgh, PA
Posts: 130
2012 Wrangler usb ipod connectivity issue with 130 RES media center

First off, Happy Thanksgiving! This forum has been extremely helpful for me. I've never owned a JEEP before/ Just got my 2012 Unlim Sahara last Friday.

I have the 130 media center and the usb port in the center console box. I also have the Connectivity package.

First day, I plugged my ipod classic 120 gb into it and the jeep logo came up on the ipod and I think it tried to set up the device. But I had to disconnect prematurely. Came back and tried later and now upon connecting, the ipod shows a slightly different Jeep logo, reads only "connected. Ok to disconnect" and shows that it is charging.

But the controls on the ipod are frozen, nothig happens. Nothing plays. And when I press the "aux/disc" button on the radio it goes into "UCI: Reading" mode for a long time, then displays "Device Empty" No audio plays, etc.

I suspected that I messed something up by yanking it early on the first hookup, but I've tried the hard ipod reset tip a couple times, (once while connected to usb) with no luck.

My iPhone connected to uconnect beautifully first time and works great. I'd really like to get the ipod working right as well.

Is there a reset function, or what else am I doing wrong? It seems like it's "half connected" but it's not working at all.

thanks for any help. This forum is awesome.

radioscooter is offline   Quote Quick Reply
Old 11-24-2011, 06:20 PM   #2
Jeeper

WF Supporting Member
 
stroh's Avatar
 
Join Date: Aug 2011
Location: Oviedo, Florida
Posts: 137
I don't have the manual in front of me but I believe you can list and delete devices in the setup menu. See if you can delete the ipod from the radio and start over from the begining?

__________________
2012 DOZER JKJP72 24G ERB DGJ PY5 APA *PL -XV MX3 AAJ HAB AHT DME 4EA

10/12/2011 Ordered, Thanks Pat@Fields Jeep!
10/31/2011 Built
11/07/2011 Plant Release
11/22/2011 Delivered!!! Thanks Fields Chrysler Jeep Dodge Ram of Florida!!!!
stroh is offline   Quote Quick Reply
Old 11-24-2011, 09:47 PM   #3
Jeeper
 
Tispco's Avatar
 
Join Date: Oct 2011
Posts: 24
Subscribing. I have the exact same setup in my 2012 and it does not seem to be working. I am hoping it is just user error.
Tispco is offline   Quote Quick Reply
Old 11-25-2011, 08:22 AM   #4
Jeeper
 
j0nx's Avatar
 
Join Date: Jun 2011
Location: NoVa
Posts: 848
disconnect the ipod and reset it by holding the center button and top arrow if i recall. Then when it resets you can plug the ipod back into the USB center console.
__________________
Natural Green 2012 JKU Sport with S Package | Freedom Top | Auto | Side Steps | Max Tow | Connectivity | Remote Start
j0nx is offline   Quote Quick Reply
Old 11-25-2011, 09:43 AM   #5
Jeeper
 
radioscooter's Avatar
 
Join Date: Sep 2011
Location: Pittsburgh, PA
Posts: 130
Quote:
Originally Posted by j0nx View Post
disconnect the ipod and reset it by holding the center button and top arrow if i recall. Then when it resets you can plug the ipod back into the USB center console.

Thanks, but I've done that a few times now with no luck.

I'm going to try a couple of the other ideas here, but is there a support/tech number to call about the media center radios, other than local dealers?
radioscooter is offline   Quote Quick Reply
Old 11-26-2011, 08:31 AM   #6
Jeeper

WF Supporting Member
 
Iron Maiden's Avatar
 
Join Date: Mar 2010
Location: Maine
Posts: 120
Plug the iPod into the latest version of iTunes and update the firmware. Then do a factory reset of the iPod on iTunes. Then reload your music. Plug into the USB. Don't unplug. It will work after a bit.
__________________
2012 JK Sport S, Bright Silver Metallic Clear Coat, Auto, Freedom Top, Deep Tint Sunscreen Glass, Connectivity Group, Infinity, SiriusXM

- Ordered 9/10, D status 9/14, D1 status 9/15, I status 9/26, KZ status 9/28, delivery 10/11
Iron Maiden is offline   Quote Quick Reply
Old 11-26-2011, 08:20 PM   #7
Jeeper
 
radioscooter's Avatar
 
Join Date: Sep 2011
Location: Pittsburgh, PA
Posts: 130
I'm fairly adept at iPod updates, but I seem to be lacking in seeing any discernible difference in updating "software version" and "firmware". Other than "check for updates" on both iTunes and iPod, how can I determine and/or update my firmware version? it looks as if all is current?


Thanks.
__________________
2012 JKU Sahara: White on white, and nearly perfect.
dual top, connectivity, 130, 6 sp. manual

radioscooter is offline   Quote Quick Reply
Old 11-26-2011, 08:29 PM   #8
Jeeper

WF Supporting Member
 
Iron Maiden's Avatar
 
Join Date: Mar 2010
Location: Maine
Posts: 120
Update the iTunes version first and then firmware from iTunes. iTunes should prompt you if the iPod firmware is out of date. Then make sure to reset then iPod to factory default from within iTunes and finally re-sync your music.
__________________
2012 JK Sport S, Bright Silver Metallic Clear Coat, Auto, Freedom Top, Deep Tint Sunscreen Glass, Connectivity Group, Infinity, SiriusXM

- Ordered 9/10, D status 9/14, D1 status 9/15, I status 9/26, KZ status 9/28, delivery 10/11
Iron Maiden is offline   Quote Quick Reply
Old 11-27-2011, 04:10 PM   #9
Jeeper
 
radioscooter's Avatar
 
Join Date: Sep 2011
Location: Pittsburgh, PA
Posts: 130
Okay, restored from Apple. All updates in place. All up to date. re-synced library from scratch.

Plugged into Jeep - same issue. Jeep logo. USC "Reading" , eventually - "Device Empty" Nada. Anywhere I can call for support on this?
__________________
2012 JKU Sahara: White on white, and nearly perfect.
dual top, connectivity, 130, 6 sp. manual

radioscooter is offline   Quote Quick Reply
Old 11-27-2011, 04:49 PM   #10
Jeeper

WF Supporting Member
 
Iron Maiden's Avatar
 
Join Date: Mar 2010
Location: Maine
Posts: 120
Nope, there is no phone support

What model iPod do you have and what is the mfg date and firmware version?
__________________
2012 JK Sport S, Bright Silver Metallic Clear Coat, Auto, Freedom Top, Deep Tint Sunscreen Glass, Connectivity Group, Infinity, SiriusXM

- Ordered 9/10, D status 9/14, D1 status 9/15, I status 9/26, KZ status 9/28, delivery 10/11
Iron Maiden is offline   Quote Quick Reply
Old 11-27-2011, 05:28 PM   #11
Jeeper
 
radioscooter's Avatar
 
Join Date: Sep 2011
Location: Pittsburgh, PA
Posts: 130
Quote:
Originally Posted by Iron Maiden View Post
Nope, there is no phone support

What model iPod do you have and what is the mfg date and firmware version?

Ipod Classic 120GB
2008
Firmware Version 2.01PC
__________________
2012 JKU Sahara: White on white, and nearly perfect.
dual top, connectivity, 130, 6 sp. manual

radioscooter is offline   Quote Quick Reply
Old 11-27-2011, 06:28 PM   #12
Jeeper

WF Supporting Member
 
Iron Maiden's Avatar
 
Join Date: Mar 2010
Location: Maine
Posts: 120
Maybe an incompatibility with that older model. UConnect has problems with many devices that work flawlessly on other vehicle Bluetooth implementations. My iPhone 4 streams audio via Bluetooth without on issue on my wife's Hyundai and on several others I've tried. Terrible static on the Wrangler. UConnect issue.

If you have access to another ipod or iPhone try it in your Jeep. That may give you an idea if there is an overall problem with your UConnect module or if it is just your iPod.
__________________
2012 JK Sport S, Bright Silver Metallic Clear Coat, Auto, Freedom Top, Deep Tint Sunscreen Glass, Connectivity Group, Infinity, SiriusXM

- Ordered 9/10, D status 9/14, D1 status 9/15, I status 9/26, KZ status 9/28, delivery 10/11
Iron Maiden is offline   Quote Quick Reply
Old 11-27-2011, 06:46 PM   #13
Jeeper
 
radioscooter's Avatar
 
Join Date: Sep 2011
Location: Pittsburgh, PA
Posts: 130
Quote:
Originally Posted by Iron Maiden View Post
Maybe an incompatibility with that older model. UConnect has problems with many devices that work flawlessly on other vehicle Bluetooth implementations. My iPhone 4 streams audio via Bluetooth without on issue on my wife's Hyundai and on several others I've tried. Terrible static on the Wrangler. UConnect issue.

If you have access to another ipod or iPhone try it in your Jeep. That may give you an idea if there is an overall problem with your UConnect module or if it is just your iPod.
I was under the impression that the USB hardwired option wasn't necessarily a Uconnect connection, because it's not really a Bluetooth thing. No?

To clarify, my iPhone 4S has paired perfectly and flawlessly to the BT/Uconnect system and will stream audio without issue.

However, I don't use my phone for music, and would prefer to just leave an iPod connected in the glovebox. Especially considering that it charges when plugged in.

I don't want to buy another flashdrive. The iPod is just a glorified hardrive and a database, and it's my preferred method of portable music. I understand that there are often compatibility issues with Apple products. I'm not a traditional Apple Kool-Aid drinking cheerleader. I'm a PC user. I just prefer the iPod for my music. And the Media 130 system is intended for usb/mp3 player connection. And I'd like it to work right. If it's a few resets, software updates and a couple other hurdles - that's fine. I'd rather keep at it to get it working rather than list alternative ways around it.

I'll try my son's newer Nano to see if it's a device issue vs. the system. I'm not beyond buying a new iPod to make this work. But my music collection is too large for any of the Touch units and they're discontinuing the Classics, so...
__________________
2012 JKU Sahara: White on white, and nearly perfect.
dual top, connectivity, 130, 6 sp. manual

radioscooter is offline   Quote Quick Reply
Old 11-27-2011, 08:09 PM   #14
Jeeper
 
m0wens's Avatar
 
Join Date: Sep 2011
Posts: 132
Just an fyi, I have a similar setup but use the older 80 ipod video which I believe is older than your classic and it works fine so I don't think it's an issue with the age of your ipod. I am curious to see if my very first ipod, I can't remember the model but it's white with the green LCD will work in the Jeep.
__________________
2012 Jeep Wrangler Unlimited 4x4 Rubicon
Black | Remote Start | Connectivity Group | Max Tow|
3pc Freedom Hardtop | 5sp Auto | 4:10
m0wens is offline   Quote Quick Reply
Old 11-27-2011, 11:38 PM   #15
Jeeper
 
Mr. Chewbacca's Avatar
 
Join Date: Nov 2011
Posts: 16
Quote:
Originally Posted by stroh View Post
I don't have the manual in front of me but I believe you can list and delete devices in the setup menu. See if you can delete the ipod from the radio and start over from the begining?
I tried to find the full manual but I think the first suggestion was the best one. I think the issue is with the radio and not the iPod especually since you did a full restore with iTunes.

I couldn't find a detailed instruction manual for the radio but I would first try finding a device list in the setup menu and delete the iPod if listed.

If not try a reset to factory settings:

1) press and hold the phone icon

2) After the Ready prompt, and the following beep say "Uconnect Setup", then "Reset".

This will delete all phone pairing, phone book entries, and other settings in all language modes. The System will prompt you before resetting to factory settings.

Kinda sucks because you will have to re-pair the iPhone 4s. If that doesn't work let me know... I love a good tech project

In the future.... never ever disconect anything during a set up :face palm: It will cause a lot of headaches.
Mr. Chewbacca is offline   Quote Quick Reply
Old 11-28-2011, 08:38 AM   #16
Jeeper
 
Join Date: Apr 2011
Posts: 1,737
have you tried a different iPod cable? I have seen a bad cable cause the information packets to be scrambled.
xsdbs is offline   Quote Quick Reply
Old 11-28-2011, 09:15 AM   #17
Jeeper

WF Supporting Member
 
Iron Maiden's Avatar
 
Join Date: Mar 2010
Location: Maine
Posts: 120
The iPod information is read by the Uconnect Module and then sent to the radio over the High Speed CAN BUS. So it is possible it is a UConnect issue.
__________________
2012 JK Sport S, Bright Silver Metallic Clear Coat, Auto, Freedom Top, Deep Tint Sunscreen Glass, Connectivity Group, Infinity, SiriusXM

- Ordered 9/10, D status 9/14, D1 status 9/15, I status 9/26, KZ status 9/28, delivery 10/11
Iron Maiden is offline   Quote Quick Reply
Old 11-28-2011, 11:49 AM   #18
Jeeper
 
radioscooter's Avatar
 
Join Date: Sep 2011
Location: Pittsburgh, PA
Posts: 130
Quote:
Originally Posted by Mr. Chewbacca View Post
I tried to find the full manual but I think the first suggestion was the best one. I think the issue is with the radio and not the iPod especually since you did a full restore with iTunes.

I couldn't find a detailed instruction manual for the radio but I would first try finding a device list in the setup menu and delete the iPod if listed.

If not try a reset to factory settings:

1) press and hold the phone icon

2) After the Ready prompt, and the following beep say "Uconnect Setup", then "Reset".

This will delete all phone pairing, phone book entries, and other settings in all language modes. The System will prompt you before resetting to factory settings.

Kinda sucks because you will have to re-pair the iPhone 4s. If that doesn't work let me know... I love a good tech project

In the future.... never ever disconect anything during a set up :face palm: It will cause a lot of headaches.
Great advice, thank you. I successfully reset the 130 RES unit. And then this gets even more interesting. After the reset, I tried the same way to hook up my iPod with the same (non) results.

However, then I attempted to hook up:
  • My son's iPod nano (newest gen)
  • My wife's 30gb OLD "classic" (from way before they were called "classics")
  • My brother-in-law's 160 Classic (also older than mine)
These are all of varying vintages and capacities. Only the Nano has anything remotely like updated firmware. They ALL connected and played music fine. Albeit the one with the most data on it took the longest to "read" but it too eventually was fine. Mine spends the same amount of time attempting to be "read", the Jeep logo still comes up the same way, the ipod is charging and yet - it eventually fails. I left it hooked up for 30 minutes just in case it was due to the large amount of files I have on there.

I am laughing now (instead of crying) because this must mean there's a settings or disc error or some issue with MY iPod Classic. Going back to do a complete factory restore on the device, and uncheck some content, adding it in later a playlist at a time.

So:
  • Not the cable
  • Not the firmware
  • Not the Uconnect (probably)
  • Not the compatibility
That leaves:
  • A setting issue
  • A capacity issue
  • A disc error issue with the specific iPod in question.
  • Something else I'm missing?
Will report back after I try to troubleshoot the iPod again.

Thanks for the help.
__________________
2012 JKU Sahara: White on white, and nearly perfect.
dual top, connectivity, 130, 6 sp. manual

radioscooter is offline   Quote Quick Reply
Old 11-28-2011, 04:14 PM   #19
Jeeper
 
radioscooter's Avatar
 
Join Date: Sep 2011
Location: Pittsburgh, PA
Posts: 130
UPDATE: Success! I did another complete restore, and trimmed off a ton of files (for now) and re-synced. It took a while to read, but this time it worked just like the other iPods I tried! Now I just need to find out how to get it to play Playlists instead of always just starting to play all the songs from "A" on!

Thanks a ton to you guys for all the help.
__________________
2012 JKU Sahara: White on white, and nearly perfect.
dual top, connectivity, 130, 6 sp. manual

radioscooter is offline   Quote Quick Reply
Old 11-28-2011, 05:53 PM   #20
Jeeper

WF Supporting Member
 
Iron Maiden's Avatar
 
Join Date: Mar 2010
Location: Maine
Posts: 120
There are a couple ways to do but just hit the voice control button on the steering wheel. Then say "Play Playlist" and the name of the playlist you want to hear.
__________________
2012 JK Sport S, Bright Silver Metallic Clear Coat, Auto, Freedom Top, Deep Tint Sunscreen Glass, Connectivity Group, Infinity, SiriusXM

- Ordered 9/10, D status 9/14, D1 status 9/15, I status 9/26, KZ status 9/28, delivery 10/11
Iron Maiden is offline   Quote Quick Reply
Old 11-29-2011, 08:19 AM   #21
Jeeper
 
Join Date: Apr 2011
Posts: 1,737
wow, that wording looks familiar to me. Anyway, it's not a Uconnect issue. Uconnect sends the audio file data to the radio on what song is currently playing, who the artist is, the name of the album etc. It does not sent the complete content of the Ipod to the radio, the content is read and stored in Uconnect. If the data does not get to Uconnect properly then Uconnect will send an error message across the HS CAN BUS line for the radio to display an error message.


Quote:
Originally Posted by Iron Maiden View Post
The iPod information is read by the Uconnect Module and then sent to the radio over the High Speed CAN BUS. So it is possible it is a UConnect issue.
xsdbs is offline   Quote Quick Reply
Old 11-29-2011, 08:32 AM   #22
Jeeper
 
Join Date: Apr 2011
Posts: 1,737
This is good news. I didn't mention the restore because I thought that you mentioned doing that already. I have seen a similar issue before and did the restore with great results. You may be able to put all of your content back on the Ipod now that it is working correctly. Do you have any files from other audio apps like media monkey? I have seen where people have downloaded from media monkey and copied them to I tunes which caused some issues with Uconnect.

List Or Browse Mode
During Play mode, pressing any of the buttons described
below, will bring up List mode. List mode enables
scrolling through the list of menus and tracks on the
audio device.
TUNE control knob: The TUNE control knob functions
in a similar manner as the scroll wheel on the or
external USB device.
Turning it clockwise (forward) and counterclockwise
(backward) scrolls through the lists, displaying
the track detail on the radio display. Once the track
to be played is highlighted on the radio display,
press the TUNE control knob to select and start
playing the track. Turning the TUNE control knob
fast will scroll through the list faster. During fast
scroll, a slight delay in updating the information on
the radio display may be noticeable.
During all List modes, the iPod displays all lists in
“wrap-around” mode. So if the track is at the
bottom of the list, just turn the wheel backwards
(counter-clockwise) to get to the track faster.
In List mode, the radio PRESET buttons are used as
shortcuts to the following lists on the iPod or
external USB device.
Preset 1 – Playlists
Preset 2 – Artists
Preset 3 – Albums
Preset 4 – Genres
Preset 5 – Audiobooks




Quote:
Originally Posted by radioscooter View Post
UPDATE: Success! I did another complete restore, and trimmed off a ton of files (for now) and re-synced. It took a while to read, but this time it worked just like the other iPods I tried! Now I just need to find out how to get it to play Playlists instead of always just starting to play all the songs from "A" on!

Thanks a ton to you guys for all the help.
xsdbs is offline   Quote Quick Reply
Old 11-30-2011, 05:34 AM   #23
Jeeper
 
radioscooter's Avatar
 
Join Date: Sep 2011
Location: Pittsburgh, PA
Posts: 130
Thanks. This is all a great help.
__________________
2012 JKU Sahara: White on white, and nearly perfect.
dual top, connectivity, 130, 6 sp. manual

radioscooter is offline   Quote Quick Reply
Old 11-30-2011, 02:20 PM   #24
Jeeper
 
Join Date: Apr 2011
Posts: 1,737
you're welcome

Quote:
Originally Posted by radioscooter View Post
Thanks. This is all a great help.

xsdbs is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2012 Wrangler & June 2nd ndrugby JK General Discussion Forum 13670 03-11-2013 11:15 AM
Planning to lease 2012 Wrangler - need opinion. Sammzway JK General Discussion Forum 10 07-29-2011 06:53 PM
2012 Wrangler Spy Shots fdelle JK General Discussion Forum 5 07-29-2011 03:16 PM



» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 07:37 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC