A/C cutting off - Page 8 - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 07-29-2013, 01:54 AM   #211
Jeeper
 
Lusus_Naturae's Avatar
 
Join Date: Oct 2012
Location: OKC, missing WI
Posts: 2,099
Anybody feel like posting your Jeeps born on date? It's located on the door sticker. Just a thought, it may be occurring on a certain batch.

I have experienced a few A/C cut outs from the fan blower. It quit doing it after it got really warm, so a loose connection that swelled in the heat is possible I guess.

I had the HVAC unit replaced once before this occurred with the new unit. The original HVAC unit was replaced because it was switching the vent setting after I turned the engine off. Upon start it would blow out vents it wasn't set to.

MDH - 092922 (Saturday night at 10pm) - MDH is on the right side of the label

(Look for the "MDH" heading on the label and make note of the six-digit code following the heading. This code is the two-digit month, two-digit day and two-digit hour (in 24-hour format) that your vehicle was manufactured.

Read more: How to Find the Date of Assembly on a Dodge Ram Truck | eHow)

__________________
2013 JKU Sport, billet, auto, 3.73, LSD, 315/75/16 Duratracs on MB 72, 10A springs, Bushwacker flatties

Sold - 2005 TJ, red, auto, 3.73, 33" Duratracs, 4" lift
Ice storm casualty in 2007 - 2003 TJ, green, auto, 3.73, 33" Duratracs, 4" lift
Lusus_Naturae is offline   Quote Quick Reply
Old 07-29-2013, 08:58 AM   #212
Build Thread Queen

WF Supporting Member
::WF Moderator::
 
StarBrite's Avatar
 
Join Date: Jun 2013
Location: Austin, Texas
Posts: 8,097
Quote:
Originally Posted by Lusus_Naturae View Post
Post 204 and 205 - Well, that makes it an issue for both the auto temps and the manual temp HVAC units then.

I have noticed it does it less if I leave the A/C on all the time. I used to turn the A/C off when I parked, and then turn off the Jeep. When starting up, I would turn the Jeep on, let the fan start, and then push the A/C button. Now, I leave it on all the time and it hasn't had an issue in weeks, aside from the A/C clutch kicking hard twice when I started the Jeep - bothersome, but not worries yet.
We leave our AC on all the time and have manual AC and just started having this problem within the last two weeks at about 12,000 miles.

We also have a Billet 2013.

StarBrite is offline   Quote Quick Reply
Old 07-29-2013, 06:53 PM   #213
Jeeper
 
PissAnt's Avatar
 
Join Date: Apr 2013
Posts: 228
Not sure this makes a difference but here goes...

My 2002 Ford Escape would do this rarely
My 2008 Nissan Titan would do this rarely
My fiances 2002 Chevrolet Camaro would do this occasionally
My fiances 2006 Jeep Grand Cherokee would do this rarely
My 2009 Jeep Wrangler Unlimited has never done it in 60,000 miles

Apparently its not only a Jeep Wrangler issue...
PissAnt is offline   Quote Quick Reply
Old 08-01-2013, 03:12 AM   #214
Jeeper
 
Join Date: Jun 2012
Posts: 78
Add another 2013 JKUR

There are threads on the following forums with the EXACT same issue:
wranglerforum
jkowners
jeepforum
jk-forum

Its got to be a SW problem. And its not normal. If you have fan on a manual setting, thats where it should stay.

I just cant believe this number of people having the issue and no one has had a resolution yet.

There's got to be a way to lodge complaints without all of us taking trips to the dealer?
diggler86 is offline   Quote Quick Reply
Old 08-01-2013, 06:25 AM   #215
THW
Jeeper
 
THW's Avatar
 
Join Date: Jun 2012
Location: Litchfield Hills area, Connecticut
Posts: 780
Quote:
Originally Posted by diggler86 View Post
Add another 2013 JKUR

There are threads on the following forums with the EXACT same issue:
wranglerforum
jkowners
jeepforum
jk-forum

Its got to be a SW problem. And its not normal. If you have fan on a manual setting, thats where it should stay.

I just cant believe this number of people having the issue and no one has had a resolution yet.

There's got to be a way to lodge complaints without all of us taking trips to the dealer?
I think the reason there's no resolution is that it hasn't actually caused anyone any harm. It's just mildly annoying.
__________________
2013 Sport S Unlimited, Black
THW is offline   Quote Quick Reply
Old 08-01-2013, 08:22 AM   #216
Supporting Member

WF Supporting Member
 
m998dna's Avatar
 
Join Date: Jan 2012
Posts: 2,688
My 1991 Cherokee started doing this at 150K miles - fixed it after sevaral attempts.

A friend told me his 2012 JkU started doing this.. the dealer installed a resistor but the condition continues. I guess Chrysler is too busy partying and enjoying their newfound wealth to address the defects they've engineered into their new vehicles.

I hope my new 2013 doesn't start this behavior.

.
__________________
2013 Wrangler JKUR10A 3.6L DOHC - MDH 032515
:: 2002 Chevrolet G3500 LWB 8.1L - motovan
:: 1991 Cherokee Laredo 4.0L HO - resto in-process
:: 2010 Cherokee SRT8 6.1L Hemi - sold
:: 1965 Plymouth Sedan 562ci Hemi - sold
m998dna is online now   Quote Quick Reply
Old 08-01-2013, 11:41 PM   #217
Jeeper
 
introsystems's Avatar
 
Join Date: Jul 2012
Location: Victoria
Posts: 44
A/C cutting off

I have been to the dealer 5 times for this problem. This time i'm not letting them not fix it. they ran their so called "diagnostics" and apparently something shows up on the code reader. They wouldn't tell me what it was though. When I asked what diagnostics they are doing they wouldn't tell me. At first they told me it was all my "Electronic" upgrades that are causing the issue, but after arguing with the manager at length for 40 minutes they will continue to look for the problem. I personally think from all my research its the TIPM but they won't change it unless its the last thing on the sheet. When I recommended they call STAR the manager freaked out telling me their techs are highly trained and if I don't quit asking all the questions they want me to go elsewhere. Will see they say they are going to switch out the switch board but still waiting for the parts to come it. Will keep you guys posted.
introsystems is offline   Quote Quick Reply
Old 08-02-2013, 03:40 AM   #218
Jeeper
 
Lusus_Naturae's Avatar
 
Join Date: Oct 2012
Location: OKC, missing WI
Posts: 2,099
It almost has to be software related. Either that, or hardware is failing and they don't have a solution for it. Not that they have a solution for the software either.

It's a low priority repair since it's not hurting anyone. I bet most people don't even know the fresh air intake door is opening to the recirculate position because they never look behind the glovebox while it's on. I probably wouldn't have noticed, except for seeing the Youtube on it and getting curious then.

My dealer will put in a Star request, but I have to keep taking it to them to update the findings, which is nothing - there is no update, just a waste of my time. If I knew they would actually find something or had something new to try - that wouldn't screw up other things with the Jeep, then I might do it. They have two JKs on the lot that do it too, brand new ones, but they won't guinea pig those two for testing.
__________________
2013 JKU Sport, billet, auto, 3.73, LSD, 315/75/16 Duratracs on MB 72, 10A springs, Bushwacker flatties

Sold - 2005 TJ, red, auto, 3.73, 33" Duratracs, 4" lift
Ice storm casualty in 2007 - 2003 TJ, green, auto, 3.73, 33" Duratracs, 4" lift
Lusus_Naturae is offline   Quote Quick Reply
Old 08-02-2013, 06:05 AM   #219
Jeeper
 
Kevin M.'s Avatar
 
Join Date: Nov 2012
Posts: 33
Both my 2013 JKUs do it from time to time...
Kevin M. is offline   Quote Quick Reply
Old 08-12-2013, 03:49 PM   #220
Newb
 
Join Date: Aug 2013
Posts: 6
Quote:
Originally Posted by introsystems View Post
I have been to the dealer 5 times for this problem. This time i'm not letting them not fix it. they ran their so called "diagnostics" and apparently something shows up on the code reader. They wouldn't tell me what it was though. When I asked what diagnostics they are doing they wouldn't tell me. At first they told me it was all my "Electronic" upgrades that are causing the issue, but after arguing with the manager at length for 40 minutes they will continue to look for the problem. I personally think from all my research its the TIPM but they won't change it unless its the last thing on the sheet. When I recommended they call STAR the manager freaked out telling me their techs are highly trained and if I don't quit asking all the questions they want me to go elsewhere. Will see they say they are going to switch out the switch board but still waiting for the parts to come it. Will keep you guys posted.
1st off, I am new to the forums and was looking for a fix to this myself for my 4 dr 2012 Sahara model.

I can't say for sure but I going to bet that they are bs you on this error code. Don't believe them. Take a look yourself, you don't even need a OBD2 scanner because the jeeps got on board ones build into them so the techs can be more lazy.

Put your key in, turn it to ACC then to ON (NOTE: NOT MOTOR ON!!!, just the on position before you start the motor). Then turn it back to off. Then repeat, and then do it again but this time leave it in the ON position. If you can do this in less then 3 seconds, you will see where your odometer go like this: ------- then it will display any error codes from OBD2. If it display --DONE-- then there are no codes.

Now AC is not to much of an issue for me as I only get a few months of summer on this rock. But when I do, I want to stay cool.

So have any of you checked the temp reading at the time of cut off for your blower. I have come to find that mine will cut off for about 3 - 4 seconds when ever the temp reader hit 24 C or about 75 F. And it just like clock work.
Elochai is offline   Quote Quick Reply
Old 08-12-2013, 07:20 PM   #221
Jeeper
 
joeymon1's Avatar
 
Join Date: Jul 2012
Location: Southern Tier NYS
Posts: 42
My 2013 has done it 2 or 3 times this summer so far. doesn't seem to be a pattern as to when it happened
joeymon1 is offline   Quote Quick Reply
Old 08-12-2013, 07:41 PM   #222
Jeeper
 
Join Date: Dec 2010
Posts: 2,583
Add my 2013 JKUR to the list ...
i82much is offline   Quote Quick Reply
Old 08-12-2013, 09:28 PM   #223
Jeeper
 
flipmeover's Avatar
 
Join Date: Mar 2013
Location: Orlando, FL
Posts: 219
I've had this problem on my 2013 too and took it to two different dealers. Both looked at me surprised and had never heard of such a problem.

After inspection, the second claimed it was an auto defrost feature that the unit used to keep the coils from icing over. Not quite sure how a 3 second pause once a week will de-ice the evaporator, but hey, problem solved!
__________________
Normal people believe that if it ain't broke, don't fix it. Engineers believe that if it ain't broke, it doesn't have enough features yet.
- Scott Adams
flipmeover is offline   Quote Quick Reply
Old 08-13-2013, 07:52 PM   #224
Newb
 
Join Date: Aug 2013
Posts: 6
I going to try and get it on video before the snow hits next month; so I can take it to the dealer here and show them.

I know one thing, I hate dealing with the dealer in this town. They don't want to help you ever !

My 2012 was bought from a friend who owns a used car dealership. He knew I was in the market for a JEEP Wrangler 4 Door Black and had convinced my fiancé (now ex, love the jeep more :P) that we need one. A man bought the JEEP just only 4 months ago brand new and came to find out he couldn't pay the bill for it. So I got a good deal on a Jeep in the color and model I wanted (Sahara 4 Door Black) with leather seats and 18" rims.

So went to the Jeep dealer and got a sales man on the floor and asked him where I would go to get the warranty switched over to my name.

He looked at me and said, you didn't buy your jeep from us so you don't got any warranty.

In which I replied; It's only 4 months old, it got 3 years full coverage pal. and 5 year PT.

He replied, well you need to talk to .... (A woman) and have her transfer your name onto the warranty.

So I said, ok where can I find her?

Him: She not here today, she wont be back either till next week, so you can call and make an appointment.

Me: Ok what the number.

Him: I don't know, look it up.

Me: Whatever

So I got back to work just in time, went to my office and got the number from the phone book. Called and asked to make an appointment with this girl to have the coverage transferred in my name. Person on the phone who I do know as he works in the service department goes, appointment ?, you don't need an appointment, just come in and go to her office and do it, she here till 5:00.

Yeah That burned me then, I said to him, I was told she wasn't in and wasn't going to be in for a week.

My friend goes, don't know who told you that crap.

Now to make this story better, I went to this woman and had the warranty put in my name. I was telling her the ordeal I had when I came in and she goes, well your covered but if anything happens we wont be giving you a car to drive when your jeep is in the shop because you didn't buy it from us. We won't even do that if you bought it new from another dodge dealer.

^ So this service I got has made me think that my money is better used at the dealer in the town 1 hour away from here when I go to buy a new car.

No matter what I will be going jeep, you can't beat this thing. If she still running when I want a new car, I will keep her and get a challenger (If still made) for my highway fun. If she giving me trouble, I will just have to get another Jeep because I can't live without one now, Not here in Newfoundland. Rain. Snow, some of the worst roads in Canada, and loads of rocky cliffs. Yeah Jeep Wrangler all the way, it a dream come true for any Jeep owner to just get to drive home on roads so bad during winter which is almost every month but 3 or 4 here that beat the crap out of all the cars in front of you lol.

Elochai is offline   Quote Quick Reply
Old 08-22-2013, 06:39 PM   #225
Newb
 
Join Date: Aug 2013
Posts: 6
Ok guys, I got a video of this doing the issue.

jeep ac issue - YouTube

AC on full blast and the temp outside is reading 23 C. 8 seconds into the video the temp reading for outside goes to 24 C. Just like clock work, the blower in the jeep dies for a few seconds. As I grab the camera around 13 and 14 seconds into the video, you can hear the blower cutting back in and the AC resumes as if nothing happened.
This happens every time the temp monitor for the outside temps goes from 23 to 24 C. I don't know why it does this for manual AC but it is not normal.
Elochai is offline   Quote Quick Reply
Old 08-22-2013, 08:25 PM   #226
Jeeper
 
JE01's Avatar
 
Join Date: Apr 2013
Posts: 620
Quote:
Originally Posted by Elochai View Post
Ok guys, I got a video of this doing the issue.

jeep ac issue - YouTube

AC on full blast and the temp outside is reading 23 C. 8 seconds into the video the temp reading for outside goes to 24 C. Just like clock work, the blower in the jeep dies for a few seconds. As I grab the camera around 13 and 14 seconds into the video, you can hear the blower cutting back in and the AC resumes as if nothing happened.
This happens every time the temp monitor for the outside temps goes from 23 to 24 C. I don't know why it does this for manual AC but it is not normal.
Wow, the fact that you can reproduce that particular issue is a mile stone...haha
JE01 is offline   Quote Quick Reply
Old 08-22-2013, 09:26 PM   #227
Jeeper
 
Gkarshens's Avatar
 
Join Date: Jul 2012
Location: Austin, TX
Posts: 294
Images: 16
My 2012 JKU sport has been doing this since I got it. I took it to the dealer and they could not repeat it and "checked" the system out and could find nothing wrong. They also acted like they had never heard of it. I find that hard to believe after seeing so many others with the same issue. It isn't a huge deal for me since I run top-off most of the time, but knowing my luck the AC will completely go out right after the warranty expires.
Gkarshens is offline   Quote Quick Reply
Old 08-22-2013, 11:08 PM   #228
Newb
 
Join Date: Aug 2013
Posts: 6
Quote:
Originally Posted by Gkarshens View Post
My 2012 JKU sport has been doing this since I got it. I took it to the dealer and they could not repeat it and "checked" the system out and could find nothing wrong. They also acted like they had never heard of it. I find that hard to believe after seeing so many others with the same issue. It isn't a huge deal for me since I run top-off most of the time, but knowing my luck the AC will completely go out right after the warranty expires.
I'm not to sure, I think if more people looked at it more closely. I would bet that the issue is similar to mine that I posted above.

Once it hits a temp on the monitor going upward, the blower cuts out. I have check for obd2 error codes and got nothing. I believe that this computer related in someway as there no other reason that it would cut out each and every time the temp reader for the outside temp goes from 23 to 24 C
Elochai is offline   Quote Quick Reply
Old 08-22-2013, 11:34 PM   #229
Jeeper
 
Join Date: Jul 2013
Posts: 199
My 2013 Rubi has done this a couple of time since I bought it with 300 miles on it about a month ago. I was at the dealer for something and mentioned it, he said he never heard of this problem. Said to make an appointment and they would look into it.
__________________
2013 Rubicon.
Gary04Z06 is offline   Quote Quick Reply
Old 08-25-2013, 11:44 AM   #230
Jeeper
 
soberbyker's Avatar
 
Join Date: Feb 2013
Location: Southeastern,PA
Posts: 239
Just started happening to my 2013 Sahara Unlimited with Auto Temp. a few days ago. Seems like it turns off and a few seconds later turns back on. My Jeep was built on 01/11/13.
__________________


“Life is not a journey to the grave with intentions of arriving safely in a pretty well-preserved body, but rather to skid in broadside, thoroughly used up, totally worn out and loudly proclaiming ... WOW! What a ride!”
soberbyker is offline   Quote Quick Reply
Old 08-25-2013, 12:05 PM   #231
Jeeper
 
Jeepgal87's Avatar
 
Join Date: Jun 2013
Posts: 20
I had to have the computer in my jeep replaced within the first week of having him! Check engine light on the second day of driving and the dealership told me they have had multiple issues with the computers used in the 2013 models. So far so good (fingers crossed).
Jeepgal87 is offline   Quote Quick Reply
Old 08-25-2013, 12:38 PM   #232
Jeeper
 
Chamberstaff's Avatar
 
Join Date: Nov 2012
Posts: 28
Bought my 2013 Sahara in Nov. and it has done this 3 times since spring,
Chamberstaff is offline   Quote Quick Reply
Old 08-25-2013, 09:36 PM   #233
Jeeper
 
Lusus_Naturae's Avatar
 
Join Date: Oct 2012
Location: OKC, missing WI
Posts: 2,099
After not having this issue for a long time, I had it - and I may have something here. I have been running the A/C on the coldest temp setting and on the highest fan setting.

Last week I was out for a long time, and actually got a bit cold. I turned the fan down two settings. Within a minute I had the fan cutoff. I was shocked since it hadn't done it in so long but I didn't connect it. I had it turned up again like normal for awhile, and then one night, I turned the fan setting down again to answer the phone. It did it again.

Can anybody else give this a try - turn the A/C to the coldest, the fan to the highest, and then turn the Jeep on and let it run? Especially someone whose been having issues. I would like to know if the issue goes away with it set like this.

I set mine back like this again and I hasn't had an issue since.
__________________
2013 JKU Sport, billet, auto, 3.73, LSD, 315/75/16 Duratracs on MB 72, 10A springs, Bushwacker flatties

Sold - 2005 TJ, red, auto, 3.73, 33" Duratracs, 4" lift
Ice storm casualty in 2007 - 2003 TJ, green, auto, 3.73, 33" Duratracs, 4" lift
Lusus_Naturae is offline   Quote Quick Reply
Old 09-02-2013, 07:12 PM   #234
Newb
 
Join Date: Mar 2013
Location: Lake Tawakoni
Posts: 11
I'm having the same issue...2013 JKU Sport, 15K miles,
2-3 second pause
within a couple of minutes
never in recirc
manual a/c
seems like I has always happened in 1/2 power and up speed.
I know about the delay when you start up however, on a couple of occasions it has come on right when I started the Jeep
temp and humidity has varied

my service guy said it had to do with it having to recycle "from top to bottom" but then he also was talking about the starting delay so I don't really know what he meant lol

I also had the issue of it not starting on occasion, with no fix found,

now I found there is a recall but no parts available, the dealership said they have not even issued part numbers yet so they don't even know what to order....

My Bluetooth feature acts like it's possessed.

Also have started noticing a ticking noise when I first start for about 10-15 seconds...gonna have to start searching the forums for the Pentastar tick to see if this is the same.

This is my first Jeep and am really disappointed in the issues so far. For those saying it's not a big deal - I bought it brand new. It should work like it's brand new or they should be able to fix it for the money we are spending on it. If I don't say something and it's something they can fix or it is part of a bigger problem we don't know yet, I am doing a disservice to my fellow Jeep owners because we have already found out - they haven't heard of this problem. if we don't keep telling them, none of us will be able to get it fixed and they'll keep putting us off. I don't mind it having glitches if they can fix them but I don't want them to put me off like I'm crazy and the only one dealing with this.

This is the best part of these forums - finding others dealing with the same issues #strengthinnumbers!
ffbubba252 is offline   Quote Quick Reply
Old 09-02-2013, 07:14 PM   #235
Newb
 
Join Date: Mar 2013
Location: Lake Tawakoni
Posts: 11
*it not starting meaning the Jeep!
ffbubba252 is offline   Quote Quick Reply
Old 09-02-2013, 07:38 PM   #236
Jeeper
 
Captain Ed's Avatar
 
Join Date: Jun 2013
Location: Wisconsin
Posts: 616
Mine just did it the first time yesterday. 2013 2 door J/k Sport. Manual controls. 3100 miles and I bought it in June. A/C went off and the wife said what happened and it went back on. I said jeep gremlins and took the top down and didn't use it again.

Don't Jeep engineers own Jeeps or read these forums???? You would think one of the eggheads would have the issue and find a reason.
Captain Ed is offline   Quote Quick Reply
Old 09-02-2013, 08:16 PM   #237
Jeeper
 
New2012JEEP's Avatar
 
Join Date: Dec 2011
Location: NB, FL
Posts: 1,300
Alternator, or weak battery? Regardless of age those can be nuisances
__________________
2014 JKUS
OME 2" HD, MB 72 15's on 33" Goodyear DT's, Synergy Metal Grab Handles, ORO Center License Plate Bracket with LED Lights, Vector Offroad LPD, TrukLite Heads
New2012JEEP is offline   Quote Quick Reply
Old 09-09-2013, 09:01 PM   #238
Jeeper
 
flipmeover's Avatar
 
Join Date: Mar 2013
Location: Orlando, FL
Posts: 219
Quote:
Originally Posted by Elochai View Post
Ok guys, I got a video of this doing the issue.

jeep ac issue - YouTube

AC on full blast and the temp outside is reading 23 C. 8 seconds into the video the temp reading for outside goes to 24 C. Just like clock work, the blower in the jeep dies for a few seconds. As I grab the camera around 13 and 14 seconds into the video, you can hear the blower cutting back in and the AC resumes as if nothing happened.
This happens every time the temp monitor for the outside temps goes from 23 to 24 C. I don't know why it does this for manual AC but it is not normal.
I think Elochai may be on to something here.

I had the air cut out multiple times this week. I usually run my temp gauge in Fahrenheit, but each time it cut out I would quick switch to Celsius and the temp was at 24C.

There does seem to be some correlation to this value. Maybe something they're calculating from the sensor inputs is causing a divide by zero or stomping on ECU memory when the temp crosses this threshold. Anyone know a software engineer at Jeep...
__________________
Normal people believe that if it ain't broke, don't fix it. Engineers believe that if it ain't broke, it doesn't have enough features yet.
- Scott Adams
flipmeover is offline   Quote Quick Reply
Old 09-15-2013, 07:46 PM   #239
Jeeper
 
Lusus_Naturae's Avatar
 
Join Date: Oct 2012
Location: OKC, missing WI
Posts: 2,099
^ That's an interesting idea. It would fit into why I haven't seen many issues this summer, I have been over 80 most of the summer except for a few times. It's possible that last post I made was one of those times, since I normally wouldn't get so cold inside to turn down the A/C.

I should be able to test this out more as fall rolls in, we are just now seeing some relief.
__________________
2013 JKU Sport, billet, auto, 3.73, LSD, 315/75/16 Duratracs on MB 72, 10A springs, Bushwacker flatties

Sold - 2005 TJ, red, auto, 3.73, 33" Duratracs, 4" lift
Ice storm casualty in 2007 - 2003 TJ, green, auto, 3.73, 33" Duratracs, 4" lift
Lusus_Naturae is offline   Quote Quick Reply
Old 09-15-2013, 08:10 PM   #240
Jeeper
 
Lusus_Naturae's Avatar
 
Join Date: Oct 2012
Location: OKC, missing WI
Posts: 2,099
Quote:
Originally Posted by New2012JEEP View Post
Alternator, or weak battery? Regardless of age those can be nuisances
I also had a leaking battery I found a few weeks ago. I never had any power issues I knew of, I never even knew i had a battery issue. I have no idea if I has helped or anything, I haven't had the issue since, but it's way to early to say if it made a difference.

__________________
2013 JKU Sport, billet, auto, 3.73, LSD, 315/75/16 Duratracs on MB 72, 10A springs, Bushwacker flatties

Sold - 2005 TJ, red, auto, 3.73, 33" Duratracs, 4" lift
Ice storm casualty in 2007 - 2003 TJ, green, auto, 3.73, 33" Duratracs, 4" lift
Lusus_Naturae is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




» Featured Product

All times are GMT -5. The time now is 12:35 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC