A/C Indicator light does not work - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 04-18-2012, 09:38 PM   #1
Newb
 
Join Date: Jul 2011
Location: NC
Posts: 10
A/C Indicator light does not work

I have a 2010 JK. The A/C works great but the light on the A/C button does not work . I have tried replacing the switch panel , but problem still exists!

Peacekeeper820 is offline   Quote Quick Reply
Old 04-19-2012, 10:40 AM   #2
Jeeper
 
Roadhawg's Avatar
 
Join Date: Apr 2011
Location: OKC
Posts: 285
Take the top off and don't use the a/c

Roadhawg is offline   Quote Quick Reply
Old 04-21-2012, 07:08 AM   #3
Newb
 
Join Date: Jul 2011
Location: NC
Posts: 10
Smile

WOW! I would have never thought of taking the top off. How do you do that?
You are obliviously an engineer and highly intelligent, can you send me details instructions and possibly pics?

Thanks so much for solving my issue!
Peacekeeper820 is offline   Quote Quick Reply
Old 04-21-2012, 07:16 AM   #4
MARGARET, 10-14-51\6-1-12

WF Supporting Member
 
GREEN-MACHINE's Avatar
 
Join Date: Aug 2010
Location: PEOPLES REPUBLIC OF MASSACHUSETTS
Posts: 10,249
have you checked the ac system it self,, if you have low refrigerant , it may cause this issue,, i remember my chevy p\u did this,, ac worked but dash light would not go on,,, charged system and all was good. light on and ac worked even better.
__________________

life is too short to be taken seriously all the time,,,, go buy a MR.potato head and have some fun.
GREEN-MACHINE is offline   Quote Quick Reply
Old 04-22-2012, 06:48 AM   #5
Newb
 
Join Date: Jul 2011
Location: NC
Posts: 10
I will check, thanks.
Peacekeeper820 is offline   Quote Quick Reply
Old 06-02-2012, 08:23 PM   #6
Newb
 
Join Date: Jun 2012
Posts: 2
Fuse

Quote:
Originally Posted by Peacekeeper820 View Post
I have a 2010 JK. The A/C works great but the light on the A/C button does not work . I have tried replacing the switch panel , but problem still exists!
//
I have the same problem and i get it because i change the ignition fuse. Did you fixed now?
Ramiromdl is offline   Quote Quick Reply
Old 06-04-2012, 05:52 PM   #7
Newb
 
Join Date: Jun 2012
Posts: 2
i fix it is the red 10 amp fuse m34 /http://www.jeepforum.com/forum/f96/jeep-jk-fuse-box-map-layout-diagram-959526/

Ramiromdl is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 01:57 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC