ABS and TC lights - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 06-11-2013, 10:55 AM   #1
Jeeper
 
redbilly's Avatar
 
Join Date: Apr 2013
Location: Indianapolis, IN
Posts: 263
ABS and TC lights

Has anyone else had this happen? The last two times I have gone to play in the mud, after pressure washing the underbody there are no dash lights displaying any problems. Then the next morning my ABS and Traction Control lights illuminate. If I turn off the engine, wait a few seconds and then turn it back on, the lights go away and they don't come back on until I wheel it again. Is this just a bit of extra water clogging the sensors from the pressure washer or a reset after being cleaned?

It worked fine after I washed it for a trip to the grocery and only came on after sitting in the garage for ten hours. BTW it is a 2011 JK Sport, lifted with 33's. Not sure if that would make a difference or not.

redbilly is offline   Quote Quick Reply
Old 06-11-2013, 10:57 AM   #2
my jeep needs a lot...

WF Supporting Member
::WF Moderator::
 
tabber02's Avatar
 
Join Date: Nov 2010
Location: left coast, florida
Posts: 9,852
first question - is the steering wheel straight (with the wheels straight)?

__________________

-bob

2010 JK - Mountain Edition
i spend way too much money on it... that's all


Become a Supporting Member of the Wrangler Forum, upgrade your account today



tabber02 is offline   Quote Quick Reply
Old 06-11-2013, 11:17 AM   #3
Jag
Jeeper
 
Jag's Avatar
 
Join Date: Oct 2012
Posts: 318
If the steering is fine, I had the same issue and it ended up being a bad ABS/wheel speed sensor.

The dealer fixed it without any hassle.
Jag is offline   Quote Quick Reply
Old 06-11-2013, 09:15 PM   #4
Jeeper
 
redbilly's Avatar
 
Join Date: Apr 2013
Location: Indianapolis, IN
Posts: 263
Steering wheel is straight. I had a bad ABS sensor on my front passenger side a year ago and the ABS light came and stayed on all the time. This one only comes on once after pressure washing. I started my Jeep a few times today at work. The light never came on. Weird.
redbilly is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Rates
Get low rates on auto insurance in Canada!

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 12:35 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC